summaryrefslogtreecommitdiff
path: root/sci-libs/rocSOLVER/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /sci-libs/rocSOLVER/files
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'sci-libs/rocSOLVER/files')
-rw-r--r--sci-libs/rocSOLVER/files/rocSOLVER-4.2.0-add-stdint-header.patch12
-rw-r--r--sci-libs/rocSOLVER/files/rocSOLVER-4.3.0-link-blas.patch21
2 files changed, 33 insertions, 0 deletions
diff --git a/sci-libs/rocSOLVER/files/rocSOLVER-4.2.0-add-stdint-header.patch b/sci-libs/rocSOLVER/files/rocSOLVER-4.2.0-add-stdint-header.patch
new file mode 100644
index 000000000000..4afff8f467ea
--- /dev/null
+++ b/sci-libs/rocSOLVER/files/rocSOLVER-4.2.0-add-stdint-header.patch
@@ -0,0 +1,12 @@
+fix compilation error rocsolver-extra-types.h:11:9: error: unknown type name 'uint32_t'
+--- a/library/include/rocsolver-extra-types.h
++++ b/library/include/rocsolver-extra-types.h
+@@ -5,6 +5,8 @@
+ #ifndef ROCSOLVER_EXTRAS_H_
+ #define ROCSOLVER_EXTRAS_H_
+
++#include "stdint.h"
++
+ /*! \brief Used to specify the logging layer mode using a bitwise combination
+ *of rocblas_layer_mode values.
+ ********************************************************************************/
diff --git a/sci-libs/rocSOLVER/files/rocSOLVER-4.3.0-link-blas.patch b/sci-libs/rocSOLVER/files/rocSOLVER-4.3.0-link-blas.patch
new file mode 100644
index 000000000000..407582831142
--- /dev/null
+++ b/sci-libs/rocSOLVER/files/rocSOLVER-4.3.0-link-blas.patch
@@ -0,0 +1,21 @@
+Should link blas otherwise ld return error adding symbols: DSO missing from command line
+--- orig/clients/benchmarks/CMakeLists.txt
++++ rocSOLVER-rocm-4.3.0/clients/benchmarks/CMakeLists.txt
+@@ -17,6 +17,7 @@ target_include_directories( rocsolver-be
+ )
+
+ target_link_libraries( rocsolver-bench PRIVATE
++ blas
+ cblas
+ lapack
+ Threads::Threads
+--- orig/clients/gtest/CMakeLists.txt
++++ rocSOLVER-rocm-4.3.0/clients/gtest/CMakeLists.txt
+@@ -87,6 +87,7 @@ target_include_directories( rocsolver-te
+ )
+
+ target_link_libraries( rocsolver-test PRIVATE
++ blas
+ cblas
+ lapack
+ GTest::GTest