summaryrefslogtreecommitdiff
path: root/sci-libs/pytorch/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-23 01:00:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-23 01:00:42 +0000
commit6c169675dd21d25ad82ab0560f3d5b1e714219b6 (patch)
treeed786201c471d4535a5eca3a754866a856812bcb /sci-libs/pytorch/files
parent7fe6984499f95d52b3c32af6ab771aa8f08c2dd4 (diff)
gentoo auto-resync : 23:03:2024 - 01:00:42
Diffstat (limited to 'sci-libs/pytorch/files')
-rw-r--r--sci-libs/pytorch/files/0002-Don-t-build-libtorch-again-for-PyTorch-1.7.1.patch18
-rw-r--r--sci-libs/pytorch/files/pytorch-1.13.1-emptyso.patch15
-rw-r--r--sci-libs/pytorch/files/pytorch-1.13.1-global-dlopen.patch23
-rw-r--r--sci-libs/pytorch/files/pytorch-2.0.0-emptyso.patch15
4 files changed, 0 insertions, 71 deletions
diff --git a/sci-libs/pytorch/files/0002-Don-t-build-libtorch-again-for-PyTorch-1.7.1.patch b/sci-libs/pytorch/files/0002-Don-t-build-libtorch-again-for-PyTorch-1.7.1.patch
deleted file mode 100644
index 640d061fcc59..000000000000
--- a/sci-libs/pytorch/files/0002-Don-t-build-libtorch-again-for-PyTorch-1.7.1.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 2db381644c..2241a33015 100644
---- a/setup.py
-+++ b/setup.py
-@@ -363,13 +363,6 @@ def build_deps():
- check_submodules()
- check_pydep('yaml', 'pyyaml')
-
-- build_caffe2(version=version,
-- cmake_python_library=cmake_python_library,
-- build_python=True,
-- rerun_cmake=RERUN_CMAKE,
-- cmake_only=CMAKE_ONLY,
-- cmake=cmake)
--
- if CMAKE_ONLY:
- report('Finished running cmake. Run "ccmake build" or '
- '"cmake-gui build" to adjust build options and '
diff --git a/sci-libs/pytorch/files/pytorch-1.13.1-emptyso.patch b/sci-libs/pytorch/files/pytorch-1.13.1-emptyso.patch
deleted file mode 100644
index 1479354b7f7a..000000000000
--- a/sci-libs/pytorch/files/pytorch-1.13.1-emptyso.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/setup.py 2023-03-24 22:36:50.361860100 +0100
-+++ b/setup.py 2023-03-24 22:36:57.384752383 +0100
-@@ -922,12 +922,6 @@
- name=str('caffe2.python.caffe2_pybind11_state_hip'),
- sources=[]),
- )
-- if cmake_cache_vars['BUILD_FUNCTORCH']:
-- extensions.append(
-- Extension(
-- name=str('functorch._C'),
-- sources=[]),
-- )
-
- cmdclass = {
- 'bdist_wheel': wheel_concatenate,
diff --git a/sci-libs/pytorch/files/pytorch-1.13.1-global-dlopen.patch b/sci-libs/pytorch/files/pytorch-1.13.1-global-dlopen.patch
deleted file mode 100644
index 4f414be67a29..000000000000
--- a/sci-libs/pytorch/files/pytorch-1.13.1-global-dlopen.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Don't hardcode the library path. Leave it to the dynamic loader.
-
-Index: pytorch-1.13.1/torch/__init__.py
-===================================================================
---- a/torch/__init__.py 2023-02-15 20:27:51.747853677 +0100
-+++ b/torch/__init__.py 2023-02-15 20:28:23.506341918 +0100
-@@ -169,14 +169,14 @@
- lib_path = os.path.join(os.path.dirname(here), 'lib', lib_name)
-
- try:
-- ctypes.CDLL(lib_path, mode=ctypes.RTLD_GLOBAL)
-+ ctypes.CDLL(lib_name, mode=ctypes.RTLD_GLOBAL)
- except OSError as err:
- # Can only happen of wheel with cublas as PYPI deps
- # As PyTorch is not purelib, but nvidia-cublas-cu11 is
- if 'libcublas.so.11' not in err.args[0]:
- raise err
- _preload_cuda_deps()
-- ctypes.CDLL(lib_path, mode=ctypes.RTLD_GLOBAL)
-+ ctypes.CDLL(lib_name, mode=ctypes.RTLD_GLOBAL)
-
-
- if (USE_RTLD_GLOBAL_WITH_LIBTORCH or os.getenv('TORCH_USE_RTLD_GLOBAL')) and \
diff --git a/sci-libs/pytorch/files/pytorch-2.0.0-emptyso.patch b/sci-libs/pytorch/files/pytorch-2.0.0-emptyso.patch
deleted file mode 100644
index e4703894308a..000000000000
--- a/sci-libs/pytorch/files/pytorch-2.0.0-emptyso.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/setup.py 2023-04-05 11:23:00.713405789 +0200
-+++ b/setup.py 2023-04-05 11:23:36.900876249 +0200
-@@ -960,12 +960,6 @@
- name=str('caffe2.python.caffe2_pybind11_state_hip'),
- sources=[]),
- )
-- if cmake_cache_vars['BUILD_FUNCTORCH']:
-- extensions.append(
-- Extension(
-- name=str('functorch._C'),
-- sources=[]),
-- )
- if cmake_cache_vars['BUILD_NVFUSER']:
- extensions.append(
- Extension(