summaryrefslogtreecommitdiff
path: root/sci-libs/pyshp/pyshp-2.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-02 20:24:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-02 20:24:39 +0000
commit7a13078cb414752df1133d1767cc29260dc60fda (patch)
tree9e90a6f188f34228806cf884fc9733e53912a371 /sci-libs/pyshp/pyshp-2.3.1.ebuild
parent7e76f9a8d4e868d30c8bf1781655cc25574c80f8 (diff)
gentoo auto-resync : 02:01:2023 - 20:24:39
Diffstat (limited to 'sci-libs/pyshp/pyshp-2.3.1.ebuild')
-rw-r--r--sci-libs/pyshp/pyshp-2.3.1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sci-libs/pyshp/pyshp-2.3.1.ebuild b/sci-libs/pyshp/pyshp-2.3.1.ebuild
index af715dcb9263..dc041f721f8e 100644
--- a/sci-libs/pyshp/pyshp-2.3.1.ebuild
+++ b/sci-libs/pyshp/pyshp-2.3.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
-PYTHON_COMPAT=( python3_{7..11} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
DESCRIPTION="Pure Python read/write support for ESRI Shapefile format"
@@ -20,7 +20,8 @@ RESTRICT="!test? ( test )"
RDEPEND=""
DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
python_test() {
epytest test_shapefile.py -m "not network" || die