summaryrefslogtreecommitdiff
path: root/sci-libs/primegen/primegen-0.97-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
commit185fa19bbf68a4d4dca534d2b46729207a177f16 (patch)
treea8a537b82fda83a0799c2ca9887f212558363aa7 /sci-libs/primegen/primegen-0.97-r2.ebuild
parentc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (diff)
gentoo resync : 11.05.2021
Diffstat (limited to 'sci-libs/primegen/primegen-0.97-r2.ebuild')
-rw-r--r--sci-libs/primegen/primegen-0.97-r2.ebuild23
1 files changed, 13 insertions, 10 deletions
diff --git a/sci-libs/primegen/primegen-0.97-r2.ebuild b/sci-libs/primegen/primegen-0.97-r2.ebuild
index 72285f5925f0..0f2528bcf5d3 100644
--- a/sci-libs/primegen/primegen-0.97-r2.ebuild
+++ b/sci-libs/primegen/primegen-0.97-r2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
inherit flag-o-matic toolchain-funcs
DESCRIPTION="Small, fast library to generate primes in order"
@@ -11,17 +12,18 @@ SRC_URI="http://cr.yp.to/primegen/${P}.tar.gz"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux"
-IUSE=""
PATCHES=(
- "${FILESDIR}/${P}-man.patch"
- "${FILESDIR}/${P}-missing-headers.patch"
+ "${FILESDIR}"/${P}-man.patch
+ "${FILESDIR}"/${P}-missing-headers.patch
+ "${FILESDIR}"/${P}-respect-ar-ranlib.patch
)
src_prepare() {
default
- while IFS="" read -d $'\0' -r file
- do
+
+ local file
+ while IFS="" read -d $'\0' -r file; do
sed -i -e 's:\(primegen.a\):lib\1:' "${file}" || die
done < <(find . -type f -print0)
mkdir usr || die
@@ -30,9 +32,10 @@ src_prepare() {
src_configure() {
# Fixes bug #161015
append-flags -fsigned-char
- echo "$(tc-getCC) ${CFLAGS}" > conf-cc || die
+ echo "$(tc-getCC) ${CFLAGS} ${CPPFLAGS}" > conf-cc || die
echo "${S}/usr" > conf-home || die
echo "$(tc-getCC) ${LDFLAGS}" > conf-ld || die
+ tc-export AR RANLIB
}
src_test() {
@@ -48,7 +51,7 @@ src_install() {
-e "s/#include \"uint32.h\"/$(grep typedef uint32.h)/" \
-e "s/#include \"uint64.h\"/$(grep typedef uint64.h)/" \
primegen.h || die
- insinto /usr/include
- doins primegen.h
+
+ doheader primegen.h
dodoc BLURB CHANGES README TODO
}