summaryrefslogtreecommitdiff
path: root/sci-libs/pdal
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-13 01:41:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-13 01:41:21 +0100
commitb89a664f266dab3b9b5ddac2cb874f8869142370 (patch)
tree21d127b0b99c1505ba548bc05975b9fcecda871e /sci-libs/pdal
parent7e662ec84fc13cef513542e4030f47017d030187 (diff)
gentoo auto-resync : 13:10:2022 - 01:41:21
Diffstat (limited to 'sci-libs/pdal')
-rw-r--r--sci-libs/pdal/Manifest2
-rw-r--r--sci-libs/pdal/pdal-2.4.3.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/sci-libs/pdal/Manifest b/sci-libs/pdal/Manifest
index 1434b7aee95a..35d4e62d733b 100644
--- a/sci-libs/pdal/Manifest
+++ b/sci-libs/pdal/Manifest
@@ -1,3 +1,5 @@
DIST PDAL-2.4.0-src.tar.gz 113449697 BLAKE2B 8f774555d32ad4f0afe6dd850e6dcaf33b58c02934207ee2224230af762a7d3062a48909e267abf790a97a1d11788bb7543971c99239e5ae742d7945db09bda5 SHA512 655fadd2b435ed1cb801ba542028bcc15156da9266eedde93b2210dbadbc50d36b0b6a151062113f2adfb68a2938e2b867438a5a94952a7b3e46f59a53b47623
+DIST PDAL-2.4.3-src.tar.gz 100758279 BLAKE2B 7c157bb51416b24bd8896a62e71a186bc9a45b34d5ab58fadbe691cb1abc9595f598fcf92ec528c9103f646c21f940b26fbf199a998e707d17f1527eb2957a85 SHA512 ed342c29d10c0506e1c0f5ee4dba531189000dd0cc6912f681a95b7c56483d6136e515771a174e20906b1cd81dfd101d53be0cbaf200480d81d053d7dec8a386
EBUILD pdal-2.4.0-r1.ebuild 1148 BLAKE2B eb3adb6444f2b20ebdec16fb9557b0eacd1584ee241ec323e35f1bcd2948d9a2feb05a46b3deff0a8f6519df3cbdeb72dc19bfbb3a2d64d3c7bad6b946a6d053 SHA512 d355971c09429fcb34863fe4d367568a26e27d616193530890ae97b9940da4bb302f0d2b50c8c3387d1f1c4870c53dea0000ba4a6f8bda0dc600ad3e8582951c
+EBUILD pdal-2.4.3.ebuild 1149 BLAKE2B 963d7f66999dad32d633bc00c161a17c3b4ab609de94e9150e4976891d4f029d815b42c25169bf95789525ac236d6ad360e3b3d129bfded9044b931ea9c200c0 SHA512 05741614f3ac94fed4084798cb52b1784adb882dbfcd23c68e78734e503fd432d63bc071e6cfda4393d89d14d416b3ff73fd27e12d0a8f52810441d61ece15e4
MISC metadata.xml 799 BLAKE2B 44fff88edc36553687a49ecf5113b1f7f3c8d092e82ef4e45f0d96cf53cc619647f45b3d3439a5b98bf43a8965e1b80582e7b074489dcd69f6f3aad9e5c7f59a SHA512 da405bacd840b714fe274fa5ca658f7a51b0078054058dcce46f690b33e641579981739de9511f4a876ff0f88aec5c2dbaa59e4db035eb9a85bdd8e9725bc7c2
diff --git a/sci-libs/pdal/pdal-2.4.3.ebuild b/sci-libs/pdal/pdal-2.4.3.ebuild
new file mode 100644
index 000000000000..9bd82c4dc76e
--- /dev/null
+++ b/sci-libs/pdal/pdal-2.4.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A C++ library for translating and manipulating point cloud data"
+HOMEPAGE="https://pdal.io/"
+SRC_URI="https://github.com/PDAL/PDAL/releases/download/${PV}/PDAL-${PV}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/14"
+KEYWORDS="~amd64 ~x86"
+IUSE="postgres test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+RDEPEND="
+ net-misc/curl
+ app-arch/zstd:=
+ dev-libs/libxml2
+ dev-libs/openssl:=
+ sci-libs/gdal:=
+ sci-libs/libgeotiff:=
+ sys-libs/libunwind:=
+ sys-libs/zlib
+ postgres? ( dev-db/postgresql:*[xml] )
+"
+DEPEND="
+ test? ( sci-libs/gdal[geos,jpeg,png] )
+ ${RDEPEND}
+"
+
+S="${WORKDIR}/PDAL-${PV}-src"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_PLUGIN_PGPOINTCLOUD="$(usex postgres)"
+ -DWITH_COMPLETION=ON
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ local myctestargs=(
+ --exclude-regex '(pgpointcloudtest|pdal_io_bpf_base_test|pdal_io_bpf_zlib_test|pdal_filters_overlay_test|pdal_filters_stats_test|pdal_app_plugin_test|pdal_merge_test)'
+ --output-on-failure
+ )
+
+ cmake_src_test
+}