summaryrefslogtreecommitdiff
path: root/sci-libs/pcl/pcl-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-13 12:48:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-13 12:48:53 +0000
commit7c1ac01728d0156998ee45be74f80b378d96c31d (patch)
tree6634bea5058fa5133bb0227fd6f1da9aea4ca8f7 /sci-libs/pcl/pcl-9999.ebuild
parentb2d06fcf55b2f88efa183831072c7bca3f8e418b (diff)
gentoo auto-resync : 13:11:2022 - 12:48:53
Diffstat (limited to 'sci-libs/pcl/pcl-9999.ebuild')
-rw-r--r--sci-libs/pcl/pcl-9999.ebuild36
1 files changed, 30 insertions, 6 deletions
diff --git a/sci-libs/pcl/pcl-9999.ebuild b/sci-libs/pcl/pcl-9999.ebuild
index 1edbb0cd7140..a1c4d5880153 100644
--- a/sci-libs/pcl/pcl-9999.ebuild
+++ b/sci-libs/pcl/pcl-9999.ebuild
@@ -9,7 +9,7 @@ if [ "${PV#9999}" != "${PV}" ] ; then
EGIT_REPO_URI="https://github.com/PointCloudLibrary/pcl"
fi
-inherit ${SCM} cmake multilib
+inherit ${SCM} cmake cuda
if [ "${PV#9999}" != "${PV}" ] ; then
SRC_URI=""
@@ -24,7 +24,8 @@ DESCRIPTION="2D/3D image and point cloud processing"
LICENSE="BSD"
SLOT="0/1.12"
IUSE="cuda doc opengl openni openni2 pcap png +qhull qt5 usb vtk cpu_flags_x86_sse test tutorials"
-RESTRICT="!test? ( test )"
+# tests need the gtest sources to be available at build time
+RESTRICT="test"
RDEPEND="
>=sci-libs/flann-1.7.1
@@ -48,11 +49,17 @@ RDEPEND="
"
DEPEND="${RDEPEND}
!!dev-cpp/metslib
- test? ( >=dev-cpp/gtest-1.6.0 )
"
BDEPEND="
- doc? ( app-doc/doxygen )
- tutorials? ( dev-python/sphinx dev-python/sphinxcontrib-doxylink )
+ doc? (
+ app-doc/doxygen[dot]
+ virtual/latex-base
+ )
+ tutorials? (
+ dev-python/sphinx
+ dev-python/sphinx_rtd_theme
+ dev-python/sphinxcontrib-doxylink
+ )
virtual/pkgconfig"
REQUIRED_USE="
@@ -61,9 +68,25 @@ REQUIRED_USE="
tutorials? ( doc )
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.12.1-allow-configuration-of-install-dirs.patch
+ "${FILESDIR}"/${PN}-1.12.1-fix-hardcoded-relative-directory-of-the-installed-cmake-files.patch
+)
+
+src_prepare() {
+ if use cuda; then
+ cuda_src_prepare
+ cuda_add_sandbox -w
+ fi
+
+ cmake_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
+ "-DDOC_INSTALL_DIR=share/doc/${PF}"
"-DLIB_INSTALL_DIR=$(get_libdir)"
+ "-DPCLCONFIG_INSTALL_DIR=share/cmake/${PN}-$(ver_cut 1-2)"
"-DWITH_CUDA=$(usex cuda TRUE FALSE)"
"-DWITH_LIBUSB=$(usex usb TRUE FALSE)"
"-DWITH_OPENGL=$(usex opengl TRUE FALSE)"
@@ -77,7 +100,8 @@ src_configure() {
"-DPCL_ENABLE_SSE=$(usex cpu_flags_x86_sse TRUE FALSE)"
"-DWITH_DOCS=$(usex doc TRUE FALSE)"
"-DWITH_TUTORIALS=$(usex tutorials TRUE FALSE)"
- "-DBUILD_TESTS=$(usex test TRUE FALSE)"
+ "-DBUILD_global_tests=FALSE"
)
+
cmake_src_configure
}