summaryrefslogtreecommitdiff
path: root/sci-libs/opencascade/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-25 13:12:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-25 13:12:41 +0000
commit959575d1af06bc64016d62d064143faba68a4c43 (patch)
treefbab98e9b035f9f858937e73ff342c2df8e17beb /sci-libs/opencascade/files
parent14a74a5f982f25582974c2ee235027a041aec36d (diff)
gentoo auto-resync : 25:11:2022 - 13:12:41
Diffstat (limited to 'sci-libs/opencascade/files')
-rw-r--r--sci-libs/opencascade/files/opencascade-7.7.0-add-missing-include-limits.patch19
-rw-r--r--sci-libs/opencascade/files/opencascade-7.7.0-avoid-pre-stripping-binaries.patch34
-rw-r--r--sci-libs/opencascade/files/opencascade-7.7.0-fix-installation-of-cmake-config-files.patch33
3 files changed, 86 insertions, 0 deletions
diff --git a/sci-libs/opencascade/files/opencascade-7.7.0-add-missing-include-limits.patch b/sci-libs/opencascade/files/opencascade-7.7.0-add-missing-include-limits.patch
new file mode 100644
index 000000000000..2bc59319864a
--- /dev/null
+++ b/sci-libs/opencascade/files/opencascade-7.7.0-add-missing-include-limits.patch
@@ -0,0 +1,19 @@
+From 44a30819131496bf41f2e1dcfd362b23173db6fb Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl-gentoo@posteo.net>
+Date: Wed, 5 Oct 2022 21:55:06 +0200
+Subject: [PATCH] add missing #include <limits>
+
+Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
+--- a/src/ViewerTest/ViewerTest_CmdParser.cxx
++++ b/src/ViewerTest/ViewerTest_CmdParser.cxx
+@@ -21,6 +21,7 @@
+
+ #include <algorithm>
+ #include <iostream>
++#include <limits>
+
+ namespace
+ {
+--
+2.38.0
+
diff --git a/sci-libs/opencascade/files/opencascade-7.7.0-avoid-pre-stripping-binaries.patch b/sci-libs/opencascade/files/opencascade-7.7.0-avoid-pre-stripping-binaries.patch
new file mode 100644
index 000000000000..5c351cb32996
--- /dev/null
+++ b/sci-libs/opencascade/files/opencascade-7.7.0-avoid-pre-stripping-binaries.patch
@@ -0,0 +1,34 @@
+From e145fb627d199e888267e19eab951c69c2f8151c Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl-gentoo@posteo.net>
+Date: Sat, 8 Oct 2022 13:16:47 +0200
+Subject: [PATCH] avoid pre-stripping binaries
+
+Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
+--- a/adm/cmake/occt_defs_flags.cmake
++++ b/adm/cmake/occt_defs_flags.cmake
+@@ -135,22 +135,12 @@ if (CMAKE_CXX_COMPILER_ID MATCHES "[Cc][Ll][Aa][Nn][Gg]")
+ # CLang can be used with both libstdc++ and libc++, however on OS X libstdc++ is outdated.
+ set (CMAKE_CXX_FLAGS "-stdlib=libc++ ${CMAKE_CXX_FLAGS}")
+ endif()
+- # Optimize size of binaries
+- set (CMAKE_SHARED_LINKER_FLAGS "-Wl,-s ${CMAKE_SHARED_LINKER_FLAGS}")
+ elseif(MINGW)
+ add_definitions(-D_WIN32_WINNT=0x0601)
+ # _WIN32_WINNT=0x0601 (use Windows 7 SDK)
+ #set (CMAKE_SYSTEM_VERSION "6.1")
+ # workaround bugs in mingw with vtable export
+ set (CMAKE_SHARED_LINKER_FLAGS "-Wl,--export-all-symbols")
+-
+- # Optimize size of binaries
+- set (CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} -s")
+- set (CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -s")
+-elseif (DEFINED CMAKE_COMPILER_IS_GNUCXX)
+- # Optimize size of binaries
+- set (CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} -s")
+- set (CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -s")
+ endif()
+
+ if (BUILD_RELEASE_DISABLE_EXCEPTIONS)
+--
+2.38.0
+
diff --git a/sci-libs/opencascade/files/opencascade-7.7.0-fix-installation-of-cmake-config-files.patch b/sci-libs/opencascade/files/opencascade-7.7.0-fix-installation-of-cmake-config-files.patch
new file mode 100644
index 000000000000..924f002b727d
--- /dev/null
+++ b/sci-libs/opencascade/files/opencascade-7.7.0-fix-installation-of-cmake-config-files.patch
@@ -0,0 +1,33 @@
+From 4eb2236370134117729bc4d55191fce736bf4df6 Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl-gentoo@posteo.net>
+Date: Thu, 6 Oct 2022 18:53:41 +0200
+Subject: [PATCH] fix installation of cmake config files
+
+Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1265,7 +1265,7 @@ foreach (OCCT_CONFIGURATION ${CMAKE_CONFIGURATION_TYPES})
+ endforeach()
+ # install OpenCASCADE config file with compile definitions and C/C++ flags ONLY for current configuration
+ install (CODE "string (TOLOWER \"\${CMAKE_INSTALL_CONFIG_NAME}\" CMAKE_INSTALL_CONFIG_NAME_LOWER)")
+-install (CODE "file(INSTALL FILES \"${CMAKE_BINARY_DIR}/OpenCASCADECompileDefinitionsAndFlags-\${CMAKE_INSTALL_CONFIG_NAME_LOWER}.cmake\" DESTINATION \"${INSTALL_DIR}/${INSTALL_DIR_CMAKE}/\" TYPE FILE)")
++install (FILES "${CMAKE_BINARY_DIR}/OpenCASCADECompileDefinitionsAndFlags-\${CMAKE_INSTALL_CONFIG_NAME_LOWER}.cmake" DESTINATION "${INSTALL_DIR_CMAKE}")
+
+ foreach (OCCT_MODULE ${OCCT_MODULES})
+ if (BUILD_MODULE_${OCCT_MODULE})
+diff --git a/adm/cmake/occt_macros.cmake b/adm/cmake/occt_macros.cmake
+index 4a060665..8ab5e39c 100755
+--- a/adm/cmake/occt_macros.cmake
++++ b/adm/cmake/occt_macros.cmake
+@@ -590,7 +590,7 @@ macro (OCCT_UPDATE_TARGET_FILE)
+
+ install (CODE
+ "string (TOLOWER \"\${CMAKE_INSTALL_CONFIG_NAME}\" CMAKE_INSTALL_CONFIG_NAME_LOWERCASE)
+- file (GLOB ALL_OCCT_TARGET_FILES \"${INSTALL_DIR}/${INSTALL_DIR_CMAKE}/OpenCASCADE*Targets-\${CMAKE_INSTALL_CONFIG_NAME_LOWERCASE}.cmake\")
++ file (GLOB ALL_OCCT_TARGET_FILES \"${INSTALL_DIR_CMAKE}/OpenCASCADE*Targets-\${CMAKE_INSTALL_CONFIG_NAME_LOWERCASE}.cmake\")
+ foreach(TARGET_FILENAME \${ALL_OCCT_TARGET_FILES})
+ file (STRINGS \"\${TARGET_FILENAME}\" TARGET_FILE_CONTENT)
+ file (REMOVE \"\${TARGET_FILENAME}\")
+--
+2.38.0
+