summaryrefslogtreecommitdiff
path: root/sci-libs/opencascade/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/opencascade/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/opencascade/files')
-rw-r--r--sci-libs/opencascade/files/opencascade-6.5.4-fixed-tbb-VERSION.patch10
-rw-r--r--sci-libs/opencascade/files/opencascade-6.7.0-fixed-DESTDIR.patch51
-rw-r--r--sci-libs/opencascade/files/opencascade-6.7.1-deprecated-glx-api.patch89
-rw-r--r--sci-libs/opencascade/files/opencascade-6.8.0-fixed-DESTDIR.patch47
-rw-r--r--sci-libs/opencascade/files/opencascade-6.9.1-vtk-6.3.patch70
-rw-r--r--sci-libs/opencascade/files/opencascade-6.9.1-vtk-configure.patch13
6 files changed, 280 insertions, 0 deletions
diff --git a/sci-libs/opencascade/files/opencascade-6.5.4-fixed-tbb-VERSION.patch b/sci-libs/opencascade/files/opencascade-6.5.4-fixed-tbb-VERSION.patch
new file mode 100644
index 000000000000..88b13acd21c4
--- /dev/null
+++ b/sci-libs/opencascade/files/opencascade-6.5.4-fixed-tbb-VERSION.patch
@@ -0,0 +1,10 @@
+--- src/Standard/Standard_MMgrTBBalloc.cxx
++++ src/Standard/Standard_MMgrTBBalloc.cxx
+@@ -12,6 +12,7 @@
+
+ // paralleling with Intel TBB
+ #ifdef HAVE_TBB
++#undef VERSION
+ #include <tbb/scalable_allocator.h>
+ using namespace tbb;
+ #else
diff --git a/sci-libs/opencascade/files/opencascade-6.7.0-fixed-DESTDIR.patch b/sci-libs/opencascade/files/opencascade-6.7.0-fixed-DESTDIR.patch
new file mode 100644
index 000000000000..3a3f98093443
--- /dev/null
+++ b/sci-libs/opencascade/files/opencascade-6.7.0-fixed-DESTDIR.patch
@@ -0,0 +1,51 @@
+--- Makefile.am.old 2014-01-13 09:43:18.530500362 +0100
++++ Makefile.am 2014-01-13 09:45:40.430496833 +0100
+@@ -82,29 +82,29 @@
+ cd $(top_builddir)/adm/lin/amk && $(MAKE) $(AM_MAKEFLAGS) Draw
+
+ install-exec-local:
+- $(INSTALL) -d $(prefix)/$(platform)
+- if [ -e $(prefix)/bin -a ! -e $(prefix)/$(platform)/bin ]; then \
+- cd $(prefix)/$(platform) && ln -s ../bin bin; \
++ $(INSTALL) -d $(DESTDIR)$(prefix)/$(platform)
++ if [ -e $(DESTDIR)$(prefix)/bin -a ! -e $(DESTDIR)$(prefix)/$(platform)/bin ]; then \
++ cd $(DESTDIR)$(prefix)/$(platform) && ln -s ../bin bin; \
+ fi
+- if [ -e $(prefix)/lib -a ! -e $(prefix)/$(platform)/lib ]; then \
+- cd $(prefix)/$(platform) && ln -s ../lib lib; \
++ if [ -e $(DESTDIR)$(prefix)/lib -a ! -e $(DESTDIR)$(prefix)/$(platform)/lib ]; then \
++ cd $(DESTDIR)$(prefix)/$(platform) && ln -s ../lib lib; \
+ fi
+- buildd=`pwd`; cd $(top_srcdir); sourced=`pwd`; cd $(prefix); installd=`pwd`; cd $$buildd; \
++ buildd=`pwd`; cd $(top_srcdir); sourced=`pwd`; cd $(DESTDIR)$(prefix); installd=`pwd`; cd $$buildd; \
+ if [ "$$installd" != "$$sourced" ]; then \
+- $(INSTALL) -d $(prefix)/inc; \
+- cp -frL $(top_srcdir)/inc $(prefix); \
+- cp -frL $$buildd/config.h $(prefix); \
++ $(INSTALL) -d $(DESTDIR)$(prefix)/inc; \
++ cp -frL $(top_srcdir)/inc $(DESTDIR)$(prefix); \
++ cp -frL $$buildd/config.h $(DESTDIR)$(prefix); \
+ for d in $(FoundationClasses_DIRS) $(ModelingData_DIRS) $(ModelingAlgorithms_DIRS) $(Visualization_DIRS) $(ApplicationFramework_DIRS) $(DataExchange_DIRS) $(Draw_DIRS); do \
+- $(INSTALL) -d $(prefix)/src/$$d; \
+- cp -frL $(top_srcdir)/src/$$d $(prefix)/src; \
++ $(INSTALL) -d $(DESTDIR)$(prefix)/src/$$d; \
++ cp -frL $(top_srcdir)/src/$$d $(DESTDIR)$(prefix)/src; \
+ done; \
+ fi
+- if [ -e $(prefix)/inc/config.h ]; then \
+- rm -f $(prefix)/inc/config.h; \
++ if [ -e $(DESTDIR)$(prefix)/inc/config.h ]; then \
++ rm -f $(DESTDIR)$(prefix)/inc/config.h; \
+ fi
+- cd $(prefix)/inc && ln -s ../config.h config.h
+- cd $(top_srcdir) && cp draw.sh $(prefix)
+- cd $(top_srcdir) && cp custom.sh $(prefix)
+- cd $(top_srcdir) && cp env.sh $(prefix)
++ cd $(DESTDIR)$(prefix)/inc && ln -s ../config.h config.h
++ cd $(top_srcdir) && cp draw.sh $(DESTDIR)$(prefix)
++ cd $(top_srcdir) && cp custom.sh $(DESTDIR)$(prefix)
++ cd $(top_srcdir) && cp env.sh $(DESTDIR)$(prefix)
+
+-.PHONY: FoundationClasses ModelingData ModelingAlgorithms Visualization ApplicationFramework DataExchange Draw
+\ Brak znaku nowej linii na końcu pliku
++.PHONY: FoundationClasses ModelingData ModelingAlgorithms Visualization ApplicationFramework DataExchange Draw
diff --git a/sci-libs/opencascade/files/opencascade-6.7.1-deprecated-glx-api.patch b/sci-libs/opencascade/files/opencascade-6.7.1-deprecated-glx-api.patch
new file mode 100644
index 000000000000..b3c3629aada1
--- /dev/null
+++ b/sci-libs/opencascade/files/opencascade-6.7.1-deprecated-glx-api.patch
@@ -0,0 +1,89 @@
+From ba7e14489e14f08aae3e0f48b419b2149290b163 Mon Sep 17 00:00:00 2001
+From: Matthias Maier <tamiko@kyomu.43-1.org>
+Date: Tue, 23 Dec 2014 21:15:59 +0100
+Subject: [PATCH] Define GLX_GLXEXT_LEGACY prior to inclusion of GL/glx.h
+
+---
+ inc/InterfaceGraphic_X11.hxx | 1 +
+ samples/qt/Common/src/View.cxx | 1 +
+ src/InterfaceGraphic/InterfaceGraphic_X11.hxx | 1 +
+ src/OpenGl/OpenGl_Context.cxx | 1 +
+ src/OpenGl/OpenGl_Workspace_Raytrace.cxx | 1 +
+ src/Xw/Xw_Window.cxx | 1 +
+ 6 files changed, 6 insertions(+)
+
+diff --git a/inc/InterfaceGraphic_X11.hxx b/inc/InterfaceGraphic_X11.hxx
+index 280bb9b..98d7415 100755
+--- a/inc/InterfaceGraphic_X11.hxx
++++ b/inc/InterfaceGraphic_X11.hxx
+@@ -21,6 +21,7 @@
+ #include <X11/Xlib.h>
+ #include <X11/Xutil.h>
+ #include <X11/Xatom.h>
++#define GLX_GLXEXT_LEGACY
+ #include <GL/glx.h>
+
+ #if defined (sun) || defined (SUNOS) || defined (__alpha) || defined (DECOSF1) || defined (sgi) || defined (IRIX) || defined (__hpux)|| defined (HPUX)
+diff --git a/samples/qt/Common/src/View.cxx b/samples/qt/Common/src/View.cxx
+index 77f51b8..9b3f4e2 100755
+--- a/samples/qt/Common/src/View.cxx
++++ b/samples/qt/Common/src/View.cxx
+@@ -28,6 +28,7 @@
+ #include <Cocoa_Window.hxx>
+ #else
+ #include <QX11Info>
++#define GLX_GLXEXT_LEGACY
+ #include <GL/glx.h>
+ #include <X11/Xutil.h>
+ #include <X11/Xatom.h>
+diff --git a/src/InterfaceGraphic/InterfaceGraphic_X11.hxx b/src/InterfaceGraphic/InterfaceGraphic_X11.hxx
+index 280bb9b..98d7415 100755
+--- a/src/InterfaceGraphic/InterfaceGraphic_X11.hxx
++++ b/src/InterfaceGraphic/InterfaceGraphic_X11.hxx
+@@ -21,6 +21,7 @@
+ #include <X11/Xlib.h>
+ #include <X11/Xutil.h>
+ #include <X11/Xatom.h>
++#define GLX_GLXEXT_LEGACY
+ #include <GL/glx.h>
+
+ #if defined (sun) || defined (SUNOS) || defined (__alpha) || defined (DECOSF1) || defined (sgi) || defined (IRIX) || defined (__hpux)|| defined (HPUX)
+diff --git a/src/OpenGl/OpenGl_Context.cxx b/src/OpenGl/OpenGl_Context.cxx
+index 9e2f074..1ddf6a4 100755
+--- a/src/OpenGl/OpenGl_Context.cxx
++++ b/src/OpenGl/OpenGl_Context.cxx
+@@ -39,6 +39,7 @@
+ #elif defined(__APPLE__) && !defined(MACOSX_USE_GLX)
+ #include <dlfcn.h>
+ #else
++ #define GLX_GLXEXT_LEGACY
+ #include <GL/glx.h> // glXGetProcAddress()
+ #endif
+
+diff --git a/src/OpenGl/OpenGl_Workspace_Raytrace.cxx b/src/OpenGl/OpenGl_Workspace_Raytrace.cxx
+index f1b5afe..870eb7d 100755
+--- a/src/OpenGl/OpenGl_Workspace_Raytrace.cxx
++++ b/src/OpenGl/OpenGl_Workspace_Raytrace.cxx
+@@ -32,6 +32,7 @@
+ #elif defined(__APPLE__) && !defined(MACOSX_USE_GLX)
+ #include <OpenGL/CGLCurrent.h>
+ #else
++ #define GLX_GLXEXT_LEGACY
+ #include <GL/glx.h>
+ #endif
+
+diff --git a/src/Xw/Xw_Window.cxx b/src/Xw/Xw_Window.cxx
+index 5442365..0e80444 100755
+--- a/src/Xw/Xw_Window.cxx
++++ b/src/Xw/Xw_Window.cxx
+@@ -20,6 +20,7 @@
+ #include <Aspect_Convert.hxx>
+ #include <Aspect_WindowDefinitionError.hxx>
+
++#define GLX_GLXEXT_LEGACY
+ #include <GL/glx.h>
+
+ namespace
+--
+2.0.5
+
diff --git a/sci-libs/opencascade/files/opencascade-6.8.0-fixed-DESTDIR.patch b/sci-libs/opencascade/files/opencascade-6.8.0-fixed-DESTDIR.patch
new file mode 100644
index 000000000000..1f37eace7602
--- /dev/null
+++ b/sci-libs/opencascade/files/opencascade-6.8.0-fixed-DESTDIR.patch
@@ -0,0 +1,47 @@
+--- opencascade-6.8.0/Makefile.am
++++ opencascade-6.8.0/Makefile.am
+@@ -82,27 +82,27 @@
+ cd $(top_builddir)/adm/lin/amk && $(MAKE) $(AM_MAKEFLAGS) Draw
+
+ install-exec-local:
+- $(INSTALL) -d $(prefix)/$(platform)
+- if [ -e $(prefix)/bin -a ! -e $(prefix)/$(platform)/bin ]; then \
+- cd $(prefix)/$(platform) && ln -s ../bin bin; \
++ $(INSTALL) -d $(DESTDIR)$(prefix)/$(platform)
++ if [ -e $(DESTDIR)$(prefix)/bin -a ! -e $(DESTDIR)$(prefix)/$(platform)/bin ]; then \
++ cd $(DESTDIR)$(prefix)/$(platform) && ln -s ../bin bin; \
+ fi
+- if [ -e $(prefix)/lib -a ! -e $(prefix)/$(platform)/lib ]; then \
+- cd $(prefix)/$(platform) && ln -s ../lib lib; \
++ if [ -e $(DESTDIR)$(prefix)/lib -a ! -e $(DESTDIR)$(prefix)/$(platform)/lib ]; then \
++ cd $(DESTDIR)$(prefix)/$(platform) && ln -s ../lib lib; \
+ fi
+- buildd=`pwd`; cd $(top_srcdir); sourced=`pwd`; cd $(prefix); installd=`pwd`; cd $$buildd; \
++ buildd=`pwd`; cd $(top_srcdir); sourced=`pwd`; cd $(DESTDIR)$(prefix); installd=`pwd`; cd $$buildd; \
+ if [ "$$installd" != "$$sourced" ]; then \
+- $(INSTALL) -d $(prefix)/inc; \
+- cp -frL $(top_srcdir)/inc $(prefix); \
+- cp -frL $$buildd/config.h $(prefix); \
++ $(INSTALL) -d $(DESTDIR)$(prefix)/inc; \
++ cp -frL $(top_srcdir)/inc $(DESTDIR)$(prefix); \
++ cp -frL $$buildd/config.h $(DESTDIR)$(prefix); \
+ for d in $(FoundationClasses_DIRS) $(ModelingData_DIRS) $(ModelingAlgorithms_DIRS) $(Visualization_DIRS) $(ApplicationFramework_DIRS) $(DataExchange_DIRS) $(Draw_DIRS); do \
+- $(INSTALL) -d $(prefix)/src/$$d; \
+- cp -frL $(top_srcdir)/src/$$d $(prefix)/src; \
++ $(INSTALL) -d $(DESTDIR)$(prefix)/src/$$d; \
++ cp -frL $(top_srcdir)/src/$$d $(DESTDIR)$(prefix)/src; \
+ done; \
+ fi
+- if [ -e $(prefix)/inc/config.h ]; then \
+- rm -f $(prefix)/inc/config.h; \
++ if [ -e $(DESTDIR)$(prefix)/inc/config.h ]; then \
++ rm -f $(DESTDIR)$(prefix)/inc/config.h; \
+ fi
+- cd $(prefix)/inc && ln -s ../config.h config.h
+- cd $(top_srcdir) && cp *.sh $(prefix)
++ cd $(DESTDIR)$(prefix)/inc && ln -s ../config.h config.h
++ cd $(top_srcdir) && cp *.sh $(DESTDIR)$(prefix)
+
+-.PHONY: FoundationClasses ModelingData ModelingAlgorithms Visualization ApplicationFramework DataExchange Draw
+\ No newline at end of file
++.PHONY: FoundationClasses ModelingData ModelingAlgorithms Visualization ApplicationFramework DataExchange Draw
diff --git a/sci-libs/opencascade/files/opencascade-6.9.1-vtk-6.3.patch b/sci-libs/opencascade/files/opencascade-6.9.1-vtk-6.3.patch
new file mode 100644
index 000000000000..8e1d3361dde6
--- /dev/null
+++ b/sci-libs/opencascade/files/opencascade-6.9.1-vtk-6.3.patch
@@ -0,0 +1,70 @@
+--- opencascade-6.9.1/configure.ac
++++ opencascade-6.9.1/configure.ac
+@@ -1044,7 +1044,7 @@
+ fi
+ if test "x$vtk_lib" != "x"; then
+ CSF_VTK_LIB="-L$vtk_lib -lvtkCommonCore -lvtkCommonDataModel -lvtkCommonExecutionModel -lvtkCommonMath -lvtkCommonTransforms "
+- CSF_VTK_LIB="${CSF_VTK_LIB} -lvtkRenderingCore -lvtkRenderingOpenGL -lvtkFiltersGeneral -lvtkIOCore -lvtkIOImage -lvtkImagingCore -lvtkInteractionStyle "
++ CSF_VTK_LIB="${CSF_VTK_LIB} -lvtkRenderingCore -lvtkRenderingOpenGL2 -lvtkFiltersGeneral -lvtkIOCore -lvtkIOImage -lvtkImagingCore -lvtkInteractionStyle "
+ else
+ HAVE_VTK=no
+ fi
+--- opencascade-6.9.1/src/IVtkVTK/IVtkVTK_View.cxx
++++ opencascade-6.9.1/src/IVtkVTK/IVtkVTK_View.cxx
+@@ -151,7 +151,7 @@ bool IVtkVTK_View::DisplayToWorld (const gp_XY& theDisplayPnt, gp_XYZ& theWorldP
+ myRenderer->SetDisplayPoint (theDisplayPnt.X(), theDisplayPnt.Y(), 0.0);
+ myRenderer->DisplayToWorld();
+
+- vtkFloatingPointType* const aCoords = myRenderer->GetWorldPoint();
++ double* const aCoords = myRenderer->GetWorldPoint();
+ if (aCoords[3] == 0.0) // Point at infinity in homogeneous coordinates
+ {
+ return false;
+--- opencascade-6.9.1/src/IVtkTools/IVtkTools_ShapePicker.cxx
++++ opencascade-6.9.1/src/IVtkTools/IVtkTools_ShapePicker.cxx
+@@ -73,15 +73,15 @@ float IVtkTools_ShapePicker::GetTolerance( ) const
+ // Method: convertDisplayToWorld
+ // Purpose: Convert display coordinates to world coordinates
+ //============================================================================
+-bool IVtkTools_ShapePicker::convertDisplayToWorld (vtkRenderer *theRenderer,
+- vtkFloatingPointType theDisplayCoord[3],
+- vtkFloatingPointType theWorldCoord[3])
++bool IVtkTools_ShapePicker::convertDisplayToWorld (vtkRenderer *theRenderer,
++ double theDisplayCoord[3],
++ double theWorldCoord[3])
+ {
+ // Convert the selection point into world coordinates.
+ theRenderer->SetDisplayPoint (theDisplayCoord[0], theDisplayCoord[1], theDisplayCoord[2]);
+ theRenderer->DisplayToWorld();
+
+- vtkFloatingPointType* const aCoords = theRenderer->GetWorldPoint();
++ double* const aCoords = theRenderer->GetWorldPoint();
+ if (aCoords[3] == 0.0)
+ {
+ return false;
+--- opencascade-6.9.1/src/IVtkTools/IVtkTools_ShapePicker.hxx
++++ opencascade-6.9.1/src/IVtkTools/IVtkTools_ShapePicker.hxx
+@@ -124,8 +124,8 @@ protected:
+
+ //! Convert display coordinates to world coordinates
+ static bool convertDisplayToWorld (vtkRenderer *theRenderer,
+- vtkFloatingPointType theDisplayCoord[3],
+- vtkFloatingPointType theWorldCoord[3] );
++ double theDisplayCoord[3],
++ double theWorldCoord[3] );
+
+ private: // not copyable
+ IVtkTools_ShapePicker (const IVtkTools_ShapePicker&);
+--- opencascade-6.9.1/inc/IVtkTools_ShapePicker.hxx
++++ opencascade-6.9.1/inc/IVtkTools_ShapePicker.hxx
+@@ -124,8 +124,8 @@
+
+ //! Convert display coordinates to world coordinates
+ static bool convertDisplayToWorld (vtkRenderer *theRenderer,
+- vtkFloatingPointType theDisplayCoord[3],
+- vtkFloatingPointType theWorldCoord[3] );
++ double theDisplayCoord[3],
++ double theWorldCoord[3] );
+
+ private: // not copyable
+ IVtkTools_ShapePicker (const IVtkTools_ShapePicker&);
diff --git a/sci-libs/opencascade/files/opencascade-6.9.1-vtk-configure.patch b/sci-libs/opencascade/files/opencascade-6.9.1-vtk-configure.patch
new file mode 100644
index 000000000000..3c2711d3813e
--- /dev/null
+++ b/sci-libs/opencascade/files/opencascade-6.9.1-vtk-configure.patch
@@ -0,0 +1,13 @@
+--- opencascade-6.9.1/configure.ac
++++ opencascade-6.9.1/configure.ac
+@@ -1043,8 +1043,8 @@
+ HAVE_VTK=no
+ fi
+ if test "x$vtk_lib" != "x"; then
+- CSF_VTK_LIB="-L$vtk_lib -lvtkCommonCore-6.1 -lvtkCommonDataModel-6.1 -lvtkCommonExecutionModel-6.1 -lvtkCommonMath-6.1 -lvtkCommonTransforms-6.1 "
+- CSF_VTK_LIB="${CSF_VTK_LIB} -lvtkRenderingCore-6.1 -lvtkRenderingOpenGL-6.1 -lvtkFiltersGeneral-6.1 -lvtkIOCore-6.1 -lvtkIOImage-6.1 -lvtkImagingCore-6.1 -lvtkInteractionStyle-6.1 "
++ CSF_VTK_LIB="-L$vtk_lib -lvtkCommonCore -lvtkCommonDataModel -lvtkCommonExecutionModel -lvtkCommonMath -lvtkCommonTransforms "
++ CSF_VTK_LIB="${CSF_VTK_LIB} -lvtkRenderingCore -lvtkRenderingOpenGL -lvtkFiltersGeneral -lvtkIOCore -lvtkIOImage -lvtkImagingCore -lvtkInteractionStyle "
+ else
+ HAVE_VTK=no
+ fi