summaryrefslogtreecommitdiff
path: root/sci-libs/onnx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sci-libs/onnx
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sci-libs/onnx')
-rw-r--r--sci-libs/onnx/Manifest3
-rw-r--r--sci-libs/onnx/metadata.xml11
-rw-r--r--sci-libs/onnx/onnx-1.11.0-r1.ebuild40
3 files changed, 54 insertions, 0 deletions
diff --git a/sci-libs/onnx/Manifest b/sci-libs/onnx/Manifest
new file mode 100644
index 000000000000..562499923ccd
--- /dev/null
+++ b/sci-libs/onnx/Manifest
@@ -0,0 +1,3 @@
+DIST onnx-1.11.0.tar.gz 9464979 BLAKE2B dfc8ab81d4776f806fa26c751c1eb1e19ea4cf9f0aa498880dc18eca160fdd9c43eda0077124ea7a674082e5ed93de7497411c48c3f9a12146905072e6477af6 SHA512 dc7045702188d7f40fead3ab6eccd8ff63357824c36873b415ad989d19aa952ff2c3758120de9050d84d92a35993198971be54ffa8e8d99fc70aa1b14b2ff73e
+EBUILD onnx-1.11.0-r1.ebuild 812 BLAKE2B 235e44d0b93832979e8adb23cf14a4e024a35985a768ea714545e550e71c87a84f9f46febfbd96ab3b48964f1043623d61eb91880b4db7cc4ddaf0eadc428da0 SHA512 eab613583b0a53e91003863bab53dfd01177ff121d29b6037b91866be1ae6dfcfa33910b5948b17e94b9a917fd7d284a6fdf0bce8e4fc46046a873f380f9b7c9
+MISC metadata.xml 322 BLAKE2B a78b6feffba2cf354154448a0e0cef5e866ec51ff0158939e7a5be1f3c4cb9bb3b29ae88ae06540627946fc3e0f6e9a63ef4d8951385e840a7a87ada99e1d50a SHA512 9d81e8e43822232c8c8cf690b6bdb9939f04adeb9230f8225a5b0b10083f9555304768901c46cc5d29c41038397bbb3b12e0111c3d0443f4c0003e99b99fc50f
diff --git a/sci-libs/onnx/metadata.xml b/sci-libs/onnx/metadata.xml
new file mode 100644
index 000000000000..2a58de7a87a9
--- /dev/null
+++ b/sci-libs/onnx/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">onnx/onnx</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-libs/onnx/onnx-1.11.0-r1.ebuild b/sci-libs/onnx/onnx-1.11.0-r1.ebuild
new file mode 100644
index 000000000000..5b2ac804bf1d
--- /dev/null
+++ b/sci-libs/onnx/onnx-1.11.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+inherit python-any-r1 cmake
+
+DESCRIPTION="Open Neural Network Exchange (ONNX)"
+HOMEPAGE="https://github.com/onnx/onnx"
+SRC_URI="https://github.com/onnx/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-libs/protobuf"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-util/patchelf
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DONNX_USE_PROTOBUF_SHARED_LIBS=ON
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ patchelf --set-soname libonnxifi.so "${D}"/usr/lib/libonnxifi.so \
+ || die
+ mv "${D}"/usr/lib/libonnxifi.so "${D}"/usr/$(get_libdir)/libonnxifi.so \
+ || die
+}