summaryrefslogtreecommitdiff
path: root/sci-libs/onnx/onnx-1.11.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-05 22:25:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-05 22:25:21 +0100
commit0234994edb2122d4508c5a07122e774bcab9195b (patch)
tree80baac10dd569694ca0dbca4232399a180870839 /sci-libs/onnx/onnx-1.11.0-r1.ebuild
parent4aec9255c99411cb07138353f1bdda61fe0b501d (diff)
gentoo auto-resync : 05:09:2022 - 22:25:20
Diffstat (limited to 'sci-libs/onnx/onnx-1.11.0-r1.ebuild')
-rw-r--r--sci-libs/onnx/onnx-1.11.0-r1.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/sci-libs/onnx/onnx-1.11.0-r1.ebuild b/sci-libs/onnx/onnx-1.11.0-r1.ebuild
deleted file mode 100644
index 5b2ac804bf1d..000000000000
--- a/sci-libs/onnx/onnx-1.11.0-r1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PYTHON_COMPAT=( python3_{8..11} )
-inherit python-any-r1 cmake
-
-DESCRIPTION="Open Neural Network Exchange (ONNX)"
-HOMEPAGE="https://github.com/onnx/onnx"
-SRC_URI="https://github.com/onnx/${PN}/archive/refs/tags/v${PV}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-RESTRICT="test"
-
-DEPEND=""
-RDEPEND="${DEPEND}
- dev-libs/protobuf"
-BDEPEND="
- ${PYTHON_DEPS}
- dev-util/patchelf
-"
-
-src_configure() {
- local mycmakeargs=(
- -DONNX_USE_PROTOBUF_SHARED_LIBS=ON
- )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- patchelf --set-soname libonnxifi.so "${D}"/usr/lib/libonnxifi.so \
- || die
- mv "${D}"/usr/lib/libonnxifi.so "${D}"/usr/$(get_libdir)/libonnxifi.so \
- || die
-}