summaryrefslogtreecommitdiff
path: root/sci-libs/octomap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /sci-libs/octomap
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'sci-libs/octomap')
-rw-r--r--sci-libs/octomap/Manifest1
-rw-r--r--sci-libs/octomap/octomap-9999.ebuild90
2 files changed, 0 insertions, 91 deletions
diff --git a/sci-libs/octomap/Manifest b/sci-libs/octomap/Manifest
index 4f47a1c68f0f..fec4b880e257 100644
--- a/sci-libs/octomap/Manifest
+++ b/sci-libs/octomap/Manifest
@@ -1,5 +1,4 @@
AUX qglqt5.patch 8456 BLAKE2B babaed86e83e1403668b9c3c8cc693775f87783ab11f1f2bd1e3304dce7087186bad406909718244e1c7fa99101e95401c663022e23156a56230d4f5efac67de SHA512 7a9cbcfd49a84ac79b18c183c8d6f6244a76fa0acefdf4adff5f3952e2ad33c1ff1b8227a906d58f40bdff3d83c168e8af2c812e90837b1f98893afd060227ea
DIST octomap-1.9.5.tar.gz 1682781 BLAKE2B 1ced023160d10c424d4bff76a0481ffe6c87c5bf8133480afe6c47ee0ee116304a811293cc0af0b303ebcad370b7ce433e85212f070ac921a9c5be41905a94ea SHA512 e58c6d33c351b14e9596e18a8702715d167c136fd029b1078ddd13a5926fe451d3b619231b5a8ccfb64b6e5fc6db8b57e6ef329099828d2f5195c0988700b581
EBUILD octomap-1.9.5.ebuild 1689 BLAKE2B 169c1a5e542e61cf5a3c9dc0774cac2afd4dab5052d49058da0c6c8bc70be0a5a4d0165a2dc74d798b71d4eec60288cf884cb4df8e0585a973f335297e246d4f SHA512 9c6ed3429728027d951c4298aba8f6762a35efeba50575ab4dff6c5c49e752842f84ec71f66d1febbd506531c1f4ec96abe74bc17c58dad7f4066ea61b8f68e0
-EBUILD octomap-9999.ebuild 1959 BLAKE2B 4011f9870ad688b0d2d9f055fc612a3a2d8f344dd0cd460dc92cc4863c32e6a47da5cbec65d1b3229ba25065cd9c08846374ae89f49626a1891567b6028727ae SHA512 ab10778e2187536b615267407e8b9acc59c96c785504ac2a4ab5f4cbb885456589eb1fc58dbc4d88fa2fbb1dab06f9365e30fab5a8da6a4146a718e50ba1f902
MISC metadata.xml 703 BLAKE2B 52e5edafca7a58ff0efddeea0eb60894c9bd26c5360fb77c41982edf0b27dec9517bb0470049d92dee05cc242effc7bb2e253a275f6e5d422e7e214676f7ffe8 SHA512 66b3c9143aea83a044a719031b4eb0d140e599048885ca6bb02e74ebebbbd2e9abccf11dc0af32e6ce94d3849dcf639ebaf34ff2c8d6e34f32767e08e465c6b0
diff --git a/sci-libs/octomap/octomap-9999.ebuild b/sci-libs/octomap/octomap-9999.ebuild
deleted file mode 100644
index c53f4e28eafc..000000000000
--- a/sci-libs/octomap/octomap-9999.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/OctoMap/octomap"
-fi
-
-inherit ${SCM} cmake-utils
-
-if [ "${PV#9999}" != "${PV}" ] ; then
- SRC_URI=""
-else
- KEYWORDS="~amd64 ~arm"
- SRC_URI="https://github.com/OctoMap/octomap/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-fi
-
-DESCRIPTION="An Efficient Probabilistic 3D Mapping Framework Based on Octrees"
-HOMEPAGE="http://octomap.github.io/"
-IUSE="qt5 dynamicEDT3D doc"
-LICENSE="BSD qt5? ( GPL-2 )"
-SLOT="0/19"
-
-RDEPEND="
- qt5? (
- virtual/opengl
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- x11-libs/libQGLViewer:=
- )
-"
-DEPEND="${RDEPEND}
- doc? (
- app-doc/doxygen
- media-gfx/graphviz
- )
-"
-
-src_prepare() {
- sed -e 's/DESTINATION lib/DESTINATION ${CMAKE_INSTALL_LIBDIR}/' \
- -i */CMakeLists.txt \
- -i */CMakeModules/InstallPkgConfigFile.cmake || die
- sed -e 's/iewer-qt4/iewer-qt5/g' \
- -i octovis/CMakeModules/FindQGLViewer.cmake || die
- cmake-utils_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- "-DBUILD_OCTOVIS_SUBPROJECT=$(usex qt5 ON OFF)"
- "-DOCTOVIS_QT5=TRUE"
- "-DBUILD_DYNAMICETD3D_SUBPROJECT=$(usex dynamicEDT3D ON OFF)"
- )
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
- if use doc ; then
- cd "${BUILD_DIR}/octomap"
- emake docs
- if use dynamicEDT3D ; then
- cd "${BUILD_DIR}/dynamicEDT3D"
- emake docs_dynamicEDT3D
- fi
- fi
-}
-
-src_install() {
- cmake-utils_src_install
- if use doc ; then
- insinto /usr/share/doc/${PF}/html/octomap
- doins -r "${S}/octomap/doc/html/"*
- if use dynamicEDT3D ; then
- insinto /usr/share/doc/${PF}/html/dynamicEDT3D
- doins -r "${S}/dynamicEDT3D/doc/html/"*
- fi
- fi
-
- insinto /usr/share/ros_packages/${PN}
- doins "${ED}/usr/share/${PN}/package.xml"
- if use qt5; then
- insinto /usr/share/ros_packages/octovis
- doins "${ED}/usr/share/octovis/package.xml"
- fi
-}