summaryrefslogtreecommitdiff
path: root/sci-libs/oc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /sci-libs/oc
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'sci-libs/oc')
-rw-r--r--sci-libs/oc/Manifest2
-rw-r--r--sci-libs/oc/oc-2.0.ebuild25
2 files changed, 17 insertions, 10 deletions
diff --git a/sci-libs/oc/Manifest b/sci-libs/oc/Manifest
index 84212f68f5ba..61464a41a963 100644
--- a/sci-libs/oc/Manifest
+++ b/sci-libs/oc/Manifest
@@ -1,3 +1,3 @@
DIST oc-2.0.tar.gz 1104073 BLAKE2B a93fdf15fe085345dc547da51e5f99b4db18baab6126be73aa240e8c5092be0501abc606f556879c09bd41fe1ea4cb78df3c84472e2de3342853d67848b6aeb3 SHA512 e583fbacc8929ef5b2ae0d0f675816b8f46056b11987f8285688a7321d3dfd244a748be00f009f1b2c2b7f95e5a6ecc8eb8e907f81415e849f10a5ff138e82a4
-EBUILD oc-2.0.ebuild 570 BLAKE2B 54d7a3b7787af74942e7b59ccc3241c427f23d31383b41dd2270c24fbae244e21bf12d8f66ece66a63d2d34a9500e24a4c1a9ef22b7c6d2b9a6e4a2a2763e1fc SHA512 5fa7ffd3da5a0a2d92bcf280b2419001f0cd8c4d5f0305ad11ba031703bfeda1d9ebfbf42168001ff33c567e09d1547cb276c9faf87f6eb9c31802de606e48a7
+EBUILD oc-2.0.ebuild 634 BLAKE2B 0c505c9eb442f8f9ba382922fe2101b4f72e7c41fcec1539d3ab9c34567e6684c3156dd4652f98aead84bf568a7108b78b396770400a289acc59c254b09c426c SHA512 e51e7c1df679874dde3bc333de5ffa34adaafee3e023dd72758e6162c958539f78252e3bdd696cba75394e2d076079f5a9395c7bb21323716cfee76b1c9d246d
MISC metadata.xml 488 BLAKE2B 879f6287b16b3b05952542e86469779f217ae2f2481557aa5047e041773816de985a2bb3eb035a18d29c9de2d11e2c96e60ae39462c8ddbdd6595a928cac9560 SHA512 bce557be392b00cdf54e6448ed69c555497e67484fdd9663e72c041fb6ab2c4f8ba82469a9d950be7393358a07dbeb1d4f5528d221c738ecafac43029cfddc92
diff --git a/sci-libs/oc/oc-2.0.ebuild b/sci-libs/oc/oc-2.0.ebuild
index f44b5451489a..24434e06661f 100644
--- a/sci-libs/oc/oc-2.0.ebuild
+++ b/sci-libs/oc/oc-2.0.ebuild
@@ -1,26 +1,33 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit autotools-utils
+EAPI=7
DESCRIPTION="Network Data Access Protocol client C library"
HOMEPAGE="http://opendap.org/"
SRC_URI="http://opendap.org/pub/OC/source/${P}.tar.gz"
LICENSE="LGPL-2"
-
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc static-libs"
+IUSE="doc"
+# tests need network
+RESTRICT="test"
RDEPEND="net-misc/curl"
DEPEND="${RDEPEND}"
-# tests need network
-#PROPERTIES=network
+src_configure() {
+ econf --disable-static
+}
src_install() {
- autotools-utils_src_install
- use doc; dodoc docs/oc*html && dohtml docs/html/*
+ if use doc; then
+ dodoc docs/oc*html
+ HTML_DOCS=( docs/html/. )
+ fi
+ default
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}