summaryrefslogtreecommitdiff
path: root/sci-libs/mpir/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/mpir/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/mpir/files')
-rw-r--r--sci-libs/mpir/files/mpir-1.3.0-ABI-multilib.patch145
-rw-r--r--sci-libs/mpir/files/mpir-2.5.1-automake-1.12.patch95
-rw-r--r--sci-libs/mpir/files/mpir-2.6.0-gcc48.patch13
-rw-r--r--sci-libs/mpir/files/mpir-2.6.0-yasm.patch52
-rw-r--r--sci-libs/mpir/files/mpir-2.7.2-ABI-multilib.patch145
-rw-r--r--sci-libs/mpir/files/mpir-2.7.2-sed-backport.patch16
6 files changed, 466 insertions, 0 deletions
diff --git a/sci-libs/mpir/files/mpir-1.3.0-ABI-multilib.patch b/sci-libs/mpir/files/mpir-1.3.0-ABI-multilib.patch
new file mode 100644
index 000000000000..fba6fea2e8f6
--- /dev/null
+++ b/sci-libs/mpir/files/mpir-1.3.0-ABI-multilib.patch
@@ -0,0 +1,145 @@
+--- configure.in.orig 2009-11-28 10:48:59.196977657 +0000
++++ configure.in 2009-11-28 10:54:50.717976971 +0000
+@@ -361,7 +361,7 @@
+ # hugely bloat the output.
+
+
+-AC_ARG_VAR(ABI, [desired ABI (for processors supporting more than one ABI)])
++AC_ARG_VAR(MPIRABI, [desired ABI (for processors supporting more than one ABI)])
+
+ # abilist needs to be non-empty, "standard" is just a generic name here
+ abilist="standard"
+@@ -1590,7 +1590,7 @@
+
+ cat >&AC_FD_CC <<EOF
+ User:
+-ABI=$ABI
++MPIRABI=$MPIRABI
+ CC=$CC
+ CFLAGS=$CFLAGS_or_unset
+ CPPFLAGS=$CPPFLAGS_or_unset
+@@ -1611,22 +1611,22 @@
+ # If the user specifies an ABI then it must be in $abilist, after that
+ # $abilist is restricted to just that choice.
+ #
+-if test -n "$ABI"; then
++if test -n "$MPIRABI"; then
+ found=no
+ for abi in $abilist; do
+- if test $abi = "$ABI"; then found=yes; break; fi
++ if test $abi = "$MPIRABI"; then found=yes; break; fi
+ done
+ if test $found = no; then
+- AC_MSG_ERROR([ABI=$ABI is not among the following valid choices: $abilist])
++ AC_MSG_ERROR([MPIRABI=$MPIRABI is not among the following valid choices: $abilist])
+ fi
+- abilist="$ABI"
++ abilist="$MPIRABI"
+ fi
+
+ found_compiler=no
+
+ for abi in $abilist; do
+
+- echo "checking ABI=$abi"
++ echo "checking MPIRABI=$abi"
+
+ # Suppose abilist="64 32", then for abi=64, will have abi1="_64" and
+ # abi2="_64". For abi=32, will have abi1="_32" and abi2="". This is how
+@@ -1879,7 +1879,7 @@
+ done
+ fi
+
+- ABI="$abi"
++ MPIRABI="$abi"
+ CC="$cc"
+ CFLAGS="$cflags"
+ CPPFLAGS="$cppflags"
+@@ -1895,8 +1895,8 @@
+ AC_SUBST(GMP_CFLAGS)
+
+ # Could easily have this in config.h too, if desired.
+- ABI_nodots=`echo $ABI | sed 's/\./_/'`
+- GMP_DEFINE_RAW("define_not_for_expansion(\`HAVE_ABI_$ABI_nodots')", POST)
++ ABI_nodots=`echo $MPIRABI | sed 's/\./_/'`
++ GMP_DEFINE_RAW("define_not_for_expansion(\`HAVE_ABI_$MPIRABI_nodots')", POST)
+
+
+ # GMP_LDFLAGS substitution, selected according to ABI.
+@@ -2094,7 +2094,7 @@
+ #
+ case $host in
+ X86_PATTERN | X86_64_PATTERN)
+- if test "$ABI" = 32; then
++ if test "$MPIRABI" = 32; then
+ case "$path $fat_path" in
+ *mmx*) GMP_ASM_X86_MMX( , [GMP_STRIP_PATH(*mmx*)]) ;;
+ esac
+@@ -2108,7 +2108,7 @@
+
+ cat >&AC_FD_CC <<EOF
+ Decided:
+-ABI=$ABI
++MPIRABI=$MPIRABI
+ CC=$CC
+ CFLAGS=$CFLAGS
+ CPPFLAGS=$CPPFLAGS
+@@ -2117,7 +2117,7 @@
+ CXXFLAGS=$CXXFLAGS
+ path=$path
+ EOF
+-echo "using ABI=\"$ABI\""
++echo "using MPIRABI=\"$MPIRABI\""
+ echo " CC=\"$CC\""
+ echo " CFLAGS=\"$CFLAGS\""
+ echo " CPPFLAGS=\"$CPPFLAGS\""
+@@ -2593,7 +2593,7 @@
+
+
+ if test -n "$fat_path"; then
+- if test "$ABI" = 64; then
++ if test "$MPIRABI" = 64; then
+ fat_path="$fat_path_64"
+ fi
+
+@@ -3099,19 +3099,19 @@
+ GMP_INCLUDE_MPN(powerpc32/powerpc-defs.m4)
+ case $host in
+ *-*-aix*)
+- case $ABI in
++ case $MPIRABI in
+ 64 | aix64) GMP_INCLUDE_MPN(powerpc64/aix.m4) ;;
+ *) GMP_INCLUDE_MPN(powerpc32/aix.m4) ;;
+ esac
+ ;;
+ *-*-linux* | *-*-*bsd*)
+- case $ABI in
++ case $MPIRABI in
+ mode64) GMP_INCLUDE_MPN(powerpc64/elf.m4) ;;
+ mode32 | 32) GMP_INCLUDE_MPN(powerpc32/elf.m4) ;;
+ esac
+ ;;
+ *-*-darwin*)
+- case $ABI in
++ case $MPIRABI in
+ mode64) GMP_INCLUDE_MPN(powerpc64/darwin.m4) ;;
+ mode32 | 32) GMP_INCLUDE_MPN(powerpc32/darwin.m4) ;;
+ esac
+@@ -3126,7 +3126,7 @@
+ GMP_INCLUDE_MPN(powerpc32/aix.m4)
+ ;;
+ sparcv9*-*-* | ultrasparc*-*-* | sparc64-*-*)
+- case $ABI in
++ case $MPIRABI in
+ 64)
+ GMP_ASM_SPARC_REGISTER
+ ;;
+@@ -3134,7 +3134,7 @@
+ ;;
+ X86_PATTERN | X86_64_PATTERN)
+ GMP_ASM_ALIGN_FILL_0x90
+- case $ABI in
++ case $MPIRABI in
+ 32)
+ GMP_INCLUDE_MPN(x86/x86-defs.m4)
+ AC_DEFINE(HAVE_HOST_CPU_FAMILY_x86)
diff --git a/sci-libs/mpir/files/mpir-2.5.1-automake-1.12.patch b/sci-libs/mpir/files/mpir-2.5.1-automake-1.12.patch
new file mode 100644
index 000000000000..684bcbf7d3c1
--- /dev/null
+++ b/sci-libs/mpir/files/mpir-2.5.1-automake-1.12.patch
@@ -0,0 +1,95 @@
+http://bugs.gentoo.org/423767
+
+--- configure.in
++++ configure.in
+@@ -69,7 +69,7 @@
+ dnl Note that there's a copy of these options in the top-level Makefile.am,
+ dnl so update there too if changing anything.
+ dnl
+-AM_INIT_AUTOMAKE([1.11 gnu no-dependencies parallel-tests dist-bzip2 no-dist-gzip dist-lzma])
++AM_INIT_AUTOMAKE([1.11 gnu no-dependencies parallel-tests dist-bzip2 no-dist-gzip dist-xz])
+ AM_CONFIG_HEADER(config.h:config.in)
+ AM_MAINTAINER_MODE
+
+@@ -208,8 +208,7 @@
+ [enable_fat=no])
+
+ # Work around an autoconf bug
+-MKDIR_P=@mkdir_p@
+-AC_SUBST(MKDIR_P)
++AC_PROG_MKDIR_P
+
+ # Table of compilers, options, and mpn paths. This code has various related
+ # purposes
+--- yasm/po/Makefile.in.in
++++ yasm/po/Makefile.in.in
+@@ -32,17 +32,17 @@
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
+
+-# We use $(mkdir_p).
+-# In automake <= 1.9.x, $(mkdir_p) is defined either as "mkdir -p --" or as
++# We use $(MKDIR_P).
++# In automake <= 1.9.x, $(MKDIR_P) is defined either as "mkdir -p --" or as
+ # "$(mkinstalldirs)" or as "$(install_sh) -d". For these automake versions,
+ # @install_sh@ does not start with $(SHELL), so we add it.
+-# In automake >= 1.10, @mkdir_p@ is derived from ${MKDIR_P}, which is defined
++# In automake >= 1.10, @MKDIR_P@ is derived from ${MKDIR_P}, which is defined
+ # either as "/path/to/mkdir -p" or ".../install-sh -c -d". For these automake
+ # versions, $(mkinstalldirs) and $(install_sh) are unused.
+ mkinstalldirs = $(SHELL) @install_sh@ -d
+ install_sh = $(SHELL) @install_sh@
+ MKDIR_P = @MKDIR_P@
+-mkdir_p = @mkdir_p@
++MKDIR_P = @MKDIR_P@
+
+ GMSGFMT_ = @GMSGFMT@
+ GMSGFMT_no = @GMSGFMT@
+@@ -204,7 +204,7 @@
+ install-exec:
+ install-data: install-data-@USE_NLS@
+ if test "$(PACKAGE)" = "gettext-tools"; then \
+- $(mkdir_p) $(DESTDIR)$(gettextsrcdir); \
++ $(MKDIR_P) $(DESTDIR)$(gettextsrcdir); \
+ for file in $(DISTFILES.common) Makevars.template; do \
+ $(INSTALL_DATA) $(srcdir)/$$file \
+ $(DESTDIR)$(gettextsrcdir)/$$file; \
+@@ -217,13 +217,13 @@
+ fi
+ install-data-no: all
+ install-data-yes: all
+- $(mkdir_p) $(DESTDIR)$(datadir)
++ $(MKDIR_P) $(DESTDIR)$(datadir)
+ @catalogs='$(CATALOGS)'; \
+ for cat in $$catalogs; do \
+ cat=`basename $$cat`; \
+ lang=`echo $$cat | sed -e 's/\.gmo$$//'`; \
+ dir=$(localedir)/$$lang/LC_MESSAGES; \
+- $(mkdir_p) $(DESTDIR)$$dir; \
++ $(MKDIR_P) $(DESTDIR)$$dir; \
+ if test -r $$cat; then realcat=$$cat; else realcat=$(srcdir)/$$cat; fi; \
+ $(INSTALL_DATA) $$realcat $(DESTDIR)$$dir/$(DOMAIN).mo; \
+ echo "installing $$realcat as $(DESTDIR)$$dir/$(DOMAIN).mo"; \
+@@ -263,19 +263,19 @@
+ installdirs-exec:
+ installdirs-data: installdirs-data-@USE_NLS@
+ if test "$(PACKAGE)" = "gettext-tools"; then \
+- $(mkdir_p) $(DESTDIR)$(gettextsrcdir); \
++ $(MKDIR_P) $(DESTDIR)$(gettextsrcdir); \
+ else \
+ : ; \
+ fi
+ installdirs-data-no:
+ installdirs-data-yes:
+- $(mkdir_p) $(DESTDIR)$(datadir)
++ $(MKDIR_P) $(DESTDIR)$(datadir)
+ @catalogs='$(CATALOGS)'; \
+ for cat in $$catalogs; do \
+ cat=`basename $$cat`; \
+ lang=`echo $$cat | sed -e 's/\.gmo$$//'`; \
+ dir=$(localedir)/$$lang/LC_MESSAGES; \
+- $(mkdir_p) $(DESTDIR)$$dir; \
++ $(MKDIR_P) $(DESTDIR)$$dir; \
+ for lc in '' $(EXTRA_LOCALE_CATEGORIES); do \
+ if test -n "$$lc"; then \
+ if (cd $(DESTDIR)$(localedir)/$$lang && LC_ALL=C ls -l -d $$lc 2>/dev/null) | grep ' -> ' >/dev/null; then \
diff --git a/sci-libs/mpir/files/mpir-2.6.0-gcc48.patch b/sci-libs/mpir/files/mpir-2.6.0-gcc48.patch
new file mode 100644
index 000000000000..55cd1a087ed6
--- /dev/null
+++ b/sci-libs/mpir/files/mpir-2.6.0-gcc48.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/470838
+
+--- a/tests/mpz/t-scan.c
++++ b/tests/mpz/t-scan.c
+@@ -84,7 +84,7 @@ check_ref (void)
+
+ for (isize = 0; isize <= size; isize++)
+ {
+- for (oindex = 0; oindex <= numberof (offset); oindex++)
++ for (oindex = 0; oindex < numberof (offset); oindex++)
+ {
+ o = offset[oindex];
+ if ((int) isize*GMP_NUMB_BITS < -o)
diff --git a/sci-libs/mpir/files/mpir-2.6.0-yasm.patch b/sci-libs/mpir/files/mpir-2.6.0-yasm.patch
new file mode 100644
index 000000000000..3c6b1881f170
--- /dev/null
+++ b/sci-libs/mpir/files/mpir-2.6.0-yasm.patch
@@ -0,0 +1,52 @@
+diff -U 3 -dHrN mpir-2.6.0.orig/configure.in mpir-2.6.0/configure.in
+--- mpir-2.6.0.orig/configure.in 2013-01-16 10:51:13.141047276 +0100
++++ mpir-2.6.0/configure.in 2013-01-16 10:51:52.437353115 +0100
+@@ -1295,8 +1295,6 @@
+ ;;
+ esac
+
+-AM_CONDITIONAL(BUILD_YASM, test "$want_yasm" = "yes")
+-
+ CFLAGS_or_unset=${CFLAGS-'(unset)'}
+ CPPFLAGS_or_unset=${CPPFLAGS-'(unset)'}
+
+@@ -1681,7 +1679,7 @@
+ GMP_CHECK_LIBM_FOR_BUILD
+
+
+-MPIR_AS="/yasm/yasm"
++MPIR_AS="yasm"
+
+ # How to assemble, used with CFLAGS etc, see mpn/Makeasm.am.
+ # Using the compiler is a lot easier than figuring out how to invoke the
+@@ -2984,7 +2982,6 @@
+ # Right now automake isn't accepting the new AC_CONFIG_FILES scheme.
+
+ # allways configure all subdirectorys , even if there are not going to be built ,
+-AC_CONFIG_SUBDIRS([yasm])
+
+ case $host in
+ *-w64-mingw*)
+diff -U 3 -dHrN mpir-2.6.0.orig/Makefile.am mpir-2.6.0/Makefile.am
+--- mpir-2.6.0.orig/Makefile.am 2013-01-16 10:51:13.121047120 +0100
++++ mpir-2.6.0/Makefile.am 2013-01-16 10:52:25.675611816 +0100
+@@ -98,10 +98,6 @@
+
+ SUBDIRS = tests
+
+-if BUILD_YASM
+-SUBDIRS += yasm
+-endif
+-
+ SUBDIRS += mpn fft mpz mpq mpf printf scanf cxx tune doc
+
+ EXTRA_DIST = configfsf.guess configfsf.sub .gdbinit INSTALL.autoconf
+diff -U 3 -dHrN mpir-2.6.0.orig/mpn/Makeasm.am mpir-2.6.0/mpn/Makeasm.am
+--- mpir-2.6.0.orig/mpn/Makeasm.am 2013-01-16 10:51:13.045046528 +0100
++++ mpir-2.6.0/mpn/Makeasm.am 2013-01-16 10:53:25.333076126 +0100
+@@ -119,4 +119,4 @@
+ # .as assembler, assembled with Yasm
+
+ .as.lo:
+- $(LIBTOOL) --mode=compile --tag=CC $(top_srcdir)/strip_fPIC.sh $(top_builddir)$(MPIR_AS) -I $(top_builddir) $(OBJECT_FORMAT) $(GSYM_FLAG) -o $@ `test -f '$<' || echo '$(srcdir)/'`$<
++ $(LIBTOOL) --mode=compile --tag=CC $(top_srcdir)/strip_fPIC.sh $(MPIR_AS) -I $(top_builddir) $(OBJECT_FORMAT) $(GSYM_FLAG) -o $@ `test -f '$<' || echo '$(srcdir)/'`$<
diff --git a/sci-libs/mpir/files/mpir-2.7.2-ABI-multilib.patch b/sci-libs/mpir/files/mpir-2.7.2-ABI-multilib.patch
new file mode 100644
index 000000000000..f02df55ccf98
--- /dev/null
+++ b/sci-libs/mpir/files/mpir-2.7.2-ABI-multilib.patch
@@ -0,0 +1,145 @@
+--- a/configure.ac 2009-11-28 10:48:59.196977657 +0000
++++ b/configure.ac 2009-11-28 10:54:50.717976971 +0000
+@@ -361,7 +361,7 @@
+ # hugely bloat the output.
+
+
+-AC_ARG_VAR(ABI, [desired ABI (for processors supporting more than one ABI)])
++AC_ARG_VAR(MPIRABI, [desired ABI (for processors supporting more than one ABI)])
+
+ # abilist needs to be non-empty, "standard" is just a generic name here
+ abilist="standard"
+@@ -1590,7 +1590,7 @@
+
+ cat >&AC_FD_CC <<EOF
+ User:
+-ABI=$ABI
++MPIRABI=$MPIRABI
+ CC=$CC
+ CFLAGS=$CFLAGS_or_unset
+ CPPFLAGS=$CPPFLAGS_or_unset
+@@ -1611,22 +1611,22 @@
+ # If the user specifies an ABI then it must be in $abilist, after that
+ # $abilist is restricted to just that choice.
+ #
+-if test -n "$ABI"; then
++if test -n "$MPIRABI"; then
+ found=no
+ for abi in $abilist; do
+- if test $abi = "$ABI"; then found=yes; break; fi
++ if test $abi = "$MPIRABI"; then found=yes; break; fi
+ done
+ if test $found = no; then
+- AC_MSG_ERROR([ABI=$ABI is not among the following valid choices: $abilist])
++ AC_MSG_ERROR([MPIRABI=$MPIRABI is not among the following valid choices: $abilist])
+ fi
+- abilist="$ABI"
++ abilist="$MPIRABI"
+ fi
+
+ found_compiler=no
+
+ for abi in $abilist; do
+
+- echo "checking ABI=$abi"
++ echo "checking MPIRABI=$abi"
+
+ # Suppose abilist="64 32", then for abi=64, will have abi1="_64" and
+ # abi2="_64". For abi=32, will have abi1="_32" and abi2="". This is how
+@@ -1879,7 +1879,7 @@
+ done
+ fi
+
+- ABI="$abi"
++ MPIRABI="$abi"
+ CC="$cc"
+ CFLAGS="$cflags"
+ CPPFLAGS="$cppflags"
+@@ -1895,8 +1895,8 @@
+ AC_SUBST(GMP_CFLAGS)
+
+ # Could easily have this in config.h too, if desired.
+- ABI_nodots=`echo $ABI | sed 's/\./_/'`
+- GMP_DEFINE_RAW("define_not_for_expansion(\`HAVE_ABI_$ABI_nodots')", POST)
++ ABI_nodots=`echo $MPIRABI | sed 's/\./_/'`
++ GMP_DEFINE_RAW("define_not_for_expansion(\`HAVE_ABI_$MPIRABI_nodots')", POST)
+
+
+ # GMP_LDFLAGS substitution, selected according to ABI.
+@@ -2094,7 +2094,7 @@
+ #
+ case $host in
+ X86_PATTERN | X86_64_PATTERN)
+- if test "$ABI" = 32; then
++ if test "$MPIRABI" = 32; then
+ case "$path $fat_path" in
+ *mmx*) GMP_ASM_X86_MMX( , [GMP_STRIP_PATH(*mmx*)]) ;;
+ esac
+@@ -2108,7 +2108,7 @@
+
+ cat >&AC_FD_CC <<EOF
+ Decided:
+-ABI=$ABI
++MPIRABI=$MPIRABI
+ CC=$CC
+ CFLAGS=$CFLAGS
+ CPPFLAGS=$CPPFLAGS
+@@ -2117,7 +2117,7 @@
+ CXXFLAGS=$CXXFLAGS
+ path=$path
+ EOF
+-echo "using ABI=\"$ABI\""
++echo "using MPIRABI=\"$MPIRABI\""
+ echo " CC=\"$CC\""
+ echo " CFLAGS=\"$CFLAGS\""
+ echo " CPPFLAGS=\"$CPPFLAGS\""
+@@ -2593,7 +2593,7 @@
+
+
+ if test -n "$fat_path"; then
+- if test "$ABI" = 64; then
++ if test "$MPIRABI" = 64; then
+ fat_path="$fat_path_64"
+ fi
+
+@@ -3099,19 +3099,19 @@
+ GMP_INCLUDE_MPN(powerpc32/powerpc-defs.m4)
+ case $host in
+ *-*-aix*)
+- case $ABI in
++ case $MPIRABI in
+ 64 | aix64) GMP_INCLUDE_MPN(powerpc64/aix.m4) ;;
+ *) GMP_INCLUDE_MPN(powerpc32/aix.m4) ;;
+ esac
+ ;;
+ *-*-linux* | *-*-*bsd*)
+- case $ABI in
++ case $MPIRABI in
+ mode64) GMP_INCLUDE_MPN(powerpc64/elf.m4) ;;
+ mode32 | 32) GMP_INCLUDE_MPN(powerpc32/elf.m4) ;;
+ esac
+ ;;
+ *-*-darwin*)
+- case $ABI in
++ case $MPIRABI in
+ mode64) GMP_INCLUDE_MPN(powerpc64/darwin.m4) ;;
+ mode32 | 32) GMP_INCLUDE_MPN(powerpc32/darwin.m4) ;;
+ esac
+@@ -3126,7 +3126,7 @@
+ GMP_INCLUDE_MPN(powerpc32/aix.m4)
+ ;;
+ sparcv9*-*-* | ultrasparc*-*-* | sparc64-*-*)
+- case $ABI in
++ case $MPIRABI in
+ 64)
+ GMP_ASM_SPARC_REGISTER
+ ;;
+@@ -3134,7 +3134,7 @@
+ ;;
+ X86_PATTERN | X86_64_PATTERN)
+ GMP_ASM_ALIGN_FILL_0x90
+- case $ABI in
++ case $MPIRABI in
+ 32)
+ GMP_INCLUDE_MPN(x86/x86-defs.m4)
+ AC_DEFINE(HAVE_HOST_CPU_FAMILY_x86)
diff --git a/sci-libs/mpir/files/mpir-2.7.2-sed-backport.patch b/sci-libs/mpir/files/mpir-2.7.2-sed-backport.patch
new file mode 100644
index 000000000000..897642909ca0
--- /dev/null
+++ b/sci-libs/mpir/files/mpir-2.7.2-sed-backport.patch
@@ -0,0 +1,16 @@
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index a3821c5..15fa93d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -2595,7 +2595,7 @@ for tmp_fn in $gmp_mpn_functions; do
+ sed -n 's/^[ ]*MULFUNC_PROLOGUE(\(.*\))/\1/p' $tmp_file ;
+ sed -n 's/^[ ]*PROLOGUE(\([^,]*\).*)/\1/p' $tmp_file ;
+ sed -n 's/^;[ ]*PROLOGUE(\([^,]*\).*)/\1/p' $tmp_file ;
+- sed -n 's/[^G]*GLOBAL_FUNC[:space:]*\(.*\)/\1/p' $tmp_file ;
++ sed -n 's/[^G]*GLOBAL_FUNC[[:space:]]*\(.*\)/\1/p' $tmp_file ;
+ `]
+ for gmp_tmp in $gmp_ep; do
+ AC_DEFINE_UNQUOTED(HAVE_NATIVE_$gmp_tmp)