summaryrefslogtreecommitdiff
path: root/sci-libs/mmtk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/mmtk
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/mmtk')
-rw-r--r--sci-libs/mmtk/Manifest5
-rw-r--r--sci-libs/mmtk/metadata.xml8
-rw-r--r--sci-libs/mmtk/mmtk-2.7.9.ebuild54
3 files changed, 67 insertions, 0 deletions
diff --git a/sci-libs/mmtk/Manifest b/sci-libs/mmtk/Manifest
new file mode 100644
index 000000000000..4759a058df31
--- /dev/null
+++ b/sci-libs/mmtk/Manifest
@@ -0,0 +1,5 @@
+DIST MMTK-2.7.9.tar.gz 1213599 SHA256 8c53acc12428ca6464e6b7e11fb1587200e16f8a5c92eb56e48ece387b6977ed SHA512 66819048aec4d8bdd370bb063f702c828145ecc9b7cb3247fcdd067486c78e00110a4e316f5c76df0b57a7885e05c347fa1616944daabfaa6d8b35933a79a7d8 WHIRLPOOL 765c9407df5dfa48891cd8b29f0e53196ca8ae20e536bb78b65458832aa342d21d84ef30b4d26c5a25c24126b65fe428f3129942435f6035931b921f1b0ba4d1
+EBUILD mmtk-2.7.9.ebuild 1195 SHA256 8132c79c328320acdac591afef5382fe6f143cefb62847b36622e014699d2fd2 SHA512 5cd7eff1be05dab6da4e7b4f026a80f3c5e88eb8eab6912bd734efbd86ca17f071273076521c89076c4d256bc2b5ddb30e51fefe36d20147f363096584d7a744 WHIRLPOOL ecbef5b1d3c514032f7ada48b0db94758ec444e48373a5e3f783747507bf1521881cbf4965780fc998b2c3b10913f4a8dabcdeaaf17c421b8232818fb5789f58
+MISC ChangeLog 2510 SHA256 9f2c34bee4bee3c08092b04bc7301fae6c6ce7e8b713e094c1cb58a6759b7846 SHA512 f73a7cd10e978afbfa4f9251005580af0fedaa7e83cf3695c231673b13cd7525ae73a1698e3b1586fcb40b9949fb5a7464eab0d305cd0d25870b87979dc90f19 WHIRLPOOL 426ef96cf772501e60b07f17b94f9ccab9fab322a5356b82d1fd4f305b1bf3617d1b6081e440bc66d599ddb9caf739ed3f43af325ef14f93427702223dfc84d7
+MISC ChangeLog-2015 2255 SHA256 7242c43c83110c572b210d4d1cf2cd83a4ef37490af30acbee158905782069fd SHA512 1a14296f6a15ea20267039f1bcd7db560c7e77052e2ae381e03334b241adb6d1ed41d1828f4c62e4766779c2322c81a550f7d3b544d803e4e3b012fcca4841f7 WHIRLPOOL 83a6af1318dfa23602fd7ca1306427725d37866be54d00e1195bfd7f5b86ab67f0db692f5c767596f2ffe2f82c268a8377309879aabc11cf3e921ad1040822d2
+MISC metadata.xml 271 SHA256 70036ea85140f86ed670bc2791c9de861c4b6164755ee36a2560d1c812ec13f6 SHA512 3e6e6047a29e07123b81279cae1de17bc4bd4c3d7d8a8d26560114a18185f473d038fc220fa81c7213fa203ce197bad8b1c272d9b7e41cd770a953fa6308ff92 WHIRLPOOL 1ccb964819c99258af550a41c6712ba8ebdecbec1c821106de2f22c37b1c981cd4f324856a8014b08bd186bcd2a7fa45a7e772cc15705d1a39016b5229e77269
diff --git a/sci-libs/mmtk/metadata.xml b/sci-libs/mmtk/metadata.xml
new file mode 100644
index 000000000000..8937bad0b175
--- /dev/null
+++ b/sci-libs/mmtk/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-chemistry@gentoo.org</email>
+ <name>Gentoo Chemistry Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-libs/mmtk/mmtk-2.7.9.ebuild b/sci-libs/mmtk/mmtk-2.7.9.ebuild
new file mode 100644
index 000000000000..15a2992306a5
--- /dev/null
+++ b/sci-libs/mmtk/mmtk-2.7.9.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+# This number identifies each release on the CRU website.
+# Can't figure out how to avoid hardcoding it.
+NUMBER="4324"
+
+MY_PN=${PN/mmtk/MMTK}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Molecular Modeling ToolKit for Python"
+HOMEPAGE="http://dirac.cnrs-orleans.fr/MMTK/"
+SRC_URI="http://sourcesup.cru.fr/frs/download.php/${NUMBER}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="CeCILL-2"
+KEYWORDS="~amd64 ~x86 ~ppc ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ <dev-python/numpy-1.9[${PYTHON_USEDEP}]
+ dev-python/scientificpython[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+python_prepare_all() {
+ export MMTK_USE_CYTHON="1"
+ sed \
+ -e "/ext_package/d" \
+ -e "/^if sphinx/s|:| == 3:|g" \
+ -e "s:import sphinx:sphinx = None:g" \
+ -i "${S}"/setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ DOCS=( README* Doc/CHANGELOG )
+ HTML_DOCS=( Doc/HTML/. )
+
+ distutils-r1_python_install_all
+
+ if use examples; then
+ insinto /usr/share/${P}
+ doins -r Examples
+ fi
+}