summaryrefslogtreecommitdiff
path: root/sci-libs/m4rie/m4rie-20200115.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /sci-libs/m4rie/m4rie-20200115.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'sci-libs/m4rie/m4rie-20200115.ebuild')
-rw-r--r--sci-libs/m4rie/m4rie-20200115.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-libs/m4rie/m4rie-20200115.ebuild b/sci-libs/m4rie/m4rie-20200115.ebuild
new file mode 100644
index 000000000000..676a82f2a93a
--- /dev/null
+++ b/sci-libs/m4rie/m4rie-20200115.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Fast dense matrix arithmetic over GF(2^e) for 2 <= e <= 16"
+HOMEPAGE="https://bitbucket.org/malb/m4rie/"
+SRC_URI="https://bitbucket.org/malb/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="debug static-libs"
+
+DEPEND=">=sci-libs/m4ri-20140914"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # m4rie doesn't actually have any openmp code. The configure flag
+ # stems from a mistaken belief that it needs to be there to use the
+ # openmp code in m4ri.
+ econf \
+ --disable-openmp \
+ $(use_enable debug) \
+ $(use_enable static-libs static)
+}
+
+src_install(){
+ default
+ find "${ED}" -name '*.la' -delete || die
+}