summaryrefslogtreecommitdiff
path: root/sci-libs/m4rie/m4rie-20200115-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /sci-libs/m4rie/m4rie-20200115-r1.ebuild
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'sci-libs/m4rie/m4rie-20200115-r1.ebuild')
-rw-r--r--sci-libs/m4rie/m4rie-20200115-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sci-libs/m4rie/m4rie-20200115-r1.ebuild b/sci-libs/m4rie/m4rie-20200115-r1.ebuild
new file mode 100644
index 000000000000..48f2dd3f0476
--- /dev/null
+++ b/sci-libs/m4rie/m4rie-20200115-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Fast dense matrix arithmetic over GF(2^e) for 2 <= e <= 16"
+HOMEPAGE="https://bitbucket.org/malb/m4rie/"
+SRC_URI="https://bitbucket.org/malb/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="debug static-libs"
+
+DEPEND="sci-libs/m4ri"
+RDEPEND="${DEPEND}"
+
+# Requires eautoreconf.
+PATCHES=( "${FILESDIR}/${P}-link-libm.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # m4rie doesn't actually have any openmp code. The configure flag
+ # stems from a mistaken belief that it needs to be there to use the
+ # openmp code in m4ri.
+ econf \
+ --disable-openmp \
+ $(use_enable debug) \
+ $(use_enable static-libs static)
+}
+
+src_install(){
+ default
+ find "${ED}" -name '*.la' -delete || die
+}