summaryrefslogtreecommitdiff
path: root/sci-libs/lrslib/lrslib-071b.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
commit95461df035e3867364495f065e5e805bf629b2d7 (patch)
tree867dce371a84a696e91be255d89f282975aa0480 /sci-libs/lrslib/lrslib-071b.ebuild
parent46eedbedafdb0040c37884982d4c775ce277fb7b (diff)
gentoo resync : 25.10.2021
Diffstat (limited to 'sci-libs/lrslib/lrslib-071b.ebuild')
-rw-r--r--sci-libs/lrslib/lrslib-071b.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/sci-libs/lrslib/lrslib-071b.ebuild b/sci-libs/lrslib/lrslib-071b.ebuild
new file mode 100644
index 000000000000..dce7bc19ece6
--- /dev/null
+++ b/sci-libs/lrslib/lrslib-071b.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Reverse-search algorithm for vertex enumeration problems"
+HOMEPAGE="http://cgm.cs.mcgill.ca/~avis/C/lrs.html"
+SRC_URI="http://cgm.cs.mcgill.ca/~avis/C/lrslib/archive/${P}.tar.gz"
+
+# COPYING is GPL-2, but e.g. lrslib.h says "or ... any later version."
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="gmp mpi"
+
+BDEPEND=""
+RDEPEND="
+ gmp? (
+ dev-libs/gmp:0=
+ mpi? ( virtual/mpi )
+ )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ tc-export CC
+
+ # The "makefile" sort-of supports CFLAGS as of lrslib-071b, but
+ # "-O3" is still included verbatim in many targets. Likewise, a
+ # LIBDIR variable exists but "lib" remains hard-coded in the install
+ # targets.
+ sed -e "s/-O3/${CFLAGS}/g" \
+ -e 's/$(CC) -shared/$(CC) $(LDFLAGS) -shared/' \
+ -e "s,/usr/local,${EPREFIX}/usr,g" \
+ -e "s,/lib,/$(get_libdir),g" \
+ -i makefile || die
+}
+
+src_compile() {
+ if use gmp ; then
+ emake
+ emake all-shared
+ use mpi && emake mplrs
+ else
+ emake allmp
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" install-common
+ if use gmp; then
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" install
+ use mpi && dobin mplrs
+ fi
+ dodoc README
+}