summaryrefslogtreecommitdiff
path: root/sci-libs/libsvm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /sci-libs/libsvm
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'sci-libs/libsvm')
-rw-r--r--sci-libs/libsvm/Manifest2
-rw-r--r--sci-libs/libsvm/libsvm-3.24.ebuild118
2 files changed, 120 insertions, 0 deletions
diff --git a/sci-libs/libsvm/Manifest b/sci-libs/libsvm/Manifest
index 5c47872d975a..7871337e5d8b 100644
--- a/sci-libs/libsvm/Manifest
+++ b/sci-libs/libsvm/Manifest
@@ -1,5 +1,7 @@
AUX 3.11-openmp.patch 943 BLAKE2B 39f092a108f808711dd928595cd82d507f6154efd549c319047c7a94edb772887338209549dba99cca4ed0a8106dc40ef4afd3a42dfe41d7d884f7f630391bfe SHA512 17bcea4da6a6aa32192ce7fb66e7eefef5e037ca2afd968e67de385938555975abe2103ee2cc50d02cd21d9783e9334eac93de694d6e685f13af80c49e42af38
AUX 3.14-makefile.patch 1634 BLAKE2B f25e5225e07040e43cc6057558914f177de4e3d40254df9668de8719fbacd6cbadd685d38e2935c13e1778d8a260ef0733672bfc5c719a9e5d9a8832cbbe8ca8 SHA512 f4c2e2f6556604bf3572e341176c855e87caf4c3db8c2b347ce4e7a7948d21b708a7df29d5bf9b741dd3f34e08a0750572b94bd5e94bb4052f1ba4b9ae50e918
DIST libsvm-3.22.tar.gz 850563 BLAKE2B 824451dd2cafb7f2546d510d2c516dee67c27e586d5b16557a3c23e0c372cd577af5a322e24f70df6cda66e0a58f2e4d70017e6155a1d211ad3c728f840bfa2b SHA512 80a22fd2c2a82f70b8279fa5d8c5a2838b10ee439cf6d725816d608f8e45990ba1780ae6750cad78b25c1c18daf2c2315b342b9e329affbd5729d6fd7da87f7a
+DIST libsvm-3.24.tar.gz 876441 BLAKE2B 6781804ba9706de5ad363bcbda20f2ec181cc4ee9613c9e7429f03872f7a03b04859df2ec00692d9de3ea237d1e478435a4d4db3ce7e5292689a2eab26a1fe46 SHA512 ff3c39bc84291bfb707151d7b8b6fb2eece937afa769cb8ee579d00ee4c30e943d476cd7bb18851d482c9bed89cf94fb3fd8abca4d47253360e12e9406f2f24b
EBUILD libsvm-3.22.ebuild 2668 BLAKE2B c1172520f22ec7f86e77aa6fcb564067c1ad055a5ce9b39a003342ee2e15378d09c19a56dcf2f76571bda62679038eb6d08c6d47533b0e2a88f37738e9e359fa SHA512 fd1d93c0b88763c0ce8e9e798bf46345debf7d00e76fb0f815e2cfbd8ce57f2b3d37a79b236699045421fefd98bdb7cd8ac66069d0ae493315af6c3cb6294637
+EBUILD libsvm-3.24.ebuild 2678 BLAKE2B acd76a68d807cfd2cd4f1bee6b6731ee5713d3e50b35fda2d8dbd304c14858f5f9c7ff0ab6ae0d4b5a2f9af37361f3caa76012d8f8533c049f550036b96bc0c2 SHA512 964b86e17b70ab4de7d81083169132b56721441babe02ee44fc8199aaeb04be8ca9a244015934c39e072e1283b93b0c35e3835337614a201e1ce9ef3f80dc09e
MISC metadata.xml 815 BLAKE2B b73e733b7881fd6c9b45f7605259a7d99e9bef6729936b7502df8c857e40e8552ebc0be25065a7d1391dd9b98cb4dd81b5dfd12722e5852f18c85ee693b2d20f SHA512 0e26fd0b3ddb08f769e92249819e93483cbca426465b8cd623703be2c242b5c8dd9731c978f6965e2c39d680229d5b15587ec0a16aea0b6fcf8172cf70e7f7ec
diff --git a/sci-libs/libsvm/libsvm-3.24.ebuild b/sci-libs/libsvm/libsvm-3.24.ebuild
new file mode 100644
index 000000000000..e68a5236b219
--- /dev/null
+++ b/sci-libs/libsvm/libsvm-3.24.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit flag-o-matic java-pkg-opt-2 python-r1 toolchain-funcs
+
+DESCRIPTION="Library for Support Vector Machines"
+HOMEPAGE="https://www.csie.ntu.edu.tw/~cjlin/libsvm/"
+SRC_URI="https://www.csie.ntu.edu.tw/~cjlin/libsvm/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="java openmp python tools"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ java? ( >=virtual/jdk-1.4 )
+ python? ( ${PYTHON_DEPS} )
+"
+RDEPEND="
+ java? ( >=virtual/jre-1.4 )
+ python? ( ${PYTHON_DEPS} )
+ tools? ( sci-visualization/gnuplot )
+"
+
+PATCHES=(
+ "${FILESDIR}/3.11-openmp.patch"
+ "${FILESDIR}/3.14-makefile.patch"
+)
+
+pkg_setup() {
+ if use openmp; then
+ if ! tc-has-openmp; then
+ ewarn "OpenMP is not supported by your currently selected compiler"
+
+ if tc-is-clang; then
+ ewarn "OpenMP support in sys-devel/clang is provided by sys-libs/libomp,"
+ ewarn "which you will need to build ${CATEGORY}/${PN} for USE=\"openmp\""
+ fi
+
+ die "need openmp capable compiler"
+ fi
+
+ append-cflags -fopenmp
+ append-cxxflags -fopenmp
+ append-cppflags -DOPENMP
+ fi
+}
+
+src_prepare() {
+ default
+
+ sed -i -e "s@\.\./@${EPREFIX}/usr/bin/@g" tools/*.py \
+ || die "Failed to fix paths in python files"
+ sed -i -e "s|./grid.py|${EPREFIX}/usr/bin/svm-grid|g" tools/*.py \
+ || die "Failed to fix paths for svm-grid"
+ sed -i -e 's/grid.py/svm-grid/g' tools/grid.py \
+ || die "Failed to rename grid.py to svm-grid"
+
+ if use java; then
+ local JAVAC_FLAGS="$(java-pkg_javac-args)"
+ sed -i \
+ -e "s/JAVAC_FLAGS =/JAVAC_FLAGS=${JAVAC_FLAGS}/g" \
+ java/Makefile || die "Failed to fix java makefile"
+ fi
+ tc-export CXX CC
+}
+
+src_compile() {
+ default
+ use java && emake -C java
+}
+
+src_install() {
+ dobin svm-train svm-predict svm-scale
+ dolib.so *.so*
+ doheader svm.h
+
+ DOCS=( README )
+
+ if use tools; then
+ local t
+ for t in tools/*.py; do
+ python_foreach_impl python_newscript ${t} svm-$(basename ${t} .py)
+ done
+
+ mv tools/README{,.tools} || die
+ DOCS+=( tools/README.tools )
+
+ insinto /usr/share/doc/${PF}/examples
+ docompress -x /usr/share/doc/${PF}/examples
+ doins heart_scale
+ doins -r svm-toy
+ fi
+
+ if use python ; then
+ installation() {
+ touch python/__init__.py || die
+ python_moduleinto libsvm
+ python_domodule python/*.py
+ }
+ python_foreach_impl installation
+
+ mv python/README{,.python} || die
+ DOCS+=( python/README.python )
+ fi
+
+ HTML_DOCS=( FAQ.html )
+ if use java; then
+ java-pkg_dojar java/libsvm.jar
+ HTML_DOCS+=( java/test_applet.html )
+ fi
+
+ einstalldocs
+}