summaryrefslogtreecommitdiff
path: root/sci-libs/libspatialindex/libspatialindex-1.8.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/libspatialindex/libspatialindex-1.8.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/libspatialindex/libspatialindex-1.8.1.ebuild')
-rw-r--r--sci-libs/libspatialindex/libspatialindex-1.8.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-libs/libspatialindex/libspatialindex-1.8.1.ebuild b/sci-libs/libspatialindex/libspatialindex-1.8.1.ebuild
new file mode 100644
index 000000000000..27123fc01822
--- /dev/null
+++ b/sci-libs/libspatialindex/libspatialindex-1.8.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools eutils
+
+MY_PN="spatialindex-src"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="General framework for developing spatial indices"
+HOMEPAGE="https://libspatialindex.github.com/"
+SRC_URI="http://download.osgeo.org/libspatialindex/${MY_P}.tar.bz2"
+LICENSE="MIT"
+
+KEYWORDS="amd64 x86"
+SLOT="0"
+IUSE="debug static-libs"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-{QA,pkgconfig}.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+}