summaryrefslogtreecommitdiff
path: root/sci-libs/libmuscle/files/libmuscle-3.7-fix-build-system.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/libmuscle/files/libmuscle-3.7-fix-build-system.patch
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/libmuscle/files/libmuscle-3.7-fix-build-system.patch')
-rw-r--r--sci-libs/libmuscle/files/libmuscle-3.7-fix-build-system.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/sci-libs/libmuscle/files/libmuscle-3.7-fix-build-system.patch b/sci-libs/libmuscle/files/libmuscle-3.7-fix-build-system.patch
new file mode 100644
index 000000000000..2b2c28c8132a
--- /dev/null
+++ b/sci-libs/libmuscle/files/libmuscle-3.7-fix-build-system.patch
@@ -0,0 +1,21 @@
+* Make build system parallel buildable
+* Remove -funroll-loops and friends
+
+--- a/libMUSCLE/Makefile.am
++++ b/libMUSCLE/Makefile.am
+@@ -1,6 +1,4 @@
+-OPTIMIZATION = -O2 -Wall -funroll-loops -fomit-frame-pointer -ftree-vectorize -funsafe-math-optimizations
+-AM_CXXFLAGS = $(OPTIMIZATION) -DNDEBUG=1 @OPENMP_CXXFLAGS@
+-AM_LDFLAGS = $(OPTIMIZATION)
++AM_CXXFLAGS = -DNDEBUG=1 @OPENMP_CXXFLAGS@
+
+ LIBMUSCLE_H = \
+ alpha.h cluster.h clust.h clustsetdf.h clustset.h clustsetmsa.h diaglist.h distcalc.h distfunc.h dpregionlist.h dpreglist.h edgelist.h enumopts.h enums.h estring.h gapscoredimer.h gonnet.h intmath.h msadist.h msa.h muscle.h objscore.h params.h profile.h pwpath.h refine.h scorehistory.h seq.h seqvect.h textfile.h timing.h tree.h types.h unixio.h threadstorage.h
+@@ -36,6 +34,6 @@
+
+
+ muscle_SOURCES = main.cpp
+-muscle_LDADD = $(top_builddir)/libMUSCLE/libMUSCLE-3.7.la
++muscle_LDADD = libMUSCLE-3.7.la
+
+