summaryrefslogtreecommitdiff
path: root/sci-libs/libghemical/libghemical-3.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/libghemical/libghemical-3.0.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/libghemical/libghemical-3.0.0.ebuild')
-rw-r--r--sci-libs/libghemical/libghemical-3.0.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sci-libs/libghemical/libghemical-3.0.0.ebuild b/sci-libs/libghemical/libghemical-3.0.0.ebuild
new file mode 100644
index 000000000000..6a3c64969ac5
--- /dev/null
+++ b/sci-libs/libghemical/libghemical-3.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Chemical quantum mechanics and molecular mechanics"
+HOMEPAGE="http://bioinformatics.org/ghemical/"
+SRC_URI="http://www.bioinformatics.org/ghemical/download/current/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="mopac7 mpqc static-libs"
+
+RDEPEND="
+ mopac7? ( >=sci-chemistry/mopac7-1.13-r1 )
+ mpqc? (
+ >=sci-chemistry/mpqc-2.3.1-r1
+ virtual/blas
+ virtual/lapack
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.98-gl.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable mopac7) \
+ $(use_enable mpqc) \
+ $(use_enable static-libs static)
+}