summaryrefslogtreecommitdiff
path: root/sci-libs/libgeotiff
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /sci-libs/libgeotiff
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'sci-libs/libgeotiff')
-rw-r--r--sci-libs/libgeotiff/Manifest2
-rw-r--r--sci-libs/libgeotiff/libgeotiff-1.4.1-r1.ebuild (renamed from sci-libs/libgeotiff/libgeotiff-1.4.1.ebuild)25
2 files changed, 9 insertions, 18 deletions
diff --git a/sci-libs/libgeotiff/Manifest b/sci-libs/libgeotiff/Manifest
index d65c29768d8d..b6341525473e 100644
--- a/sci-libs/libgeotiff/Manifest
+++ b/sci-libs/libgeotiff/Manifest
@@ -2,5 +2,5 @@ AUX Doxyfile 9282 BLAKE2B 0dcda644c528df5bd495db1785ce0f3213f0ce0c3551205e9c043a
DIST libgeotiff-1.4.0.tar.gz 1517881 BLAKE2B 5340029481b1d529626170e61b73948a620cf24e86297178eb84a76e4988dd5bde2c278f995d39fa598a84eaaac69e93a62e7d091a77830c5fd16a43cb20a750 SHA512 1336e9b5345d69c47807f350d2f757c753543fecc477a6fc036743e78fbfca7b7f99db1b0fdf03e80418fbd4c66db100d04ac7c3338913f9a2b922b9c9f91f1b
DIST libgeotiff-1.4.1.tar.gz 1674928 BLAKE2B 6c83ca77728c40995bf262d165c8566573c995f0d0116a3756f688b5686ff6529295d3340afdd771268c80050fb81b10953f7ae7339c46ed23d44dbd73cf302d SHA512 4a68bd7b9adf7453fdcb8f98cdeb79289b5f21315d1ef91d54fcc01724c8d687d243826c05a5523bb08c930296335959d2290916d46b6d802e63ac9be727c628
EBUILD libgeotiff-1.4.0.ebuild 1504 BLAKE2B 1fe286a7dd5709b2ba11c68161e2e6eed9ef36e2388c2e43fddb2f394e9af5e02e6f8b273649fd54e90c4215474a8d3fda1226bf99832a505a3a53e964a35a1b SHA512 7ead72d31550a10908d9a5e54ef6954bd4ba5ed9987f5fb5ce40e74abecf22c237a29e2591664eb9b0871a83c451408202732fad2308b3601f0b748c981b824d
-EBUILD libgeotiff-1.4.1.ebuild 1516 BLAKE2B dd80fa3723a7d3bfde18b60d0e0cbb7b76253ab71a990f246f217e300d9f8fecb3dd4e889892d53de3f956b63e572cff09852018d5dae58a23eb90b94212d108 SHA512 2d0b269239a6d8e273a5aa2072e4b8e886fa7968ad94a6dd7adc5f5e5692c2be351d715d92dc0eeac7cf4a902bb5430d32192427a3295991525a2d2c08adbe51
+EBUILD libgeotiff-1.4.1-r1.ebuild 1288 BLAKE2B 29d7fc36597ec31717fdcfdda203123b972069af3364f3d27f8782563ceb11b76d0a9f29bc0579314077f58397ca4489320736e306ecab64f66462d89fbbeb70 SHA512 e5fc2a4623d9a5f94dda82b0fd4d00e10b86c9f3e27fbebc05b84fb11e4b506b07209de809b1310b3b4e36d80951f47b9a61dc1bbcc6d4a4b1a2bf3605e2fd52
MISC metadata.xml 275 BLAKE2B 054c49c4cc7e0607212f55ec7e66b38585457f74ce21e0483503814df58d31dee0b784e9b0bd9cdf0c8fca04e7454bd1b515085e5aac2c0d7fd2700df08c9b26 SHA512 5877508750864819a1d129ac2406c0d11721cd0e4e64d55c9bd6a44649991fda435e7752e841cca94b348f74078226f12e90dcdd323915bce3d601e65865c225
diff --git a/sci-libs/libgeotiff/libgeotiff-1.4.1.ebuild b/sci-libs/libgeotiff/libgeotiff-1.4.1-r1.ebuild
index d2e161b24ea7..d30e21eb05f2 100644
--- a/sci-libs/libgeotiff/libgeotiff-1.4.1.ebuild
+++ b/sci-libs/libgeotiff/libgeotiff-1.4.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-inherit autotools eutils
+inherit autotools
MY_P=${P/_rc/RC}
@@ -30,7 +30,7 @@ S=${WORKDIR}/${MY_P/RC*/}
DOCS=( README ChangeLog )
src_prepare() {
- epatch_user
+ default
sed -i \
-e "s:-O3::g" \
configure.ac || die
@@ -40,7 +40,7 @@ src_prepare() {
src_configure() {
econf \
$(use_enable static-libs static) \
- --enable-debug=$(use debug && echo yes || echo no) \
+ --enable-debug=$(usex debug) \
--with-jpeg="${EPREFIX}"/usr/ \
--with-zip="${EPREFIX}"/usr/
@@ -49,8 +49,8 @@ src_compile() {
default
if use doc; then
- mkdir -p docs/api
- cp "${FILESDIR}"/Doxyfile Doxyfile
+ mkdir -p docs/api || die
+ cp "${FILESDIR}"/Doxyfile Doxyfile || die
doxygen -u Doxyfile || die "updating doxygen config failed"
doxygen Doxyfile || die "docs generation failed"
fi
@@ -60,14 +60,5 @@ src_install() {
default
use doc && dohtml docs/api/*
- prune_libtool_files
-}
-
-pkg_postinst() {
- echo
- ewarn "You should rebuild any packages built against ${PN} by running:"
- ewarn "# revdep-rebuild"
- ewarn "or using preserved-rebuild features of portage-2.2:"
- ewarn "# emerge @preserved-rebuild"
- echo
+ find "${D}" -name '*.la' -delete || die
}