summaryrefslogtreecommitdiff
path: root/sci-libs/libgeodecomp/libgeodecomp-0.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/libgeodecomp/libgeodecomp-0.3.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/libgeodecomp/libgeodecomp-0.3.1.ebuild')
-rw-r--r--sci-libs/libgeodecomp/libgeodecomp-0.3.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sci-libs/libgeodecomp/libgeodecomp-0.3.1.ebuild b/sci-libs/libgeodecomp/libgeodecomp-0.3.1.ebuild
new file mode 100644
index 000000000000..095cf09eafa5
--- /dev/null
+++ b/sci-libs/libgeodecomp/libgeodecomp-0.3.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="An auto-parallelizing library to speed up computer simulations"
+HOMEPAGE="http://www.libgeodecomp.org"
+SRC_URI="http://www.libgeodecomp.org/archive/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="Boost-1.0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc examples"
+
+RDEPEND=">=dev-libs/boost-1.48"
+DEPEND="${RDEPEND}
+ dev-libs/libflatarray
+ examples? ( !sys-cluster/mpich2 )"
+
+S="${WORKDIR}/${P}/src"
+
+src_prepare() {
+ epatch "${FILESDIR}/libflatarray.patch"
+ sed -i 's/libdir=${CMAKE_INSTALL_PREFIX}\/lib/libdir=\/usr\/'$(get_libdir)'/' "${S}/CMakeLists.txt"
+ sed -i 's/install(TARGETS geodecomp DESTINATION lib)/install(TARGETS geodecomp DESTINATION '$(get_libdir)')/' "${S}/CMakeLists.txt"
+
+ if ! use examples ; then
+ sed -i 's/examples//g' CMakeLists.txt
+ fi
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use doc && cmake-utils_src_make doc
+}
+
+src_install() {
+ DOCS=( ../README )
+ use doc && HTML_DOCS=( ../doc/html/* )
+ cmake-utils_src_install
+}
+
+src_test() {
+ cmake-utils_src_make test
+}