summaryrefslogtreecommitdiff
path: root/sci-libs/libgeodecomp/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /sci-libs/libgeodecomp/files
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'sci-libs/libgeodecomp/files')
-rw-r--r--sci-libs/libgeodecomp/files/libgeodecomp-0.4.0-lfa.patch37
-rw-r--r--sci-libs/libgeodecomp/files/libgeodecomp-0.5.0_pre20200314-hpx.patch246
-rw-r--r--sci-libs/libgeodecomp/files/libgeodecomp-0.5.0_pre20200314-libdir.patch (renamed from sci-libs/libgeodecomp/files/libgeodecomp-0.4.0-libdir.patch)19
-rw-r--r--sci-libs/libgeodecomp/files/libgeodecomp-0.5.0_pre20200314-mpi.patch (renamed from sci-libs/libgeodecomp/files/libgeodecomp-0.4.0-scotch.patch)139
-rw-r--r--sci-libs/libgeodecomp/files/libgeodecomp-0.5.0_pre20200314-warnings.patch33
5 files changed, 429 insertions, 45 deletions
diff --git a/sci-libs/libgeodecomp/files/libgeodecomp-0.4.0-lfa.patch b/sci-libs/libgeodecomp/files/libgeodecomp-0.4.0-lfa.patch
deleted file mode 100644
index 463d416b3bf6..000000000000
--- a/sci-libs/libgeodecomp/files/libgeodecomp-0.4.0-lfa.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index 673017f0..28704461 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -528,18 +528,20 @@ foreach(dir ${LIBDIRS})
- endforeach(dir)
-
- # install libflatarray, too
--file(GLOB HEADERS "${CMAKE_CURRENT_SOURCE_DIR}/../lib/libflatarray/src/*.hpp")
--foreach(i ${HEADERS})
-- install(FILES ${i} DESTINATION include/libflatarray)
--endforeach()
--file(GLOB HEADERS "${CMAKE_CURRENT_SOURCE_DIR}/../lib/libflatarray/src/detail/*.hpp")
--foreach(i ${HEADERS})
-- install(FILES ${i} DESTINATION include/libflatarray/detail)
--endforeach()
--file(GLOB HEADERS "${CMAKE_CURRENT_SOURCE_DIR}/../lib/libflatarray/src/testbed/*.hpp")
--foreach(i ${HEADERS})
-- install(FILES ${i} DESTINATION include/libflatarray/testbed)
--endforeach()
-+if(NOT libflatarray_FOUND)
-+ file(GLOB HEADERS "${CMAKE_CURRENT_SOURCE_DIR}/../lib/libflatarray/src/*.hpp")
-+ foreach(i ${HEADERS})
-+ install(FILES ${i} DESTINATION include/libflatarray)
-+ endforeach()
-+ file(GLOB HEADERS "${CMAKE_CURRENT_SOURCE_DIR}/../lib/libflatarray/src/detail/*.hpp")
-+ foreach(i ${HEADERS})
-+ install(FILES ${i} DESTINATION include/libflatarray/detail)
-+ endforeach()
-+ file(GLOB HEADERS "${CMAKE_CURRENT_SOURCE_DIR}/../lib/libflatarray/src/testbed/*.hpp")
-+ foreach(i ${HEADERS})
-+ install(FILES ${i} DESTINATION include/libflatarray/testbed)
-+ endforeach()
-+endif()
-
- # link against the libs we need
- set(INSTALLER_LINK_FLAGS "-L${CMAKE_INSTALL_PREFIX}/${LIB_DIR} -Wl,-rpath,${CMAKE_INSTALL_PREFIX}/${LIB_DIR} -lgeodecomp ")
diff --git a/sci-libs/libgeodecomp/files/libgeodecomp-0.5.0_pre20200314-hpx.patch b/sci-libs/libgeodecomp/files/libgeodecomp-0.5.0_pre20200314-hpx.patch
new file mode 100644
index 000000000000..9f71ea087c69
--- /dev/null
+++ b/sci-libs/libgeodecomp/files/libgeodecomp-0.5.0_pre20200314-hpx.patch
@@ -0,0 +1,246 @@
+From fe581cc24805288c6c1a9b26a4b72748906f16c8 Mon Sep 17 00:00:00 2001
+From: Kurt Kanzenbach <kurt@kmk-computers.de>
+Date: Thu, 26 Mar 2020 15:58:46 +0100
+Subject: [PATCH] hpx: Remove use of deprecated header
+
+The current hpx version is v1.4. Remove the usage of deprecated hpx headers and
+make it compile again.
+
+Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de>
+---
+ src/libgeodecomp/communication/hpxreceiver.h | 5 ++---
+ src/libgeodecomp/communication/hpxserializationwrapper.h | 8 ++++----
+ .../communication/test/parallel_hpx_4/hpxreceivertest.h | 5 ++---
+ src/libgeodecomp/geometry/coord.h | 4 ++--
+ src/libgeodecomp/io/mocksteerer.h | 5 +++++
+ src/libgeodecomp/io/mockwriter.h | 5 +++++
+ src/libgeodecomp/misc/clonable.h | 2 +-
+ src/libgeodecomp/misc/nonpodtestcell.h | 2 +-
+ src/libgeodecomp/parallelization/hpxsimulator.cpp | 2 +-
+ src/libgeodecomp/parallelization/hpxsimulator.h | 9 ++++-----
+ src/libgeodecomp/storage/displacedgrid.h | 4 ++--
+ src/libgeodecomp/storage/grid.h | 4 ++--
+ src/libgeodecomp/storage/patchprovider.h | 3 ++-
+ .../storage/test/unit/reorderingunstructuredgridtest.h | 4 ++--
+ 14 files changed, 35 insertions(+), 27 deletions(-)
+
+diff --git a/src/libgeodecomp/communication/hpxreceiver.h b/src/libgeodecomp/communication/hpxreceiver.h
+index 1a0baf9bbdee..beb657b88bbc 100644
+--- a/src/libgeodecomp/communication/hpxreceiver.h
++++ b/src/libgeodecomp/communication/hpxreceiver.h
+@@ -10,10 +10,9 @@
+
+ #include <hpx/include/components.hpp>
+ #include <hpx/include/lcos.hpp>
+-#include <hpx/lcos/broadcast.hpp>
+-#include <hpx/lcos/local/receive_buffer.hpp>
++#include <hpx/collectives/broadcast.hpp>
++#include <hpx/local_lcos/receive_buffer.hpp>
+ #include <hpx/runtime/get_ptr.hpp>
+-#include <hpx/util/unwrapped.hpp>
+ #include <libgeodecomp/communication/hpxserializationwrapper.h>
+ #include <libgeodecomp/misc/stringops.h>
+
+diff --git a/src/libgeodecomp/communication/hpxserializationwrapper.h b/src/libgeodecomp/communication/hpxserializationwrapper.h
+index 5ebf06c4cf7c..0afb145840a6 100644
+--- a/src/libgeodecomp/communication/hpxserializationwrapper.h
++++ b/src/libgeodecomp/communication/hpxserializationwrapper.h
+@@ -10,10 +10,10 @@
+ * just pull in this header.
+ */
+ #include <libgeodecomp/communication/hpxserialization.h>
+-#include <hpx/runtime/serialization/map.hpp>
+-#include <hpx/runtime/serialization/serialize.hpp>
+-#include <hpx/runtime/serialization/shared_ptr.hpp>
+-#include <hpx/runtime/serialization/vector.hpp>
++#include <hpx/serialization/map.hpp>
++#include <hpx/serialization/serialize.hpp>
++#include <hpx/serialization/shared_ptr.hpp>
++#include <hpx/serialization/vector.hpp>
+
+ #endif
+
+diff --git a/src/libgeodecomp/communication/test/parallel_hpx_4/hpxreceivertest.h b/src/libgeodecomp/communication/test/parallel_hpx_4/hpxreceivertest.h
+index ab16a0947546..b2f9c6d47559 100644
+--- a/src/libgeodecomp/communication/test/parallel_hpx_4/hpxreceivertest.h
++++ b/src/libgeodecomp/communication/test/parallel_hpx_4/hpxreceivertest.h
+@@ -1,9 +1,8 @@
+ #include <cxxtest/TestSuite.h>
+ #include <hpx/hpx.hpp>
+-#include <hpx/lcos/broadcast.hpp>
++#include <hpx/collectives/broadcast.hpp>
+ #include <hpx/runtime/components/component_factory.hpp>
+-#include <hpx/runtime/serialization/serialize_buffer.hpp>
+-#include <hpx/util/unwrapped.hpp>
++#include <hpx/serialization/serialize_buffer.hpp>
+ #include <libgeodecomp/communication/hpxreceiver.h>
+ #include <libgeodecomp/misc/stringops.h>
+
+diff --git a/src/libgeodecomp/geometry/coord.h b/src/libgeodecomp/geometry/coord.h
+index 5df21310d3ee..8772980c52df 100644
+--- a/src/libgeodecomp/geometry/coord.h
++++ b/src/libgeodecomp/geometry/coord.h
+@@ -10,8 +10,8 @@
+ #ifdef LIBGEODECOMP_WITH_HPX
+ #include <libgeodecomp/misc/cudaboostworkaround.h>
+ #include <hpx/config.hpp>
+-#include <hpx/runtime/serialization/array.hpp>
+-#include <hpx/runtime/serialization/serialize.hpp>
++#include <hpx/serialization/array.hpp>
++#include <hpx/serialization/serialize.hpp>
+ #endif
+
+ // For Intel MPI we need to source mpi.h before stdio.h:
+diff --git a/src/libgeodecomp/io/mocksteerer.h b/src/libgeodecomp/io/mocksteerer.h
+index 4ab2d28c5097..e20d0d5bb6bf 100644
+--- a/src/libgeodecomp/io/mocksteerer.h
++++ b/src/libgeodecomp/io/mocksteerer.h
+@@ -4,6 +4,11 @@
+ #include <sstream>
+ #include <libgeodecomp/io/steerer.h>
+
++#ifdef LIBGEODECOMP_WITH_HPX
++#include <hpx/include/threads.hpp>
++#include <hpx/concurrency/spinlock.hpp>
++#endif
++
+ namespace LibGeoDecomp {
+
+ namespace MockSteererHelpers {
+diff --git a/src/libgeodecomp/io/mockwriter.h b/src/libgeodecomp/io/mockwriter.h
+index 4d6d13c93acb..36cb7e1e1ae6 100644
+--- a/src/libgeodecomp/io/mockwriter.h
++++ b/src/libgeodecomp/io/mockwriter.h
+@@ -8,6 +8,11 @@
+ #include <libgeodecomp/misc/clonable.h>
+ #include <libgeodecomp/misc/testcell.h>
+
++#ifdef LIBGEODECOMP_WITH_HPX
++#include <hpx/include/threads.hpp>
++#include <hpx/concurrency/spinlock.hpp>
++#endif
++
+ #include <sstream>
+
+ namespace LibGeoDecomp {
+diff --git a/src/libgeodecomp/misc/clonable.h b/src/libgeodecomp/misc/clonable.h
+index 8162513826b8..a1dccbf94bd3 100644
+--- a/src/libgeodecomp/misc/clonable.h
++++ b/src/libgeodecomp/misc/clonable.h
+@@ -5,7 +5,7 @@
+
+ #ifdef LIBGEODECOMP_WITH_HPX
+ #include <libgeodecomp/misc/cudaboostworkaround.h>
+-#include <hpx/runtime/serialization/base_object.hpp>
++#include <hpx/serialization/base_object.hpp>
+ #endif
+
+ namespace LibGeoDecomp {
+diff --git a/src/libgeodecomp/misc/nonpodtestcell.h b/src/libgeodecomp/misc/nonpodtestcell.h
+index 66453ce80ba7..1618c8359b90 100644
+--- a/src/libgeodecomp/misc/nonpodtestcell.h
++++ b/src/libgeodecomp/misc/nonpodtestcell.h
+@@ -11,7 +11,7 @@
+ #endif
+
+ #ifdef LIBGEODECOMP_WITH_HPX
+-#include <hpx/runtime/serialization/set.hpp>
++#include <hpx/serialization/set.hpp>
+ #endif
+
+ namespace LibGeoDecomp {
+diff --git a/src/libgeodecomp/parallelization/hpxsimulator.cpp b/src/libgeodecomp/parallelization/hpxsimulator.cpp
+index 6e2fb6c78519..0329d6815913 100644
+--- a/src/libgeodecomp/parallelization/hpxsimulator.cpp
++++ b/src/libgeodecomp/parallelization/hpxsimulator.cpp
+@@ -3,7 +3,7 @@
+
+ #include <libgeodecomp/parallelization/hpxsimulator.h>
+ #include <hpx/include/lcos.hpp>
+-#include <hpx/lcos/broadcast.hpp>
++#include <hpx/collectives/broadcast.hpp>
+
+ namespace LibGeoDecomp {
+ namespace HpxSimulatorHelpers {
+diff --git a/src/libgeodecomp/parallelization/hpxsimulator.h b/src/libgeodecomp/parallelization/hpxsimulator.h
+index 1ccdf883e915..15b5a3628f9d 100644
+--- a/src/libgeodecomp/parallelization/hpxsimulator.h
++++ b/src/libgeodecomp/parallelization/hpxsimulator.h
+@@ -6,11 +6,10 @@
+
+ #include <libgeodecomp/misc/cudaboostworkaround.h>
+ #include <hpx/config.hpp>
+-#include <hpx/runtime/serialization/set.hpp>
+-#include <hpx/runtime/serialization/string.hpp>
+-#include <hpx/runtime/serialization/vector.hpp>
+-#include <hpx/include/lcos.hpp>
+-#include <hpx/lcos/broadcast.hpp>
++#include <hpx/serialization/set.hpp>
++#include <hpx/serialization/string.hpp>
++#include <hpx/serialization/vector.hpp>
++#include <hpx/collectives/broadcast.hpp>
+
+ #include <libgeodecomp/communication/hpxserializationwrapper.h>
+ #include <libgeodecomp/geometry/partitions/stripingpartition.h>
+diff --git a/src/libgeodecomp/storage/displacedgrid.h b/src/libgeodecomp/storage/displacedgrid.h
+index 5c72e520ce48..a8831053fedc 100644
+--- a/src/libgeodecomp/storage/displacedgrid.h
++++ b/src/libgeodecomp/storage/displacedgrid.h
+@@ -19,8 +19,8 @@
+ #ifdef LIBGEODECOMP_WITH_HPX
+ #include <libgeodecomp/misc/cudaboostworkaround.h>
+ #include <libgeodecomp/communication/hpxserializationwrapper.h>
+-#include <hpx/runtime/serialization/input_archive.hpp>
+-#include <hpx/runtime/serialization/output_archive.hpp>
++#include <hpx/serialization/input_archive.hpp>
++#include <hpx/serialization/output_archive.hpp>
+ #endif
+
+ namespace LibGeoDecomp {
+diff --git a/src/libgeodecomp/storage/grid.h b/src/libgeodecomp/storage/grid.h
+index 6e218696f625..821b02002c87 100644
+--- a/src/libgeodecomp/storage/grid.h
++++ b/src/libgeodecomp/storage/grid.h
+@@ -26,8 +26,8 @@
+ #ifdef LIBGEODECOMP_WITH_HPX
+ #include <libgeodecomp/misc/cudaboostworkaround.h>
+ #include <libgeodecomp/communication/hpxserializationwrapper.h>
+-#include <hpx/runtime/serialization/input_archive.hpp>
+-#include <hpx/runtime/serialization/output_archive.hpp>
++#include <hpx/serialization/input_archive.hpp>
++#include <hpx/serialization/output_archive.hpp>
+ #endif
+
+ namespace LibGeoDecomp {
+diff --git a/src/libgeodecomp/storage/patchprovider.h b/src/libgeodecomp/storage/patchprovider.h
+index 71fda8091e95..66aa67f214fa 100644
+--- a/src/libgeodecomp/storage/patchprovider.h
++++ b/src/libgeodecomp/storage/patchprovider.h
+@@ -2,7 +2,8 @@
+ #define LIBGEODECOMP_STORAGE_PATCHPROVIDER_H
+
+ #ifdef LIBGEODECOMP_WITH_HPX
+-#include <hpx/lcos/local/spinlock.hpp>
++#include <hpx/include/threads.hpp>
++#include <hpx/synchronization/spinlock.hpp>
+ #include <mutex>
+ #endif
+
+diff --git a/src/libgeodecomp/storage/test/unit/reorderingunstructuredgridtest.h b/src/libgeodecomp/storage/test/unit/reorderingunstructuredgridtest.h
+index d89146a4bf69..7cb5203dae44 100644
+--- a/src/libgeodecomp/storage/test/unit/reorderingunstructuredgridtest.h
++++ b/src/libgeodecomp/storage/test/unit/reorderingunstructuredgridtest.h
+@@ -19,8 +19,8 @@
+ #ifdef LIBGEODECOMP_WITH_HPX
+ #include <libgeodecomp/misc/cudaboostworkaround.h>
+ #include <libgeodecomp/communication/hpxserializationwrapper.h>
+-#include <hpx/runtime/serialization/input_archive.hpp>
+-#include <hpx/runtime/serialization/output_archive.hpp>
++#include <hpx/serialization/input_archive.hpp>
++#include <hpx/serialization/output_archive.hpp>
+ #endif
+
+ using namespace LibGeoDecomp;
+--
+2.24.1
+
diff --git a/sci-libs/libgeodecomp/files/libgeodecomp-0.4.0-libdir.patch b/sci-libs/libgeodecomp/files/libgeodecomp-0.5.0_pre20200314-libdir.patch
index 39da128feff8..d76930d83ca1 100644
--- a/sci-libs/libgeodecomp/files/libgeodecomp-0.4.0-libdir.patch
+++ b/sci-libs/libgeodecomp/files/libgeodecomp-0.5.0_pre20200314-libdir.patch
@@ -1,11 +1,21 @@
+From b03cef449361bef6d65f40382227714e0e0980c3 Mon Sep 17 00:00:00 2001
+From: Kurt Kanzenbach <kurt@kmk-computers.de>
+Date: Fri, 21 Feb 2020 19:47:51 +0100
+Subject: [PATCH] cmake: Fix library installation directory
+
+Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de>
+---
+ src/CMakeLists.txt | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index 0666f1d..673017f 100644
+index b82d667087ba..f4ea6b379ec7 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
-@@ -509,11 +509,12 @@ endif()
+@@ -335,11 +335,12 @@ endif()
target_link_libraries(geodecomp ${LIBGEODECOMP_LINK_LIBRARIES})
- #============= 10. INSTALLER CONFIG ==================================
+ #============= 6. INSTALLER CONFIG ===================================
+include(GNUInstallDirs)
install(
TARGETS geodecomp
@@ -17,3 +27,6 @@ index 0666f1d..673017f 100644
install(FILES "${CMAKE_BINARY_DIR}/${PACKAGE_NAME}/config.h" DESTINATION include/${PACKAGE_NAME})
install(FILES libgeodecomp.h DESTINATION include)
+--
+2.24.1
+
diff --git a/sci-libs/libgeodecomp/files/libgeodecomp-0.4.0-scotch.patch b/sci-libs/libgeodecomp/files/libgeodecomp-0.5.0_pre20200314-mpi.patch
index 774293f34c4a..1a1164e342be 100644
--- a/sci-libs/libgeodecomp/files/libgeodecomp-0.4.0-scotch.patch
+++ b/sci-libs/libgeodecomp/files/libgeodecomp-0.5.0_pre20200314-mpi.patch
@@ -1,8 +1,48 @@
+From 55356ab9c03cd25efeb5176761f2f5b3744b4371 Mon Sep 17 00:00:00 2001
+From: Kurt Kanzenbach <kurt@kmk-computers.de>
+Date: Fri, 24 Jan 2020 17:59:48 +0100
+Subject: [PATCH] cmake: Disable mpiruns
+
+The mpiruns will violate the sandboxing. Therefore, disable them including
+scotch.
+
+Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de>
+---
+ CMakeLists.txt | 14 +-
+ CMakeModules/FindSCOTCH.cmake | 238 +++++++++++++++++-----------------
+ 2 files changed, 121 insertions(+), 131 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index ed5cc607c3ed..fec488002958 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -238,19 +238,9 @@ if (MACHINE_ARCH MATCHES "x86_64")
+ set(AMD64_LINUX true)
+ endif()
+
+-# test if mpirun/mpiexec supports the --oversubscribe flag:
++# use the --oversubscribe flag:
+ if(MPI_FOUND)
+- execute_process(
+- COMMAND ${MPIEXEC} --oversubscribe ${MPIEXEC_NUMPROC_FLAG} 4 echo ok
+- RESULT_VARIABLE MPIEXEC_OVERSUBSCRIBE_RETURN_CODE
+- OUTPUT_QUIET
+- ERROR_QUIET)
+-
+- if (MPIEXEC_OVERSUBSCRIBE_RETURN_CODE EQUAL 0)
+- set(MPIEXEC_OVERSUBSCRIBE_FLAG "--oversubscribe")
+- else()
+- set(MPIEXEC_OVERSUBSCRIBE_FLAG "")
+- endif()
++ set(MPIEXEC_OVERSUBSCRIBE_FLAG "--oversubscribe")
+ endif()
+
+ #============= 3. CONFIGURABLE BUILD OPTIONS =========================
diff --git a/CMakeModules/FindSCOTCH.cmake b/CMakeModules/FindSCOTCH.cmake
-index 9f22b8d..0755470 100644
+index 5c717977dbba..146c2bf8bb60 100644
--- a/CMakeModules/FindSCOTCH.cmake
+++ b/CMakeModules/FindSCOTCH.cmake
-@@ -232,81 +232,83 @@ int main() {
+@@ -233,125 +233,125 @@ int main() {
")
message(STATUS "Performing test SCOTCH_TEST_RUNS")
@@ -81,8 +121,50 @@ index 9f22b8d..0755470 100644
-
- endif()
- endif()
-+ set(SCOTCH_TEST_RUNS FALSE)
-+ message(STATUS "Performing test SCOTCH_TEST_RUNS - Failed")
+-
+- if(NOT SCOTCH_TEST_RUNS)
+- if (NOT BZIP2_FOUND)
+- find_package(BZip2)
+- endif()
+-
+- if (BZIP2_INCLUDE_DIR AND BZIP2_LIBRARIES)
+- set(CMAKE_REQUIRED_INCLUDES ${CMAKE_REQUIRED_INCLUDES} ${BZIP2_INCLUDE_DIR})
+- set(CMAKE_REQUIRED_LIBRARIES ${CMAKE_REQUIRED_LIBRARIES} ${BZIP2_LIBRARIES})
+-
+- message(STATUS "Performing test SCOTCH_BZIP2_TEST_RUNS")
+- try_run(
+- SCOTCH_BZIP2_TEST_LIB_EXITCODE
+- SCOTCH_BZIP2_TEST_LIB_COMPILED
+- ${CMAKE_CURRENT_BINARY_DIR}
+- ${SCOTCH_TEST_LIB_CPP}
+- CMAKE_FLAGS
+- "-DINCLUDE_DIRECTORIES:STRING=${CMAKE_REQUIRED_INCLUDES}"
+- "-DLINK_LIBRARIES:STRING=${CMAKE_REQUIRED_LIBRARIES}"
+- COMPILE_OUTPUT_VARIABLE SCOTCH_BZIP2_TEST_LIB_COMPILE_OUTPUT
+- RUN_OUTPUT_VARIABLE SCOTCH_BZIP2_TEST_LIB_OUTPUT
+- )
+-
+- # Add zlib flags if required and set test run to 'true'
+- if (SCOTCH_BZIP2_TEST_LIB_COMPILED AND SCOTCH_BZIP2_TEST_LIB_EXITCODE EQUAL 0)
+- message(STATUS "Performing test SCOTCH_BZIP2_TEST_RUNS - Success")
+- set(SCOTCH_INCLUDE_DIRS ${SCOTCH_INCLUDE_DIRS} ${BZIP2_INCLUDE_DIR})
+- set(SCOTCH_LIBRARIES ${SCOTCH_LIBRARIES} ${BZIP2_LIBRARIES})
+- set(SCOTCH_TEST_RUNS TRUE)
+- else()
+- message(STATUS "Performing test SCOTCH_BZIP2_TEST_RUNS - Failed")
+- if (SCOTCH_DEBUG)
+- message(STATUS "[ ${CMAKE_CURRENT_LIST_FILE}:${CMAKE_CURRENT_LIST_LINE} ] "
+- "SCOTCH_BZIP2_TEST_LIB_COMPILED = ${SCOTCH_BZIP2_TEST_LIB_COMPILED}")
+- message(STATUS "[ ${CMAKE_CURRENT_LIST_FILE}:${CMAKE_CURRENT_LIST_LINE} ] "
+- "SCOTCH_BZIP2_TEST_LIB_COMPILE_OUTPUT = ${SCOTCH_BZIP2_TEST_LIB_COMPILE_OUTPUT}")
+- message(STATUS "[ ${CMAKE_CURRENT_LIST_FILE}:${CMAKE_CURRENT_LIST_LINE} ] "
+- "SCOTCH_TEST_LIB_EXITCODE = ${SCOTCH_TEST_LIB_EXITCODE}")
+- message(STATUS "[ ${CMAKE_CURRENT_LIST_FILE}:${CMAKE_CURRENT_LIST_LINE} ] "
+- "SCOTCH_TEST_LIB_OUTPUT = ${SCOTCH_TEST_LIB_OUTPUT}")
+- endif()
+- endif()
+- endif()
+- endif()
+ # try_run(
+ # SCOTCH_TEST_LIB_EXITCODE
+ # SCOTCH_TEST_LIB_COMPILED
@@ -158,6 +240,53 @@ index 9f22b8d..0755470 100644
+
+ # endif()
+ # endif()
++
++ # if(NOT SCOTCH_TEST_RUNS)
++ # if (NOT BZIP2_FOUND)
++ # find_package(BZip2)
++ # endif()
++
++ # if (BZIP2_INCLUDE_DIR AND BZIP2_LIBRARIES)
++ # set(CMAKE_REQUIRED_INCLUDES ${CMAKE_REQUIRED_INCLUDES} ${BZIP2_INCLUDE_DIR})
++ # set(CMAKE_REQUIRED_LIBRARIES ${CMAKE_REQUIRED_LIBRARIES} ${BZIP2_LIBRARIES})
++
++ # message(STATUS "Performing test SCOTCH_BZIP2_TEST_RUNS")
++ # try_run(
++ # SCOTCH_BZIP2_TEST_LIB_EXITCODE
++ # SCOTCH_BZIP2_TEST_LIB_COMPILED
++ # ${CMAKE_CURRENT_BINARY_DIR}
++ # ${SCOTCH_TEST_LIB_CPP}
++ # CMAKE_FLAGS
++ # "-DINCLUDE_DIRECTORIES:STRING=${CMAKE_REQUIRED_INCLUDES}"
++ # "-DLINK_LIBRARIES:STRING=${CMAKE_REQUIRED_LIBRARIES}"
++ # COMPILE_OUTPUT_VARIABLE SCOTCH_BZIP2_TEST_LIB_COMPILE_OUTPUT
++ # RUN_OUTPUT_VARIABLE SCOTCH_BZIP2_TEST_LIB_OUTPUT
++ # )
++
++ # # Add zlib flags if required and set test run to 'true'
++ # if (SCOTCH_BZIP2_TEST_LIB_COMPILED AND SCOTCH_BZIP2_TEST_LIB_EXITCODE EQUAL 0)
++ # message(STATUS "Performing test SCOTCH_BZIP2_TEST_RUNS - Success")
++ # set(SCOTCH_INCLUDE_DIRS ${SCOTCH_INCLUDE_DIRS} ${BZIP2_INCLUDE_DIR})
++ # set(SCOTCH_LIBRARIES ${SCOTCH_LIBRARIES} ${BZIP2_LIBRARIES})
++ # set(SCOTCH_TEST_RUNS TRUE)
++ # else()
++ # message(STATUS "Performing test SCOTCH_BZIP2_TEST_RUNS - Failed")
++ # if (SCOTCH_DEBUG)
++ # message(STATUS "[ ${CMAKE_CURRENT_LIST_FILE}:${CMAKE_CURRENT_LIST_LINE} ] "
++ # "SCOTCH_BZIP2_TEST_LIB_COMPILED = ${SCOTCH_BZIP2_TEST_LIB_COMPILED}")
++ # message(STATUS "[ ${CMAKE_CURRENT_LIST_FILE}:${CMAKE_CURRENT_LIST_LINE} ] "
++ # "SCOTCH_BZIP2_TEST_LIB_COMPILE_OUTPUT = ${SCOTCH_BZIP2_TEST_LIB_COMPILE_OUTPUT}")
++ # message(STATUS "[ ${CMAKE_CURRENT_LIST_FILE}:${CMAKE_CURRENT_LIST_LINE} ] "
++ # "SCOTCH_TEST_LIB_EXITCODE = ${SCOTCH_TEST_LIB_EXITCODE}")
++ # message(STATUS "[ ${CMAKE_CURRENT_LIST_FILE}:${CMAKE_CURRENT_LIST_LINE} ] "
++ # "SCOTCH_TEST_LIB_OUTPUT = ${SCOTCH_TEST_LIB_OUTPUT}")
++ # endif()
++ # endif()
++ # endif()
++ # endif()
+
endif()
endif()
-
+--
+2.24.1
+
diff --git a/sci-libs/libgeodecomp/files/libgeodecomp-0.5.0_pre20200314-warnings.patch b/sci-libs/libgeodecomp/files/libgeodecomp-0.5.0_pre20200314-warnings.patch
new file mode 100644
index 000000000000..2a7acd0c655b
--- /dev/null
+++ b/sci-libs/libgeodecomp/files/libgeodecomp-0.5.0_pre20200314-warnings.patch
@@ -0,0 +1,33 @@
+From 87e1918e13fa3f3124e945a0ea12cfb339ddf303 Mon Sep 17 00:00:00 2001
+From: Kurt Kanzenbach <kurt@kmk-computers.de>
+Date: Thu, 26 Mar 2020 16:05:02 +0100
+Subject: [PATCH] hpx: receiver: Remove std::move() call
+
+This fixes the following warning:
+
+|/home/kurt/git/libgeodecomp/src/libgeodecomp/communication/hpxreceiver.h:138:29: warning: moving a local object in a return statement prevents copy elision [-Wpessimizing-move]
+| 138 | return std::move(vec);
+
+The compiler should be smart enough to optimize the correct way :).
+
+Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de>
+---
+ src/libgeodecomp/communication/hpxreceiver.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/libgeodecomp/communication/hpxreceiver.h b/src/libgeodecomp/communication/hpxreceiver.h
+index beb657b88bbc..28de314d5ef5 100644
+--- a/src/libgeodecomp/communication/hpxreceiver.h
++++ b/src/libgeodecomp/communication/hpxreceiver.h
+@@ -135,7 +135,7 @@ public:
+ vec << receiver->get(i).get();
+ }
+
+- return std::move(vec);
++ return vec;
+ }
+
+ private:
+--
+2.24.1
+