summaryrefslogtreecommitdiff
path: root/sci-libs/libdap/libdap-3.20.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /sci-libs/libdap/libdap-3.20.9.ebuild
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'sci-libs/libdap/libdap-3.20.9.ebuild')
-rw-r--r--sci-libs/libdap/libdap-3.20.9.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sci-libs/libdap/libdap-3.20.9.ebuild b/sci-libs/libdap/libdap-3.20.9.ebuild
new file mode 100644
index 000000000000..7e2276b04adb
--- /dev/null
+++ b/sci-libs/libdap/libdap-3.20.9.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Implementation of a C++ SDK for DAP 2.0 and 3.2"
+HOMEPAGE="https://www.opendap.org"
+SRC_URI="https://www.opendap.org/pub/source/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 URI )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/libxml2:2
+ net-misc/curl
+ sys-apps/util-linux
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ sys-devel/flex
+ test? ( dev-util/cppunit )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.20.9-disable-net-tests.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ # bug 619144
+ append-cxxflags -std=c++14
+
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ # package provides .pc files
+ find "${ED}" -name '*.la' -delete || die
+}