summaryrefslogtreecommitdiff
path: root/sci-libs/libdap/libdap-3.18.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/libdap/libdap-3.18.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/libdap/libdap-3.18.1.ebuild')
-rw-r--r--sci-libs/libdap/libdap-3.18.1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sci-libs/libdap/libdap-3.18.1.ebuild b/sci-libs/libdap/libdap-3.18.1.ebuild
new file mode 100644
index 000000000000..b0a4bfc02ba2
--- /dev/null
+++ b/sci-libs/libdap/libdap-3.18.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Implementation of a C++ SDK for DAP 2.0 and 3.2"
+HOMEPAGE="http://opendap.org/"
+SRC_URI="http://www.opendap.org/pub/source/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 URI )"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs test"
+
+RDEPEND="
+ dev-libs/libxml2:2
+ net-misc/curl
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/flex
+ test? ( dev-util/cppunit )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.18.1-fix-buildsystem.patch"
+ "${FILESDIR}/${PN}-3.18.1-fix-c++14.patch"
+ "${FILESDIR}/${PN}-3.18.1-disable-cache-test.patch"
+ "${FILESDIR}/${PN}-3.18.1-disable-dmr-tests.patch"
+ "${FILESDIR}/${PN}-3.18.1-disable-net-tests.patch"
+ "${FILESDIR}/${PN}-3.18.1-disable-broken-tests.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ # package provides .pc files
+ find "${D}" -name '*.la' -delete || die
+}