summaryrefslogtreecommitdiff
path: root/sci-libs/libctl/libctl-3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/libctl/libctl-3.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/libctl/libctl-3.1.ebuild')
-rw-r--r--sci-libs/libctl/libctl-3.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-libs/libctl/libctl-3.1.ebuild b/sci-libs/libctl/libctl-3.1.ebuild
new file mode 100644
index 000000000000..23d9af250871
--- /dev/null
+++ b/sci-libs/libctl/libctl-3.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit fortran-2 autotools-utils
+
+DESCRIPTION="Guile-based library for scientific simulations"
+HOMEPAGE="http://ab-initio.mit.edu/libctl/"
+SRC_URI="http://ab-initio.mit.edu/libctl/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86"
+IUSE="doc examples static-libs"
+
+DEPEND="
+ dev-scheme/guile[deprecated]
+ sci-libs/nlopt"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dohtml doc/*
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins "${AUTOTOOLS_BUILD_DIR}"/examples/{*.c,*.h,example.scm,Makefile}
+ doins "${S}"/examples/{README,example.c,run.ctl}
+ fi
+}