summaryrefslogtreecommitdiff
path: root/sci-libs/libcmatrix/libcmatrix-3.11.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/libcmatrix/libcmatrix-3.11.0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/libcmatrix/libcmatrix-3.11.0-r1.ebuild')
-rw-r--r--sci-libs/libcmatrix/libcmatrix-3.11.0-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/sci-libs/libcmatrix/libcmatrix-3.11.0-r1.ebuild b/sci-libs/libcmatrix/libcmatrix-3.11.0-r1.ebuild
new file mode 100644
index 000000000000..8596928ef6a1
--- /dev/null
+++ b/sci-libs/libcmatrix/libcmatrix-3.11.0-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+MY_P="${PN}${PV}_lite"
+
+DESCRIPTION="lite version of pNMRsim"
+HOMEPAGE="http://www.dur.ac.uk/paul.hodgkinson/pNMRsim/"
+SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cpu_flags_x86_sse threads"
+
+RDEPEND="sci-libs/minuit"
+DEPEND="${RDEPEND}"
+
+RESTRICT=mirror
+
+S="${WORKDIR}/${PN}R3"
+
+DOCS=( CHANGES docs/cmatrix.pdf )
+PATCHES=(
+ "${FILESDIR}/${PN}-3.11.0-shared.patch"
+ "${FILESDIR}/${PN}-3.2.1-minuit2.patch"
+ "${FILESDIR}/${PN}-3.2.1-gcc4.4.patch"
+ "${FILESDIR}/${PN}-3.2.1-gcc4.6.patch"
+ "${FILESDIR}/${PN}-3.2.1-gcc4.7.patch"
+ "${FILESDIR}/${PN}-3.9.0-atlas.patch"
+ "${FILESDIR}/${PN}-3.11.0-gcc5.2.patch"
+ "${FILESDIR}/${PN}-3.11.0-fix-c++14.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-minuit \
+ --without-atlas \
+ --with-sysroot="${EROOT}" \
+ $(use_with cpu_flags_x86_sse sse) \
+ $(use_with threads)
+}
+
+src_install() {
+ dolib.so lib/*.so*
+
+ insinto /usr/include/${PN}R3
+ doins -r include/.
+
+ einstalldocs
+}