summaryrefslogtreecommitdiff
path: root/sci-libs/levmar/levmar-2.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/levmar/levmar-2.6.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/levmar/levmar-2.6.ebuild')
-rw-r--r--sci-libs/levmar/levmar-2.6.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sci-libs/levmar/levmar-2.6.ebuild b/sci-libs/levmar/levmar-2.6.ebuild
new file mode 100644
index 000000000000..c79aa78b669c
--- /dev/null
+++ b/sci-libs/levmar/levmar-2.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-utils eutils toolchain-funcs
+
+DESCRIPTION="Levenberg-Marquardt nonlinear least squares C library"
+HOMEPAGE="https://www.ics.forth.gr/~lourakis/levmar/"
+SRC_URI="${HOMEPAGE}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-shared.patch
+ "${FILESDIR}"/${P}-demo-underlinking.patch
+)
+
+src_configure() {
+ local mycmakeargs+=(
+ -DNEED_F2C=OFF
+ -DHAVE_LAPACK=ON
+ -DLAPACKBLAS_LIB_NAMES="$($(tc-getPKG_CONFIG) --libs blas lapack)"
+ $(cmake-utils_use test BUILD_DEMO)
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ cd ${CMAKE_BUILD_DIR}
+ ./lmdemo || die
+}
+
+src_install() {
+ dolib.so ${CMAKE_BUILD_DIR}/liblevmar.so
+ insinto /usr/include
+ doins levmar.h
+}