summaryrefslogtreecommitdiff
path: root/sci-libs/levmar/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/levmar/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/levmar/files')
-rw-r--r--sci-libs/levmar/files/levmar-2.6-demo-underlinking.patch12
-rw-r--r--sci-libs/levmar/files/levmar-2.6-shared.patch12
2 files changed, 24 insertions, 0 deletions
diff --git a/sci-libs/levmar/files/levmar-2.6-demo-underlinking.patch b/sci-libs/levmar/files/levmar-2.6-demo-underlinking.patch
new file mode 100644
index 000000000000..a6be5587d3e0
--- /dev/null
+++ b/sci-libs/levmar/files/levmar-2.6-demo-underlinking.patch
@@ -0,0 +1,12 @@
+diff -urN levmar-2.6.old/CMakeLists.txt levmar-2.6/CMakeLists.txt
+--- levmar-2.6.old/CMakeLists.txt 2014-08-07 18:22:25.739008113 +0200
++++ levmar-2.6/CMakeLists.txt 2014-08-07 18:22:36.050014845 +0200
+@@ -67,7 +67,7 @@
+
+ # demo program
+ IF(BUILD_DEMO)
+- SET(LIBS levmar)
++ SET(LIBS levmar m)
+
+ LINK_DIRECTORIES(${CMAKE_BINARY_DIR}) # location of the levmar library
+ LINK_DIRECTORIES(${LAPACKBLAS_DIR})
diff --git a/sci-libs/levmar/files/levmar-2.6-shared.patch b/sci-libs/levmar/files/levmar-2.6-shared.patch
new file mode 100644
index 000000000000..e89750cc028f
--- /dev/null
+++ b/sci-libs/levmar/files/levmar-2.6-shared.patch
@@ -0,0 +1,12 @@
+diff -Nur levmar-2.6.orig/CMakeLists.txt levmar-2.6/CMakeLists.txt
+--- levmar-2.6.orig/CMakeLists.txt 2012-04-13 04:53:53.000000000 +0100
++++ levmar-2.6/CMakeLists.txt 2012-04-13 04:54:20.000000000 +0100
+@@ -60,7 +60,7 @@
+ ENDIF(HAVE_PLASMA)
+
+ # levmar library source files
+-ADD_LIBRARY(levmar STATIC
++ADD_LIBRARY(levmar SHARED
+ lm.c Axb.c misc.c lmlec.c lmbc.c lmblec.c lmbleic.c
+ levmar.h misc.h compiler.h
+ )