summaryrefslogtreecommitdiff
path: root/sci-libs/keras-preprocessing/keras-preprocessing-1.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /sci-libs/keras-preprocessing/keras-preprocessing-1.0.5.ebuild
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'sci-libs/keras-preprocessing/keras-preprocessing-1.0.5.ebuild')
-rw-r--r--sci-libs/keras-preprocessing/keras-preprocessing-1.0.5.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/sci-libs/keras-preprocessing/keras-preprocessing-1.0.5.ebuild b/sci-libs/keras-preprocessing/keras-preprocessing-1.0.5.ebuild
new file mode 100644
index 000000000000..1299a0693b5f
--- /dev/null
+++ b/sci-libs/keras-preprocessing/keras-preprocessing-1.0.5.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python{3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="Easy data preprocessing and data augmentation for deep learning models"
+HOMEPAGE="https://keras.io/"
+SRC_URI="https://github.com/keras-team/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"