summaryrefslogtreecommitdiff
path: root/sci-libs/keras-applications
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /sci-libs/keras-applications
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'sci-libs/keras-applications')
-rw-r--r--sci-libs/keras-applications/Manifest3
-rw-r--r--sci-libs/keras-applications/keras-applications-1.0.4.ebuild20
-rw-r--r--sci-libs/keras-applications/metadata.xml14
3 files changed, 37 insertions, 0 deletions
diff --git a/sci-libs/keras-applications/Manifest b/sci-libs/keras-applications/Manifest
new file mode 100644
index 000000000000..b730166b4af8
--- /dev/null
+++ b/sci-libs/keras-applications/Manifest
@@ -0,0 +1,3 @@
+DIST keras-applications-1.0.4.tar.gz 285031 BLAKE2B 7208752b45f825949eb2718e4e276f7c3e4a523b2668975d6834084c42cdc2dc3efb57fd0ef24401bc0dd35453f4798422f6afd9583249237cd35941939c25f4 SHA512 10a793a60b7084ea641035618e178d5b1261da5826292db25134f9886b191bd152dfa8fa686a6270fa56a7fc1831bda07e77d12597972b186a9354f857feb1d0
+EBUILD keras-applications-1.0.4.ebuild 554 BLAKE2B 8492cef67af05dc39a0ed36f0afdedb568983de1c6225417ee143ed73017cc76e38307ac7e95aaeebed6494d1a8b2ccbbfe9eb1b5a86d66cb5597d9650debd43 SHA512 b0ab5268039f213cf46c88198f2153acdacf672e42e6d51bb85c6115d7ceca39fe78472a71af2a2e93b6ef176a44b0d9000fd8ef693fa967158432a98d5151a9
+MISC metadata.xml 621 BLAKE2B 4f375ddfcfed6172df186350f7bd3dbfbcacea34f555b14719af43f58b140d73e378cd0a5efd8438ed2a0006f3552febc684b4fce85aeb88fb2c9bf819c06c4b SHA512 9dbb366d483843279cc7532b56a877313a7c39de25c93c313a2957092f9766ce5715a83dd87ef116d1733a7cc399319025ce1eb0e7ad174e2b7441360a9f5560
diff --git a/sci-libs/keras-applications/keras-applications-1.0.4.ebuild b/sci-libs/keras-applications/keras-applications-1.0.4.ebuild
new file mode 100644
index 000000000000..ce11be0de2ee
--- /dev/null
+++ b/sci-libs/keras-applications/keras-applications-1.0.4.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="Keras deep learning library reference implementations of deep learning models"
+HOMEPAGE="https://keras.io/applications/"
+SRC_URI="https://github.com/keras-team/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/sci-libs/keras-applications/metadata.xml b/sci-libs/keras-applications/metadata.xml
new file mode 100644
index 000000000000..f195797ab3a0
--- /dev/null
+++ b/sci-libs/keras-applications/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>perfinion@gentoo.org</email>
+ <name>Jason Zaman</name>
+ </maintainer>
+ <longdescription lang="en">
+ Keras Applications is the applications module of the Keras deep learning library. It provides model definitions and pre-trained weights for a number of popular archictures, such as VGG16, ResNet50, Xception, MobileNet, and more.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">keras-team/keras-applications</remote-id>
+ </upstream>
+</pkgmetadata>