summaryrefslogtreecommitdiff
path: root/sci-libs/jmol-acme/jmol-acme-1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/jmol-acme/jmol-acme-1.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/jmol-acme/jmol-acme-1.0.ebuild')
-rw-r--r--sci-libs/jmol-acme/jmol-acme-1.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sci-libs/jmol-acme/jmol-acme-1.0.ebuild b/sci-libs/jmol-acme/jmol-acme-1.0.ebuild
new file mode 100644
index 000000000000..30ad53ef215f
--- /dev/null
+++ b/sci-libs/jmol-acme/jmol-acme-1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="Acme"
+
+# It proved difficult to recompile the whole Acme package, so we'll only take what we need.
+
+DESCRIPTION="Portions of the Acme collection required for jMol"
+HOMEPAGE="http://www.acme.com/"
+SRC_URI="http://www.acme.com/resources/classes/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4"
+RDEPEND=">=virtual/jre-1.4"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ mkdir -p classes
+ find . -name \*.class -delete
+ java-pkg_filter-compiler jikes
+}
+
+src_compile() {
+ cp "${FILESDIR}/src.list" "${T}" || die
+ ejavac -sourcepath "" -d "${S}/classes" "@${T}/src.list"
+ jar cf "${PN}.jar" -C classes . || die "failed to create jar"
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+}