summaryrefslogtreecommitdiff
path: root/sci-libs/jama/jama-1.2.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
commita4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (patch)
tree852c90a4bf354c30ea66504f70bfab5401fba18d /sci-libs/jama/jama-1.2.5.ebuild
parent5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (diff)
gentoo resync : 28.04.2018
Diffstat (limited to 'sci-libs/jama/jama-1.2.5.ebuild')
-rw-r--r--sci-libs/jama/jama-1.2.5.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/sci-libs/jama/jama-1.2.5.ebuild b/sci-libs/jama/jama-1.2.5.ebuild
index 232208b2534d..a9db9225bd5a 100644
--- a/sci-libs/jama/jama-1.2.5.ebuild
+++ b/sci-libs/jama/jama-1.2.5.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+EAPI=6
+
inherit versionator
MYP="${PN}$(replace_all_version_separators '')"
@@ -14,7 +16,6 @@ SRC_URI="http://math.nist.gov/tnt/${MYP}.zip
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
IUSE="doc"
DEPEND="app-arch/unzip"
@@ -23,7 +24,8 @@ RDEPEND="sci-libs/tnt"
S="${WORKDIR}"
src_install() {
- insinto /usr/include
- doins *.h || die
- use doc && dohtml doxygen/html/*
+ doheader *.h
+
+ use doc && HTML_DOCS=( doxygen/html/. )
+ einstalldocs
}