summaryrefslogtreecommitdiff
path: root/sci-libs/jama/jama-1.2.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/jama/jama-1.2.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/jama/jama-1.2.5.ebuild')
-rw-r--r--sci-libs/jama/jama-1.2.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sci-libs/jama/jama-1.2.5.ebuild b/sci-libs/jama/jama-1.2.5.ebuild
new file mode 100644
index 000000000000..232208b2534d
--- /dev/null
+++ b/sci-libs/jama/jama-1.2.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit versionator
+
+MYP="${PN}$(replace_all_version_separators '')"
+DOCPV=102
+
+DESCRIPTION="Java-like matrix C++ templates"
+HOMEPAGE="http://math.nist.gov/tnt/"
+SRC_URI="http://math.nist.gov/tnt/${MYP}.zip
+ doc? ( http://math.nist.gov/tnt/${PN}${DOCPV}doc.zip )"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc"
+
+DEPEND="app-arch/unzip"
+RDEPEND="sci-libs/tnt"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/include
+ doins *.h || die
+ use doc && dohtml doxygen/html/*
+}