summaryrefslogtreecommitdiff
path: root/sci-libs/jama/jama-1.2.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-14 00:01:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-14 00:01:24 +0100
commit59c2499e0c9720169c9d5a02168c51c807a21467 (patch)
tree48c68a8a7e0094b2edaace12850e6c059bc3636b /sci-libs/jama/jama-1.2.5-r1.ebuild
parenta25cc082a26782e5d39ded4559c91ff11bc3c299 (diff)
gentoo auto-resync : 14:05:2024 - 00:01:24
Diffstat (limited to 'sci-libs/jama/jama-1.2.5-r1.ebuild')
-rw-r--r--sci-libs/jama/jama-1.2.5-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sci-libs/jama/jama-1.2.5-r1.ebuild b/sci-libs/jama/jama-1.2.5-r1.ebuild
new file mode 100644
index 000000000000..f2dafa318d92
--- /dev/null
+++ b/sci-libs/jama/jama-1.2.5-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Java-like matrix C++ templates"
+HOMEPAGE="https://math.nist.gov/tnt/"
+SRC_URI="https://math.nist.gov/tnt/${PN}${PV//./}.zip
+ doc? ( https://math.nist.gov/tnt/${PN}102doc.zip )"
+S="${WORKDIR}"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="sci-libs/tnt"
+BDEPEND="app-arch/unzip"
+
+src_install() {
+ doheader *.h
+
+ use doc && HTML_DOCS=( doxygen/html/. )
+ einstalldocs
+}