summaryrefslogtreecommitdiff
path: root/sci-libs/io_lib/io_lib-1.14.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
commita4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (patch)
tree852c90a4bf354c30ea66504f70bfab5401fba18d /sci-libs/io_lib/io_lib-1.14.7.ebuild
parent5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (diff)
gentoo resync : 28.04.2018
Diffstat (limited to 'sci-libs/io_lib/io_lib-1.14.7.ebuild')
-rw-r--r--sci-libs/io_lib/io_lib-1.14.7.ebuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/sci-libs/io_lib/io_lib-1.14.7.ebuild b/sci-libs/io_lib/io_lib-1.14.7.ebuild
index f1475e779918..61c5170f0012 100644
--- a/sci-libs/io_lib/io_lib-1.14.7.ebuild
+++ b/sci-libs/io_lib/io_lib-1.14.7.ebuild
@@ -1,27 +1,26 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils
-
DESCRIPTION="General purpose trace and experiment file reading/writing interface"
HOMEPAGE="http://staden.sourceforge.net/"
SRC_URI="mirror://sourceforge/staden/${P}.tar.gz"
LICENSE="BSD"
-SLOT="0"
+SLOT="0/11"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
IUSE="static-libs"
-DEPEND="
- net-misc/curl
- sys-libs/zlib"
-RDEPEND="${DEPEND}"
+RDEPEND="
+ app-arch/bzip2:=
+ app-arch/xz-utils:=
+ net-misc/curl:=
+ sys-libs/zlib:="
+DEPEND="${RDEPEND}"
# tests fails and might need sci-biology/staden from
# the science overlay
-
RESTRICT="test"
src_configure() {
@@ -30,6 +29,9 @@ src_configure() {
src_install() {
default
- use static-libs || prune_libtool_files
dodoc docs/{Hash_File_Format,ZTR_format}
+
+ if ! use static-libs; then
+ find "${D}" \( -name '*.la' -o -name '*.a' \) -delete || die
+ fi
}