summaryrefslogtreecommitdiff
path: root/sci-libs/ignition-math
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/ignition-math
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/ignition-math')
-rw-r--r--sci-libs/ignition-math/Manifest4
-rw-r--r--sci-libs/ignition-math/ignition-math-3.2.0.ebuild28
-rw-r--r--sci-libs/ignition-math/metadata.xml11
3 files changed, 43 insertions, 0 deletions
diff --git a/sci-libs/ignition-math/Manifest b/sci-libs/ignition-math/Manifest
new file mode 100644
index 000000000000..f532025287d0
--- /dev/null
+++ b/sci-libs/ignition-math/Manifest
@@ -0,0 +1,4 @@
+DIST ignition-math3_3.2.0.tar.bz2 382201 SHA256 929794ababed10c92d7217973e1d268a9de4a51dae80c401c6d1333ff65f7f89 SHA512 ffb5d61105ba0951c6420c53d64b47bdd65bdcac17e8ef2ce7cb83aeb2310280e5acb4d029d1af5c05fb5c40accf05df61d1e04dc990225159f1749284e3dcf1 WHIRLPOOL 300279c839246ab892c79cdf4dbe0a59a188f9e0ca10b0980e0dd3bbcbe11ea776bcfacae3c7c56b0d7d4d991183235db0addd688d5f44129ca216c96e74d451
+EBUILD ignition-math-3.2.0.ebuild 880 SHA256 ce94e09e0717aac949b71a29846851149509820694f87fb571b932556a347b15 SHA512 8c5e7eb0bba7b5c928dd42169a7ffcc594ef338314dfa81373b6ffe3e5d836d944627ae68c342ca01b630c6badb1e094cb680e449fb5d68f160fb9b93bf96a88 WHIRLPOOL 7bcc650651ee183de44a828affbeef7a59c1212c4a509a8e6b808fb87f62940a7ad3762b4255d060ffaf53b70b0ab8f4f5349dc0356071e698f7ae29e0dafd5b
+MISC ChangeLog 1987 SHA256 f424ee8c6f10f257435d0b99d0d2554bdeccee62db5966cf8def5a28e05a1779 SHA512 1a73a35e3b2f26998f2505f195ced77d1b2ef93c7b112c3c19b746cd7847df4636a6a8a31174ca25baca8025475aa32bf441a17dde8b28c1b734e0470eaad49e WHIRLPOOL 3c4c2ddc28912aca3c2eb6ff9808481a41881e42a4f95fec8fe346e65fbcd4929f64d98f8b148a940c142580465b4a197f273308ce7cdc1968849a3f1e16e912
+MISC metadata.xml 342 SHA256 f21cd7dd1f0994b6e4a35cc4e60fa40017f50ddb9c29cfa9c5031cd29c329cf9 SHA512 8969e6c2df55cfae7cc21640498871d7049499d146d06b13057701e742e9ef6f2c5124acd144b9e7f0974ea39032e89402252e32192242697555c64d90eb4b4a WHIRLPOOL 5a6f57638a4e971df8698ec5d73bf13f0b4afb48ab0fcc73e060341c2cb499794d44127e1c7c8fcfb51580da84cc0aaa97d0e16bf4bf731dec5ce62af4d451cb
diff --git a/sci-libs/ignition-math/ignition-math-3.2.0.ebuild b/sci-libs/ignition-math/ignition-math-3.2.0.ebuild
new file mode 100644
index 000000000000..edbe8795a029
--- /dev/null
+++ b/sci-libs/ignition-math/ignition-math-3.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-multilib vcs-snapshot flag-o-matic
+
+DESCRIPTION="A small, fast, and high performance math library for robot applications"
+HOMEPAGE="http://ignitionrobotics.org/libraries/math"
+SRC_URI="https://bitbucket.org/ignitionrobotics/ign-math/get/${PN}3_${PV}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="3/3"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${PN}3_${PV}"
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+src_configure() {
+ # upstream appends this conditionally...
+ append-flags "-fPIC"
+ echo "set (CMAKE_C_FLAGS_ALL \"${CXXFLAGS} \${CMAKE_C_FLAGS_ALL}\")" > "${S}/cmake/HostCFlags.cmake"
+ sed -i -e "s/LINK_FLAGS_RELWITHDEBINFO \" \"/LINK_FLAGS_RELWITHDEBINFO \" ${LDFLAGS} \"/" cmake/DefaultCFlags.cmake || die
+ cmake-multilib_src_configure
+}
diff --git a/sci-libs/ignition-math/metadata.xml b/sci-libs/ignition-math/metadata.xml
new file mode 100644
index 000000000000..cd92ae6d0f49
--- /dev/null
+++ b/sci-libs/ignition-math/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="bitbucket">ignitionrobotics/ign-math</remote-id>
+ </upstream>
+</pkgmetadata>