summaryrefslogtreecommitdiff
path: root/sci-libs/hypre/hypre-2.20.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sci-libs/hypre/hypre-2.20.0.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sci-libs/hypre/hypre-2.20.0.ebuild')
-rw-r--r--sci-libs/hypre/hypre-2.20.0.ebuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/sci-libs/hypre/hypre-2.20.0.ebuild b/sci-libs/hypre/hypre-2.20.0.ebuild
index c7a163995f57..f1b93093da7b 100644
--- a/sci-libs/hypre/hypre-2.20.0.ebuild
+++ b/sci-libs/hypre/hypre-2.20.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -27,16 +27,12 @@ DEPEND="${RDEPEND}"
DOCS=( CHANGELOG COPYRIGHT README )
pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]] && use openmp && [[ $(tc-getCC) == *gcc* ]] ; then
- tc-check-openmp
- fi
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
pkg_setup() {
- if [[ ${MERGE_TYPE} != binary ]] && use openmp && [[ $(tc-getCC) == *gcc* ]] && ! tc-has-openmp ; then
- ewarn "You are using a non capable gcc compiler ( < 4.2 ? )"
- die "Need an OpenMP capable compiler"
- fi
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+ use fortran && fortran-2_pkg_setup
}
src_prepare() {
@@ -60,8 +56,9 @@ src_configure() {
tc-export CC CXX
append-flags -Dhypre_dgesvd=dgesvd_
- if use openmp && [[ $(tc-getCC) == *gcc* ]] ; then
- append-flags -fopenmp && append-ldflags -fopenmp
+ if use openmp ; then
+ append-flags -fopenmp
+ append-ldflags -fopenmp
fi
if use mpi ; then