summaryrefslogtreecommitdiff
path: root/sci-libs/hypre/hypre-2.18.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /sci-libs/hypre/hypre-2.18.2.ebuild
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'sci-libs/hypre/hypre-2.18.2.ebuild')
-rw-r--r--sci-libs/hypre/hypre-2.18.2.ebuild100
1 files changed, 0 insertions, 100 deletions
diff --git a/sci-libs/hypre/hypre-2.18.2.ebuild b/sci-libs/hypre/hypre-2.18.2.ebuild
deleted file mode 100644
index 2b5614b59ac8..000000000000
--- a/sci-libs/hypre/hypre-2.18.2.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-FORTRAN_NEEDED=fortran
-
-inherit cmake-utils fortran-2 toolchain-funcs flag-o-matic
-
-DESCRIPTION="Parallel matrix preconditioners library"
-HOMEPAGE="https://computation.llnl.gov/projects/hypre-scalable-linear-solvers-multigrid-methods"
-SRC_URI="https://github.com/${PN}-space/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0/${PV}"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="debug examples fortran int64 openmp mpi"
-
-RDEPEND="
- sci-libs/superlu:=
- virtual/blas
- virtual/lapack
- mpi? ( virtual/mpi )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-DOCS=( CHANGELOG COPYRIGHT README )
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] &&\
- use openmp && [[ $(tc-getCC)$ == *gcc* ]] && tc-check-openmp
-}
-
-pkg_setup() {
- if [[ ${MERGE_TYPE} != binary ]] && \
- use openmp && [[ $(tc-getCC)$ == *gcc* ]] && ! tc-has-openmp ; then
- ewarn "You are using a non capable gcc compiler ( < 4.2 ? )"
- die "Need an OpenMP capable compiler"
- fi
-}
-
-src_prepare() {
- default
- # link with system superlu and propagate LDFLAGS
- sed -e "s:@LIBS@:@LIBS@ $($(tc-getPKG_CONFIG) --libs superlu):" \
- -e 's:_SHARED@:_SHARED@ $(LDFLAGS):g' \
- -i src/config/Makefile.config.in || die
- sed -e '/HYPRE_ARCH/s: = :=:g' \
- -i src/configure || die
- # link with system blas and lapack
- sed -e '/^BLASFILES/d' \
- -e '/^LAPACKFILES/d' \
- -i src/lib/Makefile || die
-}
-
-src_configure() {
- tc-export CC CXX
- append-flags -Dhypre_dgesvd=dgesvd_
- use openmp && [[ $(tc-getCC)$ == *gcc* ]] && \
- append-flags -fopenmp && append-ldflags -fopenmp
- use mpi && CC=mpicc FC=mpif77 CXX=mpicxx
-
- cd src
-
- # without-superlu: means do not use bundled one
- econf \
- --enable-shared \
- --with-blas-libs="$($(tc-getPKG_CONFIG) --libs-only-l blas | sed -e 's/-l//g')" \
- --with-blas-lib-dirs="$($(tc-getPKG_CONFIG) --libs-only-L blas | sed -e 's/-L//g')" \
- --with-lapack-libs="$($(tc-getPKG_CONFIG) --libs-only-l lapack | sed -e 's/-l//g')" \
- --with-lapack-lib-dirs="$($(tc-getPKG_CONFIG) --libs-only-L lapack | sed -e 's/-L//g')" \
- --with-timing \
- --without-superlu \
- $(use_enable debug) \
- $(use_enable openmp hopscotch) \
- $(use_enable int64 bigint) \
- $(use_enable fortran) \
- $(use_with openmp) \
- $(use_with mpi MPI)
-}
-
-src_compile() {
- emake -C src
-}
-
-src_test() {
- LD_LIBRARY_PATH="${S}/src/lib:${LD_LIBRARY_PATH}" \
- PATH="${S}/src/test:${PATH}" \
- emake -C src check
-}
-
-src_install() {
- emake -C src install \
- HYPRE_INSTALL_DIR="${ED}" \
- HYPRE_LIB_INSTALL="${ED}/usr/$(get_libdir)" \
- HYPRE_INC_INSTALL="${ED}$/usr/include/hypre"
- if use examples; then
- dodoc -r src/examples
- fi
-}