summaryrefslogtreecommitdiff
path: root/sci-libs/htslib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /sci-libs/htslib
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'sci-libs/htslib')
-rw-r--r--sci-libs/htslib/Manifest2
-rw-r--r--sci-libs/htslib/htslib-1.13.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/sci-libs/htslib/Manifest b/sci-libs/htslib/Manifest
index a7ac3683dba8..7c854624e360 100644
--- a/sci-libs/htslib/Manifest
+++ b/sci-libs/htslib/Manifest
@@ -1,3 +1,5 @@
DIST htslib-1.10.2.tar.bz2 1306320 BLAKE2B f877bd9c160921f498f4160f687094a1a369732bc9f61cd94a3c9ca311fa9f865505a205e38e0d348a1010b627f1ef07b590cd7e69c945df1d804133b17b2fd1 SHA512 3ecb83b0abccf731cd42b889e352e10dd922524f6e78bcafb04f8c6c71457b0dc1f5f22690b36f03cce7d97a6a905db286243ef4858138068dcac368e4ae1075
+DIST htslib-1.13.tar.bz2 4226834 BLAKE2B ae1f64e564f0f7bea80ea9d276b5d5b2b04fa3c8bd58f2c68966225b4324962f34d8a26b74267ab90dc530dfced1b9c01702d25918fd7a7c74e13913f00d5007 SHA512 16a3d61c115b71406bc4411a0c1176909166b52c4f7bb11614e398df4defaec4d09763413053e4d0d5916921c866d20019096d8fed866e77f9f1cafbd1e95b16
EBUILD htslib-1.10.2.ebuild 1041 BLAKE2B 12d35fa9397f441d9e1ee444abca8c56cf87bf16aa2b82b0d6d0bad6ec27546dccdb4b540eaca322f5208eb7c0a6b9f6de5cfa8762641d73a3f40fd8bee5ea47 SHA512 99c54c20f1f01fc243bc7cb25325265e1d959fdc23a3d2db4c2cef29fb9f74cc423835a25d9f5fa1b5af027413caeb6ee8fff2f517ae2dbe8119b80c504b87d9
+EBUILD htslib-1.13.ebuild 1052 BLAKE2B 1d219220299500bce4aaf8927bde67beba02afda02319527cae8f3aa7ccce131a21c0b27e9eaa0ade634d99d910915108abd48385a9686a95795b74733f3c0ce SHA512 3d5bc8e165e27b5a5f1e0d87c7802e65c2de55bc7754cb13d5bcd5f2c211de37ecd81e8ebfa0377158eea196449d9b71858c08372ab73f30614e6e787af47005
MISC metadata.xml 350 BLAKE2B 6512256a4c692625cb824d90fc8b85942f88db717fd265548b97a5b535158fc65e1f2e74df4ebd3c2a259dfd3a4244a13493fc410b1663b8054b29a14995787d SHA512 926efc676b0619ae901253f2207c8ba948ebe3db560377a55edecd9cd58cd2ec806bcdff875e9c5c9a170921c44818271e8ddd691fe1a84ed651f7aca75265ec
diff --git a/sci-libs/htslib/htslib-1.13.ebuild b/sci-libs/htslib/htslib-1.13.ebuild
new file mode 100644
index 000000000000..cfd9cfb3263e
--- /dev/null
+++ b/sci-libs/htslib/htslib-1.13.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="C library for high-throughput sequencing data formats"
+HOMEPAGE="http://www.htslib.org/"
+SRC_URI="mirror://sourceforge/samtools/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0/3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+bzip2 curl +lzma"
+
+RDEPEND="
+ sys-libs/zlib
+ bzip2? ( app-arch/bzip2 )
+ curl? ( net-misc/curl )
+ lzma? ( app-arch/xz-utils )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ # upstream injects LDFLAGS into the .pc file,
+ # which is a big nono for QA
+ sed -e '/^\(static_l\|Libs.private\|Requires.private\)/d' \
+ -i htslib.pc.in || die
+}
+
+src_configure() {
+ econf \
+ --disable-gcs \
+ --disable-plugins \
+ --disable-s3 \
+ $(use_enable bzip2 bz2) \
+ $(use_enable curl libcurl) \
+ $(use_enable lzma)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ # doesn't use libtool, can't disable static libraries
+ find "${ED}" -name '*.a' -delete || die
+}