summaryrefslogtreecommitdiff
path: root/sci-libs/htslib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-30 16:00:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-30 16:00:34 +0100
commit8b63b46fda85d54cfbe94df2444a3ddd3e63b8e4 (patch)
treeced0310e563ec21deb23ca12d5459aebadba36f6 /sci-libs/htslib
parent93c735f5f1ff867aadcc947348d984ff2c5a29cb (diff)
gentoo auto-resync : 30:03:2023 - 16:00:34
Diffstat (limited to 'sci-libs/htslib')
-rw-r--r--sci-libs/htslib/Manifest2
-rw-r--r--sci-libs/htslib/htslib-1.17.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/sci-libs/htslib/Manifest b/sci-libs/htslib/Manifest
index 219cd1fd26dc..e91377411bf4 100644
--- a/sci-libs/htslib/Manifest
+++ b/sci-libs/htslib/Manifest
@@ -1,3 +1,5 @@
DIST htslib-1.16.tar.bz2 4466776 BLAKE2B 4957dd7a25b3d0b939d4e924db018916a5f8a13a81e55ebd1ce1acc548986e581d017ead9a08245a4af1ebdcd15536f082425ebe05f16eb4faad27d332e48482 SHA512 9fa0b1f9bba50f889d4542825c9543fb3b34c13b4cc0e18940a66fafd130749574bfa2c2663d8b39f0b4ed2b298bf130367cda1b17b2929093d64b386730cbc5
+DIST htslib-1.17.tar.bz2 4619884 BLAKE2B c45591b3f1da4f6ddfdf5e1a20864583d57de2a460d42049715335fce7dafe1f5cd14403e6033fee4f9d0bfc75f8777b5835d2d01bf2cadff0155d9fc92b97d9 SHA512 624ab449d57713dab2d34399926c065f8cff8a45e6fbe68e0bb518c601421f587b613caeb095f8639b1d67cdb4a65d658c85f942173bcaa48da026fe15def5d3
EBUILD htslib-1.16.ebuild 1074 BLAKE2B d04ae956ac6d4819704e8342d9679d0c54274c09da155c6d73d0e889b3db75cfbbae80665e750c0d7387cf9eeeac7642ff31bbe301220cef06915d7081c3aa74 SHA512 6c617b18f47e2823077527653dcf2a6976577efde1481087d5188ce151089edc9a98343ef6ad3864117477c60531694287adae5def956f016d6e105445ae1963
+EBUILD htslib-1.17.ebuild 1074 BLAKE2B 2bfb261fbe65d7a3d2cd33aec2c3e1e3c649570abfa7b5a630e43f07118869731e22ee1180d8877237aa3423e76c5f3eba7c87c6b1bfe591a982a427eb7d6fc6 SHA512 d2901ebb4f8e43b7db795e6a6e4f53b5eaad3bbc5db5607d65db08f517fbf6c41547053ccf229a6f0849ba38921127233ce824e8d18bcefbd7a921c284703609
MISC metadata.xml 342 BLAKE2B 1c27212ba39cbbd235e2b023af977d5dffbb53dab193e21c989b2da52641fec13317110cfb52fd73cbe7fbdd5aa6b3628ee7cd55ae919551fa82267b05f93e2d SHA512 5b61d1b204a33d6328d3964346c48dc35bc4e29c56dc7920a63caf2fc510be35b10f74f2649a2670239de90cff5ed4652fa99d4ef51a55245b7fc4b31f29674b
diff --git a/sci-libs/htslib/htslib-1.17.ebuild b/sci-libs/htslib/htslib-1.17.ebuild
new file mode 100644
index 000000000000..6f690363326b
--- /dev/null
+++ b/sci-libs/htslib/htslib-1.17.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="C library for high-throughput sequencing data formats"
+HOMEPAGE="http://www.htslib.org/"
+SRC_URI="https://github.com/samtools/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0/3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+bzip2 curl +lzma"
+
+RDEPEND="
+ sys-libs/zlib
+ bzip2? ( app-arch/bzip2 )
+ curl? ( net-misc/curl )
+ lzma? ( app-arch/xz-utils )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ # upstream injects LDFLAGS into the .pc file,
+ # which is a big nono for QA
+ sed -e '/^\(static_l\|Libs.private\|Requires.private\)/d' \
+ -i htslib.pc.in || die
+}
+
+src_configure() {
+ econf \
+ --disable-gcs \
+ --disable-plugins \
+ --disable-s3 \
+ $(use_enable bzip2 bz2) \
+ $(use_enable curl libcurl) \
+ $(use_enable lzma)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ # doesn't use libtool, can't disable static libraries
+ find "${ED}" -name '*.a' -delete || die
+}