summaryrefslogtreecommitdiff
path: root/sci-libs/htslib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-27 02:09:02 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-27 02:09:02 +0000
commit65531d9c170398a321c546ea67946a932842217b (patch)
tree8e66963f21c4e75bb21506d2643d40a3151ed516 /sci-libs/htslib
parent6dfd9c39ab68bbc917ffc374b2fa515f676f891f (diff)
gentoo auto-resync : 27:12:2022 - 02:09:02
Diffstat (limited to 'sci-libs/htslib')
-rw-r--r--sci-libs/htslib/Manifest4
-rw-r--r--sci-libs/htslib/htslib-1.16.ebuild52
-rw-r--r--sci-libs/htslib/metadata.xml14
3 files changed, 62 insertions, 8 deletions
diff --git a/sci-libs/htslib/Manifest b/sci-libs/htslib/Manifest
index 319557fa6017..839656915080 100644
--- a/sci-libs/htslib/Manifest
+++ b/sci-libs/htslib/Manifest
@@ -1,3 +1,5 @@
DIST htslib-1.15.1.tar.bz2 4141140 BLAKE2B 312f67c8916586199b32b7703b43a9fd365b8af22802bf4d63fc40960c62b956915e7c60bbd777a8b179066608cd3a281929a10b60eef21d6eedb4caf8c147c1 SHA512 69d0c7f3ac50a9b9c579e9b3479b6745fc30d0ac838ff14695cf4e3da593854350e345ed1f4a496931ef57395f3416da4316903488f3e641f1e00fec544f3620
+DIST htslib-1.16.tar.bz2 4466776 BLAKE2B 4957dd7a25b3d0b939d4e924db018916a5f8a13a81e55ebd1ce1acc548986e581d017ead9a08245a4af1ebdcd15536f082425ebe05f16eb4faad27d332e48482 SHA512 9fa0b1f9bba50f889d4542825c9543fb3b34c13b4cc0e18940a66fafd130749574bfa2c2663d8b39f0b4ed2b298bf130367cda1b17b2929093d64b386730cbc5
EBUILD htslib-1.15.1.ebuild 1074 BLAKE2B d04ae956ac6d4819704e8342d9679d0c54274c09da155c6d73d0e889b3db75cfbbae80665e750c0d7387cf9eeeac7642ff31bbe301220cef06915d7081c3aa74 SHA512 6c617b18f47e2823077527653dcf2a6976577efde1481087d5188ce151089edc9a98343ef6ad3864117477c60531694287adae5def956f016d6e105445ae1963
-MISC metadata.xml 350 BLAKE2B 6512256a4c692625cb824d90fc8b85942f88db717fd265548b97a5b535158fc65e1f2e74df4ebd3c2a259dfd3a4244a13493fc410b1663b8054b29a14995787d SHA512 926efc676b0619ae901253f2207c8ba948ebe3db560377a55edecd9cd58cd2ec806bcdff875e9c5c9a170921c44818271e8ddd691fe1a84ed651f7aca75265ec
+EBUILD htslib-1.16.ebuild 1074 BLAKE2B d04ae956ac6d4819704e8342d9679d0c54274c09da155c6d73d0e889b3db75cfbbae80665e750c0d7387cf9eeeac7642ff31bbe301220cef06915d7081c3aa74 SHA512 6c617b18f47e2823077527653dcf2a6976577efde1481087d5188ce151089edc9a98343ef6ad3864117477c60531694287adae5def956f016d6e105445ae1963
+MISC metadata.xml 342 BLAKE2B 1c27212ba39cbbd235e2b023af977d5dffbb53dab193e21c989b2da52641fec13317110cfb52fd73cbe7fbdd5aa6b3628ee7cd55ae919551fa82267b05f93e2d SHA512 5b61d1b204a33d6328d3964346c48dc35bc4e29c56dc7920a63caf2fc510be35b10f74f2649a2670239de90cff5ed4652fa99d4ef51a55245b7fc4b31f29674b
diff --git a/sci-libs/htslib/htslib-1.16.ebuild b/sci-libs/htslib/htslib-1.16.ebuild
new file mode 100644
index 000000000000..c4bd910685de
--- /dev/null
+++ b/sci-libs/htslib/htslib-1.16.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="C library for high-throughput sequencing data formats"
+HOMEPAGE="http://www.htslib.org/"
+SRC_URI="https://github.com/samtools/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0/3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+bzip2 curl +lzma"
+
+RDEPEND="
+ sys-libs/zlib
+ bzip2? ( app-arch/bzip2 )
+ curl? ( net-misc/curl )
+ lzma? ( app-arch/xz-utils )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ # upstream injects LDFLAGS into the .pc file,
+ # which is a big nono for QA
+ sed -e '/^\(static_l\|Libs.private\|Requires.private\)/d' \
+ -i htslib.pc.in || die
+}
+
+src_configure() {
+ econf \
+ --disable-gcs \
+ --disable-plugins \
+ --disable-s3 \
+ $(use_enable bzip2 bz2) \
+ $(use_enable curl libcurl) \
+ $(use_enable lzma)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ # doesn't use libtool, can't disable static libraries
+ find "${ED}" -name '*.a' -delete || die
+}
diff --git a/sci-libs/htslib/metadata.xml b/sci-libs/htslib/metadata.xml
index 003b4a9e53f3..1950263f31e1 100644
--- a/sci-libs/htslib/metadata.xml
+++ b/sci-libs/htslib/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>sci-biology@gentoo.org</email>
- <name>Gentoo Biology Project</name>
- </maintainer>
- <upstream>
- <remote-id type="sourceforge">samtools</remote-id>
- </upstream>
+ <maintainer type="project">
+ <email>sci-biology@gentoo.org</email>
+ <name>Gentoo Biology Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">samtools/htslib</remote-id>
+ </upstream>
</pkgmetadata>