summaryrefslogtreecommitdiff
path: root/sci-libs/htslib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /sci-libs/htslib
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'sci-libs/htslib')
-rw-r--r--sci-libs/htslib/Manifest2
-rw-r--r--sci-libs/htslib/htslib-1.15.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/sci-libs/htslib/Manifest b/sci-libs/htslib/Manifest
index 475aad140a52..66510cf1b757 100644
--- a/sci-libs/htslib/Manifest
+++ b/sci-libs/htslib/Manifest
@@ -1,3 +1,5 @@
DIST htslib-1.13.tar.bz2 4226834 BLAKE2B ae1f64e564f0f7bea80ea9d276b5d5b2b04fa3c8bd58f2c68966225b4324962f34d8a26b74267ab90dc530dfced1b9c01702d25918fd7a7c74e13913f00d5007 SHA512 16a3d61c115b71406bc4411a0c1176909166b52c4f7bb11614e398df4defaec4d09763413053e4d0d5916921c866d20019096d8fed866e77f9f1cafbd1e95b16
+DIST htslib-1.15.tar.bz2 4141168 BLAKE2B 20462b01e065b65de2b7df883cf61f9beb9ccca6fa3dc159c0aa7b303daf7c3779938f5eadbd3320e85ec19de105dc55e238c47a922ff6ace6fcaea2b0e95c19 SHA512 b87ce3eaa63a731d812953129f1c9aa857fe896ea9e924b7eb92173d8e624dd45e5582b3a97e7120ff7fe339e4d40148077424029626f50372b3f164093aa6cc
EBUILD htslib-1.13.ebuild 1052 BLAKE2B 1d219220299500bce4aaf8927bde67beba02afda02319527cae8f3aa7ccce131a21c0b27e9eaa0ade634d99d910915108abd48385a9686a95795b74733f3c0ce SHA512 3d5bc8e165e27b5a5f1e0d87c7802e65c2de55bc7754cb13d5bcd5f2c211de37ecd81e8ebfa0377158eea196449d9b71858c08372ab73f30614e6e787af47005
+EBUILD htslib-1.15.ebuild 1052 BLAKE2B dda021a25b1066d6e0f79aabed974ed1d6b96bb78ebbf86741207ae61ee11b1b399895c3863b1bab59669812794a0e13372c4b824612dee4cdad00a0e57aa5b9 SHA512 68f35d2c93c397ec6034468d5a5a10ca5dca42f9954fc6e5ca3583a443014324e1b802b5f42d7851c277f8f1f86c544cf574d32fe813c06e985158a8c1ab0fc9
MISC metadata.xml 350 BLAKE2B 6512256a4c692625cb824d90fc8b85942f88db717fd265548b97a5b535158fc65e1f2e74df4ebd3c2a259dfd3a4244a13493fc410b1663b8054b29a14995787d SHA512 926efc676b0619ae901253f2207c8ba948ebe3db560377a55edecd9cd58cd2ec806bcdff875e9c5c9a170921c44818271e8ddd691fe1a84ed651f7aca75265ec
diff --git a/sci-libs/htslib/htslib-1.15.ebuild b/sci-libs/htslib/htslib-1.15.ebuild
new file mode 100644
index 000000000000..e651576d8a81
--- /dev/null
+++ b/sci-libs/htslib/htslib-1.15.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="C library for high-throughput sequencing data formats"
+HOMEPAGE="http://www.htslib.org/"
+SRC_URI="mirror://sourceforge/samtools/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0/3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+bzip2 curl +lzma"
+
+RDEPEND="
+ sys-libs/zlib
+ bzip2? ( app-arch/bzip2 )
+ curl? ( net-misc/curl )
+ lzma? ( app-arch/xz-utils )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ # upstream injects LDFLAGS into the .pc file,
+ # which is a big nono for QA
+ sed -e '/^\(static_l\|Libs.private\|Requires.private\)/d' \
+ -i htslib.pc.in || die
+}
+
+src_configure() {
+ econf \
+ --disable-gcs \
+ --disable-plugins \
+ --disable-s3 \
+ $(use_enable bzip2 bz2) \
+ $(use_enable curl libcurl) \
+ $(use_enable lzma)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ # doesn't use libtool, can't disable static libraries
+ find "${ED}" -name '*.a' -delete || die
+}