summaryrefslogtreecommitdiff
path: root/sci-libs/htslib/htslib-1.17.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-25 00:07:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-25 00:07:14 +0100
commitf8999218b5a6eafa151e7367030cbfdb69e045ed (patch)
tree0d0e9293bcb75153cd18542369fa789ede9338a0 /sci-libs/htslib/htslib-1.17.ebuild
parentaa4954f71a3ba2293395a8cce2321a70c39c7554 (diff)
gentoo auto-resync : 25:05:2024 - 00:07:14next
Diffstat (limited to 'sci-libs/htslib/htslib-1.17.ebuild')
-rw-r--r--sci-libs/htslib/htslib-1.17.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/sci-libs/htslib/htslib-1.17.ebuild b/sci-libs/htslib/htslib-1.17.ebuild
deleted file mode 100644
index 6f690363326b..000000000000
--- a/sci-libs/htslib/htslib-1.17.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs
-
-DESCRIPTION="C library for high-throughput sequencing data formats"
-HOMEPAGE="http://www.htslib.org/"
-SRC_URI="https://github.com/samtools/${PN}/releases/download/${PV}/${P}.tar.bz2"
-
-LICENSE="MIT"
-SLOT="0/3"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="+bzip2 curl +lzma"
-
-RDEPEND="
- sys-libs/zlib
- bzip2? ( app-arch/bzip2 )
- curl? ( net-misc/curl )
- lzma? ( app-arch/xz-utils )"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- default
-
- # upstream injects LDFLAGS into the .pc file,
- # which is a big nono for QA
- sed -e '/^\(static_l\|Libs.private\|Requires.private\)/d' \
- -i htslib.pc.in || die
-}
-
-src_configure() {
- econf \
- --disable-gcs \
- --disable-plugins \
- --disable-s3 \
- $(use_enable bzip2 bz2) \
- $(use_enable curl libcurl) \
- $(use_enable lzma)
-}
-
-src_compile() {
- emake AR="$(tc-getAR)"
-}
-
-src_install() {
- default
-
- # doesn't use libtool, can't disable static libraries
- find "${ED}" -name '*.a' -delete || die
-}