summaryrefslogtreecommitdiff
path: root/sci-libs/hipSOLVER/files/hipSOLVER-6.1.1-find-cholmod.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-27 07:59:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-27 07:59:40 +0100
commitd2ed973482fdd800013658e83a61709b29e0a80f (patch)
tree57ea7666a57b5a05a4c8866e4915e90b4a6e7c94 /sci-libs/hipSOLVER/files/hipSOLVER-6.1.1-find-cholmod.patch
parent9f6a82a85d400d6ae7de04c43cee88dbc6bc4da0 (diff)
gentoo auto-resync : 27:06:2024 - 07:59:39
Diffstat (limited to 'sci-libs/hipSOLVER/files/hipSOLVER-6.1.1-find-cholmod.patch')
-rw-r--r--sci-libs/hipSOLVER/files/hipSOLVER-6.1.1-find-cholmod.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/sci-libs/hipSOLVER/files/hipSOLVER-6.1.1-find-cholmod.patch b/sci-libs/hipSOLVER/files/hipSOLVER-6.1.1-find-cholmod.patch
new file mode 100644
index 000000000000..da43f4ff116b
--- /dev/null
+++ b/sci-libs/hipSOLVER/files/hipSOLVER-6.1.1-find-cholmod.patch
@@ -0,0 +1,29 @@
+cholmod.h is in /usr/include in Gentoo, use pkg-config to find it
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -221,11 +221,9 @@ if( NOT USE_CUDA )
+ if( BUILD_WITH_SPARSE )
+ list(APPEND hipsolver_pkgdeps "rocsparse >= 2.3.0")
+
+- if( SYSTEM_OS STREQUAL "centos" OR SYSTEM_OS STREQUAL "rhel" )
+- list(APPEND hipsolver_pkgdeps "suitesparse")
+- else()
+- list(APPEND hipsolver_pkgdeps "libcholmod3" "libsuitesparseconfig5")
+- endif()
++ find_package(PkgConfig REQUIRED)
++ pkg_check_modules(CHOLMOD REQUIRED IMPORTED_TARGET cholmod)
++ target_link_libraries(hipsolver-common INTERFACE PkgConfig::CHOLMOD)
+ endif( )
+
+ rocm_package_add_dependencies(DEPENDS ${hipsolver_pkgdeps})
+--- a/library/src/amd_detail/hipsolver_sparse.cpp
++++ b/library/src/amd_detail/hipsolver_sparse.cpp
+@@ -45,7 +45,7 @@
+
+ #ifdef HAVE_ROCSPARSE
+ #include <rocsparse/rocsparse.h>
+-#include <suitesparse/cholmod.h>
++#include <cholmod.h>
+ #endif
+
+ #undef TRUE