summaryrefslogtreecommitdiff
path: root/sci-libs/hipRAND/hipRAND-5.6.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-19 17:06:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-19 17:06:50 +0000
commit5a31d854eec302fd1efb1466af757e520ae4e1dc (patch)
tree58a9a7036a479519c2b853ff7646e69d1c6a2339 /sci-libs/hipRAND/hipRAND-5.6.0-r1.ebuild
parent8c58ead574346296889d58006e1bf184da00be3a (diff)
gentoo auto-resync : 19:11:2023 - 17:06:49
Diffstat (limited to 'sci-libs/hipRAND/hipRAND-5.6.0-r1.ebuild')
-rw-r--r--sci-libs/hipRAND/hipRAND-5.6.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-libs/hipRAND/hipRAND-5.6.0-r1.ebuild b/sci-libs/hipRAND/hipRAND-5.6.0-r1.ebuild
new file mode 100644
index 000000000000..006440bb6a29
--- /dev/null
+++ b/sci-libs/hipRAND/hipRAND-5.6.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ROCM_VERSION=${PV}
+
+inherit cmake rocm
+
+DESCRIPTION="CU / ROCM agnostic hip RAND implementation"
+HOMEPAGE="https://github.com/ROCmSoftwarePlatform/hipRAND"
+SRC_URI="https://github.com/ROCmSoftwarePlatform/hipRAND/archive/refs/tags/rocm-${PV}.tar.gz -> hipRAND-rocm-${PV}.tar.gz"
+REQUIRED_USE="${ROCM_REQUIRED_USE}"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0/$(ver_cut 1-2)"
+
+RESTRICT="test"
+
+RDEPEND="dev-util/hip
+ sci-libs/rocRAND:${SLOT}[${ROCM_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/hipRAND-rocm-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DAMDGPU_TARGETS="$(get_amdgpu_flags)"
+ -DBUILD_FILE_REORG_BACKWARD_COMPATIBILITY=OFF
+ -DROCM_SYMLINK_LIBS=OFF
+ )
+
+ CXX=hipcc cmake_src_configure
+}