summaryrefslogtreecommitdiff
path: root/sci-libs/hipBLAS/hipBLAS-5.4.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-29 04:38:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-29 04:38:41 +0100
commitd5c5aa9b48bd6a821f5e0a1a98474ac35fb21360 (patch)
tree9de3699cbe327fb5dd93a6ec37b895f9fdb94494 /sci-libs/hipBLAS/hipBLAS-5.4.2.ebuild
parentc6a12f3c8604a9269cfb82d666fc716df0e67792 (diff)
gentoo auto-resync : 29:07:2023 - 04:38:40
Diffstat (limited to 'sci-libs/hipBLAS/hipBLAS-5.4.2.ebuild')
-rw-r--r--sci-libs/hipBLAS/hipBLAS-5.4.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-libs/hipBLAS/hipBLAS-5.4.2.ebuild b/sci-libs/hipBLAS/hipBLAS-5.4.2.ebuild
new file mode 100644
index 000000000000..b61f8865b925
--- /dev/null
+++ b/sci-libs/hipBLAS/hipBLAS-5.4.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ROCM_VERSION=${PV}
+
+inherit cmake rocm
+DESCRIPTION="ROCm BLAS marshalling library"
+HOMEPAGE="https://github.com/ROCmSoftwarePlatform/hipBLAS"
+SRC_URI="https://github.com/ROCmSoftwarePlatform/hipBLAS/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+REQUIRED_USE="${ROCM_REQUIRED_USE}"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0/$(ver_cut 1-2)"
+
+RDEPEND="dev-util/hip
+ sci-libs/rocBLAS:${SLOT}[${ROCM_USEDEP}]
+ sci-libs/rocSOLVER:${SLOT}[${ROCM_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/hipBLAS-rocm-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_CLIENTS_TESTS=OFF # currently hipBLAS is a wrapper of rocBLAS which has tests, so no need to perform test here
+ -DBUILD_CLIENTS_BENCHMARKS=OFF
+ -DBUILD_FILE_REORG_BACKWARD_COMPATIBILITY=OFF
+ -DROCM_SYMLINK_LIBS=OFF
+ )
+
+ CXX=hipcc cmake_src_configure
+}