summaryrefslogtreecommitdiff
path: root/sci-libs/hdf5/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-14 05:44:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-14 05:44:50 +0100
commit1d18b53ed419c49eb3f71637ccd58a431c1368d4 (patch)
treeeb3671b1209855aa64534ee96262d06bcda99d74 /sci-libs/hdf5/files
parentfdca6388cf31827202fae75cae067c695bd09339 (diff)
gentoo auto-resync : 14:04:2023 - 05:44:49
Diffstat (limited to 'sci-libs/hdf5/files')
-rw-r--r--sci-libs/hdf5/files/hdf5-1.12.2-configure-clang16.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-libs/hdf5/files/hdf5-1.12.2-configure-clang16.patch b/sci-libs/hdf5/files/hdf5-1.12.2-configure-clang16.patch
new file mode 100644
index 000000000000..f341fa99ddac
--- /dev/null
+++ b/sci-libs/hdf5/files/hdf5-1.12.2-configure-clang16.patch
@@ -0,0 +1,30 @@
+https://github.com/HDFGroup/hdf5/commit/9dd36f016a4316b94f5df15856d228de01d304c6
+
+From 9dd36f016a4316b94f5df15856d228de01d304c6 Mon Sep 17 00:00:00 2001
+From: Ryan Schmidt <ryandesign@macports.org>
+Date: Thu, 17 Nov 2022 16:28:44 -0600
+Subject: [PATCH] Simplify & fix check for szlib encoder (#2263)
+
+Return the result rather than setting the exit code. "return" is a
+language keyword whereas "exit" is a function for which the <stdlib.h>
+header has to be included which it wasn't in this test, therefore the
+test would previously fail to identify that the encoder was enabled if
+"-Werror=implicit-function-declaration" was used, which it is by default
+with clang from Xcode 12 and later.
+
+Fixes #2262
+--- a/configure.ac
++++ b/configure.ac
+@@ -1737,10 +1737,7 @@ if test "x$HAVE_SZLIB" = "xyes" -a "x$HAVE_SZLIB_H" = "xyes"; then
+ #include "szlib.h"
+ ],[[
+ /* SZ_encoder_enabled returns 1 if encoder is present */
+- if(SZ_encoder_enabled() == 1)
+- exit(0);
+- else
+- exit(1);
++ return SZ_encoder_enabled() != 1;
+ ]])]
+ , [hdf5_cv_szlib_can_encode=yes], [hdf5_cv_szlib_can_encode=no],)]
+ )
+