summaryrefslogtreecommitdiff
path: root/sci-libs/hdf/files/hdf-4.2.11-fix-szip-detection.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/hdf/files/hdf-4.2.11-fix-szip-detection.patch
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/hdf/files/hdf-4.2.11-fix-szip-detection.patch')
-rw-r--r--sci-libs/hdf/files/hdf-4.2.11-fix-szip-detection.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/sci-libs/hdf/files/hdf-4.2.11-fix-szip-detection.patch b/sci-libs/hdf/files/hdf-4.2.11-fix-szip-detection.patch
new file mode 100644
index 000000000000..4486eb959b82
--- /dev/null
+++ b/sci-libs/hdf/files/hdf-4.2.11-fix-szip-detection.patch
@@ -0,0 +1,27 @@
+--- hdf-4.2.11.orig/configure.ac 2016-03-16 20:07:45.093493050 +0000
++++ hdf-4.2.11/configure.ac 2016-03-16 22:08:06.232711036 +0000
+@@ -473,12 +473,14 @@
+ yes)
+ HAVE_SZIP="yes"
+ AC_CHECK_HEADERS([szlib.h], [HAVE_SZLIB_H="yes"], [unset HAVE_SZIP])
+- if test "x$HAVE_SZLIB" = "xyes" -a "x$HAVE_SZLIB_H" = "xyes"; then
++ if test "x$HAVE_SZIP" = "xyes" -a "x$HAVE_SZLIB_H" = "xyes"; then
+ AC_CHECK_LIB([sz], [SZ_BufftoBuffCompress],, [unset HAVE_SZIP])
+ fi
+
+ if test -z "$HAVE_SZIP"; then
+ AC_MSG_ERROR([couldn't find szlib library])
++ else
++ USE_COMP_SZIP="yes"
+ fi
+ ;;
+ no)
+@@ -525,7 +527,7 @@
+ AC_CHECK_LIB([sz], [SZ_BufftoBuffCompress],, [unset HAVE_SZIP])
+ fi
+
+- if test -z "$HAVE_SZIP"; then
++ if test "x$HAVE_SZIP" != "xyes"; then
+ AC_MSG_ERROR([couldn't find szlib library])
+ else
+ USE_COMP_SZIP="yes"